Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Serial Line Problem

We have a 2Mbit leased line between two of our sites. In the last day or two we have been experiencing thousands of frame and CRC errors on one of our serial interfaces (X21). Today our leased line providers did and end to end test of the line and found no problems. The router is a 1721 with a WIC card. The router is showing no other problems. Is the WIC card likely to be the problem and apart from replacing it is there any other information I could gather from the router that would confirm this?

TIA

Daz

7 REPLIES

Re: Serial Line Problem

Hi

(1)You can check the routers back-to-back using DTE-DCE cable.This will eliminate the carrior with the modems.

(2)You can take loopbacks from your telco and then check on the router.You should be able to ping your serial ip in looped mode.(set encap to hdlc)

Hope it helps.Pls revert back if u have more questions

Regards

JD

New Member

Re: Serial Line Problem

Thanks

Problem is the sites are 80 miles apart and because we have limited connectivity, its better than none, I've already ordered a new WIC-2T because we have another leased line out to the internet, so I would need a second WIC anyway. I suppose its just reassurance that its likely to be the WIC, fingers crossed as I've just commited ?500 to it with the cables!

Gold

Re: Serial Line Problem

To a point you can confirm it is the wic by placing a loop on the circuit at the csu/dsu toward the router.

This would mean all you had was wic-cable-csu/dsu-loop

If you own the CSU/DSU you can do this with software and can place it on the data side or line side of the csu/dsu. This would help to eliminate the csu/dsu. Otherwise you can loop it with a cable. It could still be the cdu/dsu and I tend to suspect those more than wic cards.

New Member

Re: Serial Line Problem

I did originally suspect the DSU but the engineers did there end to end test from our side of the dsu's, basically connected to the x21 interface on the dsu's at either end and plugged a gadget into it that then ran for about 30 mins

Re: Serial Line Problem

Hi

I believe they have done BERT test which is standard for testing a lease-line.

I have following queries:

(1)The did a 30. min. test. What is the frequency of your errors?Are the errors comming in that time?If u do "clear counters" and check for a hr,what are the errors and CRCs comming?

Regards

JD

Silver

Re: Serial Line Problem

I suggest to have the loopback test too, it can also elimiate the cable issue. If you have spare cable, try to replace it.

New Member

Re: Serial Line Problem

Just a quick update, I have now installed the WIC-2T and new cables. I have connected both lines, one 2Mbit to internet line and one 2Mbit point to point. The internet line is showing no errors on the interface whilst the point to point is still showing thousands within seconds of clearing the counters.

Attached is the output of a sh int s0

Could someone possibly just scan my configs please just to confirm I have no major blunder in there.

This is the router with the problem:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Tockwith

!

boot-start-marker

boot-end-marker

!

enable secret 5 ************

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

no ip domain lookup

ip name-server 158.152.1.58

ip name-server 158.152.1.43

!

!

username ******* privilege 15 password 7 **********

!

!

!

!

!

interface FastEthernet0

ip address 10.106.11.1 255.255.255.0

ip nat inside

speed auto

no cdp enable

!

interface Serial0

ip unnumbered FastEthernet0

no cdp enable

!

interface Serial1

ip address xxx.xxx.xxx.xxx 255.255.255.240

ip nat outside

encapsulation ppp

!

ip nat inside source list 1 interface Serial1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Serial1 permanent

ip route 10.106.10.0 255.255.255.0 Serial0 permanent

ip http server

ip http authentication local

no ip http secure-server

!

access-list 1 remark INSIDE_IF=FastEthernet0

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.106.11.0 0.0.0.255

no cdp run

banner motd ^CC

Demon Internet Gateway

^C

!

line con 0

exec-timeout 5 0

password 7 xxxxxxxxxxxxx

line aux 0

line vty 0 4

privilege level 15

password 7 xxxxxxxxxxx

login local

transport input telnet

!

end

This is the other end of the point to point:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Eccles

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

ip domain name nowhere

!

username xxxxxx privilege 15 secret 5 xxxxxxx

!

!

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 10.106.10.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.22.16.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

ip unnumbered FastEthernet0/0

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.22.16.10

ip route 10.106.11.0 255.255.255.0 Serial0/0/0

!

ip http server

ip http authentication local

ip http timeout-policy idle 5 life 86400 requests 10000

!

no cdp run

!

control-plane

!

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

line vty 5 15

privilege level 15

login local

transport input telnet

!

end

I will do the loopback tests as soon as I can put it in loopback mode.

TIA

104
Views
0
Helpful
7
Replies
CreatePlease to create content