Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Serial tunneling

Hi all,

I'm looking for help in configuring CISCO environment.... usually rookie question :-)


We have two routers ( 2600 series, IOS 12.0(7)T ), E1 connected via PRI 2CE1U interface on both sides.  The routers are equipped with WIC-2T serial interface cards on both sides. On the first site we have real-time data source (RS232 syncro, HDLC, low speed) and there is a requisite for transfering data onto the other site. Since the sites are already connected via E1, we think it is not necessary to lease new line for this purpose. The idea is to connect source device directly to router interface WIC-2T (DTE-DCE) and receive the data on the other side. We already tried with STUN configuration, but it seems it doesn't work on our router. Didn't find in documentation for this protocol is it supported by this router ( or IOS version ). So please, any help will be appreciated. Thanks.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Green

Re: Serial tunneling

Hi,

This take me back a fair bit.(I'm getting old now)
It has been quite some time since I was involved with STUN and BSTUN
for IBM FEPS etc.

I have enclosed a couple of configs.
You will need to adjust to suit your interfaces and IP address etc

ROUTER A

!
hostname ROUTER-A
!
ip subnet-zero
no ip domain-lookup
!
!
interface loopback 100
desc *** LOOPBACK 100 FOR STUN PEERING ***
ip address 10.255.255.254 255.255.255.255
no ip red
no ip dir
!
stun peer-name 10.255.255.254
stun protocol-group 100 basic
!
!
interface Serial0/0
desc *** LINK TO ROUTER B ***
band 2048
ip address 10.255.255.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
interface Serial0/1
desc *** STUN LINK TO MY OLD BOX A - THIS IS THE DCE END ***
no ip address
no ip directed-broadcast
encapsulation stun
no ip mroute-cache
clockrate 9600
stun group 100
stun route all interface serial 0/0 direct

!
interface fast 0/0
desc *** LAN ON ROUTER A ***
ip address 10.1.1.0 255.255.255.0
!
ip route 10.255.255.253 255.255.255.255 10.255.255.2 name LOOPBACK-B
ip route 10.1.2.0 255.255.255.0 10.255.255.2 name LAN-B
!
!

ROUTER B

!
hostname ROUTER-B
!
ip subnet-zero
no ip domain-lookup
!
!
interface loopback 100
desc *** LOOPBACK 100 FOR STUN PEERING ***
ip address 10.255.255.253 255.255.255.255
no ip red
no ip dir
!
stun peer-name 10.255.255.253
stun protocol-group 100 basic
!
!
interface Serial0/0
desc *** LINK TO ROUTER A ***
band 2048
ip address 10.255.255.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
interface Serial0/1
desc *** STUN LINK TO MY OLD BOX B - THIS IS THE DCE END ***
no ip address
no ip directed-broadcast
encapsulation stun
no ip mroute-cache
clockrate 9600
stun group 100
stun route all interface serial 0/0 direct

!
interface fast 0/0
desc *** LAN ON ROUTER B ***
ip address 10.1.2.0 255.255.255.0
!
ip route 10.255.255.254 255.255.255.255 10.255.255.1 name LOOPBACK-A
ip route 10.1.1.0 255.255.255.0 10.255.255.1 name LAN-A
!
!


These should be OK for HDLC to your old kit
I have assumed the link speeds to be 9600


This is the link to the STUN commands
http://www.cisco.com/en/US/partner/docs/ios/11_0/router/command/reference/rstun.html

Good luck


HTH
Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.
12 REPLIES
Gold

Re: Serial tunneling

it can run on a 2600, heres a quick list of versions of 12.0.7  

Green

Re: Serial tunneling

Hi,

This take me back a fair bit.(I'm getting old now)
It has been quite some time since I was involved with STUN and BSTUN
for IBM FEPS etc.

I have enclosed a couple of configs.
You will need to adjust to suit your interfaces and IP address etc

ROUTER A

!
hostname ROUTER-A
!
ip subnet-zero
no ip domain-lookup
!
!
interface loopback 100
desc *** LOOPBACK 100 FOR STUN PEERING ***
ip address 10.255.255.254 255.255.255.255
no ip red
no ip dir
!
stun peer-name 10.255.255.254
stun protocol-group 100 basic
!
!
interface Serial0/0
desc *** LINK TO ROUTER B ***
band 2048
ip address 10.255.255.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
interface Serial0/1
desc *** STUN LINK TO MY OLD BOX A - THIS IS THE DCE END ***
no ip address
no ip directed-broadcast
encapsulation stun
no ip mroute-cache
clockrate 9600
stun group 100
stun route all interface serial 0/0 direct

!
interface fast 0/0
desc *** LAN ON ROUTER A ***
ip address 10.1.1.0 255.255.255.0
!
ip route 10.255.255.253 255.255.255.255 10.255.255.2 name LOOPBACK-B
ip route 10.1.2.0 255.255.255.0 10.255.255.2 name LAN-B
!
!

ROUTER B

!
hostname ROUTER-B
!
ip subnet-zero
no ip domain-lookup
!
!
interface loopback 100
desc *** LOOPBACK 100 FOR STUN PEERING ***
ip address 10.255.255.253 255.255.255.255
no ip red
no ip dir
!
stun peer-name 10.255.255.253
stun protocol-group 100 basic
!
!
interface Serial0/0
desc *** LINK TO ROUTER A ***
band 2048
ip address 10.255.255.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
interface Serial0/1
desc *** STUN LINK TO MY OLD BOX B - THIS IS THE DCE END ***
no ip address
no ip directed-broadcast
encapsulation stun
no ip mroute-cache
clockrate 9600
stun group 100
stun route all interface serial 0/0 direct

!
interface fast 0/0
desc *** LAN ON ROUTER B ***
ip address 10.1.2.0 255.255.255.0
!
ip route 10.255.255.254 255.255.255.255 10.255.255.1 name LOOPBACK-A
ip route 10.1.1.0 255.255.255.0 10.255.255.1 name LAN-A
!
!


These should be OK for HDLC to your old kit
I have assumed the link speeds to be 9600


This is the link to the STUN commands
http://www.cisco.com/en/US/partner/docs/ios/11_0/router/command/reference/rstun.html

Good luck


HTH
Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.
Community Member

Serial tunneling

Thanks.

I'll try. I have already connected and configured Serial WAN interface, your example didn't predict that... anyway, I'll post the result.

Thanks again.

Community Member

Re: Serial tunneling

Hi,

strange, but I can't enter stun peer-name command in global configuration mode on my router. This has to be basic command if I want to do anything with STUN protocol. Am I right?  Did I put the router in kind of mode that has limited features for stun commands? I asked before, should I need upgraded IOS version or my router doesn't support stun commands?

Do you have any idea?

Thanks.

Green

Re: Serial tunneling

Leo,

Can you post the show version from your router.

The command has been supported since IOS ver 10

Regards

Alex

Regards, Alex. Please rate useful posts.
Community Member

Serial tunneling

Hi,

here it is.

myrouter#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-I-M), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Tue 07-Dec-99 02:12 by phanguye

Image text-base: 0x80008088, data-base: 0x807AAF70

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

myrouter uptime is 2 weeks, 5 days, 6 hours, 28 minutes

System returned to ROM by reload

System image file is "flash:c2600-i-mz.120-7.T"

cisco 2621 (MPC860) processor (revision 0x600) with 26624K/6144K bytes of memory.

Processor board ID JAD05390352 (4105579750)

M860 processor: part number 0, mask 49

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

2 FastEthernet/IEEE 802.3 interface(s)

8 Serial network interface(s)

4 Serial(sync/async) network interface(s)

2 Channelized E1/PRI port(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Green

Re: Serial tunneling

Leo,

Although your IOS version 12.0.7T is very old.
The issue is the feature set you ar using.

You have the "IP" only featureset.

This need to be upgraded to at least an "Enterprise" or "IP-PLUS" featureset.

The problem here is that you your router is lacking in memory with
only 32M Dram & 8M Flash

I can not find a suitable IOS that will allow you to run the STUN feature
without upgeading both DRAM & FLASH to at leat least 48M DRAM & 16M FLASH

Regards
Alex

Regards, Alex. Please rate useful posts.
Community Member

Serial tunneling

Hi acampbell,

thanks for reply.

I was looking on official page and found that it is possible to find appropriate IOS for this amount of memory.

Even Enterprise feature set can be find with 8/32M.

c2600-js-mz.120-8

Where did I get wrong?

Regards,

Leo

Hall of Fame Super Gold

Serial tunneling

Leo

Perhaps you can post some of the details of what you found, especially about what Enterprise feature set is supported with 8/32 M?

I have not gone back and looked for myself, but my experience is similar to what Alex discusses - the support for STUN has been in IOS for a very long time. But it is supported only in certain feature sets - and those feature sets frequently have larger requirements for flash and memory.

HTH

Rick

Community Member

Serial tunneling

Richard,

I have no experience in configuring CISCO equipement, so I'll accept all your opinions as God's voice :-)

I found this:

http://www.cisco.com/en/US/products/sw/iosswrel/ps5014/prod_release_note09186a00800810a3.html

and it says that it is possible to upgrade my IOS version to Enterprise with 8/32M. Did I miss something?

Another question, I didn't find any document that says STUN is supported only on certain feature sets; is that kind od hidden message?

Leo

Hall of Fame Super Gold

Serial tunneling

Leo

Thank you for posting the link to the page that you are talking about. It does show that there are releases of 12.0(7)T that appear to support the Enterprise feature set and that require no more than the 8/32 that you have.  :)

So if you can find a copy of that code it may be possible to run code that does support stun on your router. My guess is that the code is old enough that it will be difficult to find it. I did check the software download page at Cisco and the oldest code that I find there is 12.2 and the versions of that code that support stun do require more than 8/32.

HTH

Rick

Community Member

Re: Serial tunneling

Hi Alex! Thanks for your config. It's very interesting. But unfortunately, it' doesn't work for me.
2 issues:
1. I can't use ip address 10.1.1.0 255.255.255.0 even when ip subnet-zero command issued. So, I migrated to ip address 10.1.1.1 255.255.255.0 (for Router A) and ip address 10.1.1.2 255.255.255.0 (Router B).
2. Host 10.255.255.253 can't be reached from A. Host 10.255.255.254 can't be reached from B.
Finally, config doesn't work.Could you please look into? Thanks!

Here are my current configs:

ROUTER A ROUTER B
hostname ROUTER-A hostname ROUTER-B
ip subnet-zero ip subnet-zero
interface loopback 100 interface loopback 100
desc *** LOOPBACK 100 FOR STUN PEERING *** desc *** LOOPBACK 100 FOR STUN PEERING ***
ip address 10.255.255.254 255.255.255.255 ip address 10.255.255.253 255.255.255.255
no ip red no ip red
no ip directed-broadcast no ip directed-broadcast
! !
stun peer-name 10.255.255.254 stun peer-name 10.255.255.253
stun protocol-group 100 basic stun protocol-group 100 basic
! !
interface Serial0/0 interface Serial0/0
desc *** LINK TO ROUTER B *** desc *** LINK TO ROUTER A ***
bandwidth 2048 bandwidth 2048
ip address 10.255.255.1 255.255.255.252 ip address 10.255.255.2 255.255.255.252
no ip directed-broadcast no ip directed-broadcast
no ip mroute-cache no ip mroute-cache
! !
interface Serial0/1 interface Serial0/1
desc *** STUN LINK TO MY OLD BOX A - THIS IS THE DCE END *** desc *** STUN LINK TO MY OLD BOX B - THIS IS THE DCE END ***
no ip address no ip address
no ip directed-broadcast no ip directed-broadcast
encapsulation stun encapsulation stun
no ip mroute-cache no ip mroute-cache
clockrate 9600 clockrate 9600
stun group 100 stun group 100
stun route all interface serial 0/0 direct stun route all interface serial 0/0 direct
! !
interface fast 0/0 interface fast 0/0
desc *** LAN ON ROUTER A *** desc *** LAN ON ROUTER B ***
ip address 10.1.1.1 255.255.255.0 ip address 10.1.1.2 255.255.255.0
! !
ip route 10.255.255.253 255.255.255.255 10.255.255.2 name LOOPBACK-B ip route 10.255.255.254 255.255.255.255 10.255.255.1 name LOOPBACK-A
ip route 10.1.1.0 255.255.255.0 10.255.255.2 name LAN-B ip route 10.1.1.0 255.255.255.0 10.255.255.1 name LAN-A
969
Views
0
Helpful
12
Replies
CreatePlease to create content