Cisco Support Community
Community Member

service policy command and QoS

When setting up a policy-map containing a class map, and then applying that policy map to either the LAN interface or WAN interface of 2 particular routers, the policy is not getting applied. I type the command in, no errors, however when looking at the interface with show run it reveals no policy map has been applied. I've successfully applied the same policy maps to 2 other routers. Both the problem routers are running IOS 12.4(11)T1

Is there possibly an IOS bug in these versions or something missing in the interface configs?

I've checked out cisco's feature navigator to explore the possibility that the different images, (c2801-ipbasek9-mz.124-11 - router with the problem and c2800nm-advipservicesk9-mz - router without the problem) are the cause, but the only unique QoS related feature on either is QoS Policy Propagation via Border Gateway Protocol (QPPB) on the Advanced IP image and QOS: DirectConnect PDLM on the standard.

I found a 3rd router with the same IOS image that does NOT have the problem. Only 2 of them seem to be exhibiting this behavior.

thank you,



Re: service policy command and QoS

Hi Bill,

If i understand clearly, the router accepts the command "ip service-policy output xxx" but doesnt show it in "sh run".

have you tried "sh policy-map interface" to see whether its really applied or not.

Community Member

Re: service policy command and QoS

that's correct. No errors, the command goes in fine, but is never actually applied to the interface. Yes, I have also used the sh policy-map int if_name command and nothing is returned.

Cisco Employee

Re: service policy command and QoS


could you provide us the configuration of the policy, class-maps and interface, where the issue occurs?

Regards, Martin

Community Member

Re: service policy command and QoS

I've tried stripping it down to its simplest form for these 2 particular routers. I have only 1 class map, and 1 policy map and have attempted binding it to several interfaces. I've repeated the process on another router with the same results. Of course however as mentioned previously it works fine on 3 other routers.

SanDiego2801#sh class-map

Class Map match-any BUSINESSCRITICAL (id 1)

Match access-group 151

Match protocol citrix

Match protocol sqlserver

Match protocol http host "timesheets"

Match protocol http host "connect"


SanDiego2801#sh policy-map



set dscp af31

Extended IP access list 151

10 permit ip any host

20 permit tcp any host eq www

30 permit tcp any host eq www

40 permit tcp any host eq www

50 permit tcp any host eq www

60 permit tcp any host eq www

SanDiego2801(config)#int fa 0/1


SanDiego2801(config-if)#service-policy input LANEDGE-MARKING&WORMTRAFFIC

SanDiego2801(config-if)#do sh run int fa 0/0

Building configuration...

Current configuration : 203 bytes


interface FastEthernet0/0

ip address

ip accounting output-packets

ip nbar protocol-discovery

ip flow ingress

ip flow egress

ip route-cache flow

speed auto



Community Member

Re: service policy command and QoS

I've looked at the logs after applying the service policy commands to an interface and on am getting traceback errors,

this is on the dallas router

*Dec 5 21:58:55.473 UTC: %ALIGN-3-TRACE: -Traceback= 0x61B56CE8 0x613A2EC8 0x613AAB70 0x613AC308 0x614855E8 0x614104AC 0x6141062C 0x6143BBBC

and this on the San Diego router <187>196: Dec 5 22:07:05: %ALIGN-3-SPURIOUS: Spurious memory access made at 0x613B303C reading 0x28 <187>197: Dec 5 22:07:05: %ALIGN-3-TRACE: -Traceback= 0x613B303C 0x613AD19C 0x613AD4F8 0x613AC8D0 0x614855E8 0x614104AC 0x6141062C 0x6143BBBC

Cisco Employee

Re: service policy command and QoS


That does not look too good. If this log entry is related to applying the service-policy command, you might have to use another IOS version to get the desired result.

Regards, Martin

作成コンテンツを作成するには してください