Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Service-policy not working fine with ATM subint

Hi

I've a C1801 with IOS C180X Software (C180X-BROADBAND-M), Version 12.4(15)T1 experiencing a problem related to Qos.

The config is attached.

As soon as the ATM come up the "service-policy output cos-po2-bhw-atm-0-1-70" statement disapper from the config under ATM0.1 pvc 8/35.

*Jan 29 17:11:18: %LINK-3-UPDOWN: Interface ATM0, changed state to up

*Jan 29 17:11:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to up

*Jan 29 17:11:24: I/f ATM0.1 VC 8/35 class cos-map-bhw-fe-ge-0.0-vo requested bandwidth 80 (kbps), available only 0 (kbps)

*Jan 29 17:11:24: Service policy detach failed

#sh run interface atM 0.1

Building configuration...

Current configuration : 193 bytes

!

interface ATM0.1 point-to-point

bandwidth 128

ip address 10.205.1.22 255.255.255.252

no ip redirects

no ip proxy-arp

no snmp trap link-status

pvc 8/35

encapsulation aal5snap

!

Any idea ?

Tks

Ric

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Service-policy not working fine with ATM subint

Hello Riccardo,

on other threads about this someone has reported that to be able to apply a CBWFQ to an ATM subinterface you need to define under the pvc some ATM Class of service

the default is an UBR (unspecified bit rate) that has no guaranteed resources.

I would try to configure some BW resources for the pvc using vbr-nrt.

Hope to help

Giuseppe

3 REPLIES
New Member

Re: Service-policy not working fine with ATM subint

here's the config

C1801

!

class-map match-any cos-map-bhw-atm-0-0-1

match access-group name cos-map-acl-bhw-fe-0.0-vo

class-map match-any cos-map-bhw-fe-ge-0.0-bu

match access-group name cos-map-acl-bhw-fe-0.0-bu

class-map match-any cos-map-bhw-fe-ge-0.0-vo

match access-group name cos-map-acl-bhw-fe-0.0-vo

class-map match-any cos-map-bhw-fe-ge-0.0-st

match access-group name cos-map-acl-bhw-fe-0.0-st

!

!

policy-map cos-po2-bhw-atm-0-1-70

class cos-map-bhw-fe-ge-0.0-vo

priority 80

police 80000 conform-action transmit exceed-action transmit violate-action transmit

class cos-map-bhw-fe-ge-0.0-st

bandwidth 8

random-detect

class cos-map-bhw-fe-ge-0.0-bu

bandwidth 20

random-detect

class class-default

policy-map cos-map-bhw-fe-ge-0.0

class cos-map-bhw-fe-ge-0.0-vo

set ip dscp af41

class cos-map-bhw-fe-ge-0.0-st

set ip dscp af31

class cos-map-bhw-fe-ge-0.0-bu

set ip dscp af21

class class-default

set ip dscp af11

!

!

!

!

!

interface FastEthernet0

description Dati

ip address 192.168.116.49 255.255.255.240

duplex auto

speed auto

service-policy input cos-map-bhw-fe-ge-0.0

!

!

interface ATM0

bandwidth 4608

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

bandwidth 128

ip address 10.205.1.22 255.255.255.252

no ip redirects

no ip proxy-arp

pvc 8/35

encapsulation aal5snap

service-policy output cos-po2-bhw-atm-0-1-70

!

!

interface Vlan1

description Voip

ip address 192.168.116.145 255.255.255.240

ip tcp adjust-mss 1452

service-policy input cos-map-bhw-fe-ge-0.0

!

!

ip access-list extended cos-map-acl-bhw-fe-0.0-bu

permit ip any 192.168.28.0 0.0.0.255

ip access-list extended cos-map-acl-bhw-fe-0.0-st

remark *** Class Stream ***

deny ip any any

ip access-list extended cos-map-acl-bhw-fe-0.0-vo

permit ip any 192.168.52.0 0.0.0.255

permit ip any 192.168.53.0 0.0.0.255

remark *** Class Voice ***

!

etc

Hall of Fame Super Silver

Re: Service-policy not working fine with ATM subint

Hello Riccardo,

on other threads about this someone has reported that to be able to apply a CBWFQ to an ATM subinterface you need to define under the pvc some ATM Class of service

the default is an UBR (unspecified bit rate) that has no guaranteed resources.

I would try to configure some BW resources for the pvc using vbr-nrt.

Hope to help

Giuseppe

New Member

Re: Service-policy not working fine with ATM subint

Ciao Giuseppe,

using cbr and/or vbr-nrt seems working...

Tks for your help

Ric

553
Views
0
Helpful
3
Replies