Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Setting up basic configs for a 2651 router and 2 x 2950 switches

I am looking for advice on the following:-

I have 1 x 2651 router and 2 x 2950 switches and I want to learn to configure them for my CCNA.

I want to set up vlans and inter vlan routing on these devices, can anyone advise me on this please.

Paul

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Setting up basic configs for a 2651 router and 2 x 2950 swit

Hello Paul,

You have not indicated how you want your devices to be interconnected, so let me just suggest an interconnection and a possible configuration to make all this run:

Sw1 (fa0/11) --- trunk --- (fa0/11) Sw2 (fa0/12) --- trunk --- (fa0/0) 2651

Configure Sw1 as follows:

hostname Sw1

no ip domain-lookup

spaning-tree mode rapid

spanning-tree portfast default

vtp domain CCNA

vtp mode server

interface FastEthernet0/11

switchport mode trunk

exit

vlan 11

name FirstVLAN

vlan 12

name SecondVLAN

vlan 999

name ManagementVLAN

interface Vlan1

shutdown

interface Vlan999

ip address 10.255.255.11 255.255.255.0

no shutdown

ip default-gateway 10.255.255.1

interface FastEthernet0/1

switchport mode access

switchport access vlan 11

interface FastEthernet0/2

switchport mode access

switchport access vlan 12

end

Configure Sw2 as follows:

hostname Sw2

no ip domain-lookup

spaning-tree mode rapid

spanning-tree portfast default

vtp domain CCNA

vtp mode client

interface FastEthernet0/11

switchport mode trunk

interface FastEthernet0/12

switchport mode trunk

spanning-tree portfast trunk

interface Vlan1

shutdown

interface Vlan999

ip address 10.255.255.12 255.255.255.0

no shutdown

ip default-gateway 10.255.255.1

interface FastEthernet0/1

switchport mode access

switchport access vlan 11

interface FastEthernet0/2

switchport mode access

switchport access vlan 12

end

Configure the router as follows:

hostname R2651

no ip domain-lookup

interface FastEthernet0/0

no shutdown

interface FastEthernet0/0.11

encapsulation dot1q 11

ip address 10.0.11.1 255.255.255.0

interface FastEthernet0/0.12

encapsulation dot1q 12

ip address 10.0.12.1 255.255.255.0

interface FastEthernet0/0.999

encapsulation dot1q 999

ip address 10.255.255.1 255.255.255.0

end

This will configure your switches into management VLAN 999, and create two other VLANs 11 and 12 with Fa0/1 being in VLAN 11 and Fa0/2 being in VLAN 12 on both switches. The router is configured with subinterfaces for all three VLANs.

It's a very quick configuration but it should work right out of the box. While I am not explaining the individual commands, you should be aware of their meaning on CCNA level - and of course, if you are unsure of anything here, feel welcome to ask further!

Best regards,

Peter

9 REPLIES
Cisco Employee

Re: Setting up basic configs for a 2651 router and 2 x 2950 swit

Hello Paul,

You have not indicated how you want your devices to be interconnected, so let me just suggest an interconnection and a possible configuration to make all this run:

Sw1 (fa0/11) --- trunk --- (fa0/11) Sw2 (fa0/12) --- trunk --- (fa0/0) 2651

Configure Sw1 as follows:

hostname Sw1

no ip domain-lookup

spaning-tree mode rapid

spanning-tree portfast default

vtp domain CCNA

vtp mode server

interface FastEthernet0/11

switchport mode trunk

exit

vlan 11

name FirstVLAN

vlan 12

name SecondVLAN

vlan 999

name ManagementVLAN

interface Vlan1

shutdown

interface Vlan999

ip address 10.255.255.11 255.255.255.0

no shutdown

ip default-gateway 10.255.255.1

interface FastEthernet0/1

switchport mode access

switchport access vlan 11

interface FastEthernet0/2

switchport mode access

switchport access vlan 12

end

Configure Sw2 as follows:

hostname Sw2

no ip domain-lookup

spaning-tree mode rapid

spanning-tree portfast default

vtp domain CCNA

vtp mode client

interface FastEthernet0/11

switchport mode trunk

interface FastEthernet0/12

switchport mode trunk

spanning-tree portfast trunk

interface Vlan1

shutdown

interface Vlan999

ip address 10.255.255.12 255.255.255.0

no shutdown

ip default-gateway 10.255.255.1

interface FastEthernet0/1

switchport mode access

switchport access vlan 11

interface FastEthernet0/2

switchport mode access

switchport access vlan 12

end

Configure the router as follows:

hostname R2651

no ip domain-lookup

interface FastEthernet0/0

no shutdown

interface FastEthernet0/0.11

encapsulation dot1q 11

ip address 10.0.11.1 255.255.255.0

interface FastEthernet0/0.12

encapsulation dot1q 12

ip address 10.0.12.1 255.255.255.0

interface FastEthernet0/0.999

encapsulation dot1q 999

ip address 10.255.255.1 255.255.255.0

end

This will configure your switches into management VLAN 999, and create two other VLANs 11 and 12 with Fa0/1 being in VLAN 11 and Fa0/2 being in VLAN 12 on both switches. The router is configured with subinterfaces for all three VLANs.

It's a very quick configuration but it should work right out of the box. While I am not explaining the individual commands, you should be aware of their meaning on CCNA level - and of course, if you are unsure of anything here, feel welcome to ask further!

Best regards,

Peter

New Member

Re: Setting up basic configs for a 2651 router and 2 x 2950 swit

Thanks Peter

It's given me a lot to think about.....much appreciated......

Paul

New Member

Setting up basic configs for a 2651 router and 2 x 2950 switches

Peter

Ive configured the switches (apart from altering the IP scheme) and am having problems with SW2, below are the details I'm seeing.......it seems to start from the spanning tree command & vtp.

Thanks for your help

Paul

Password:
SW2>en
Password:
SW2#config t
Enter configuration commands, one per line.  End with CNTL/Z.
SW2(config)#hostname SW2
SW2(config)#no ip domain-lookup
SW2(config)#spanning-tree mode rapid
                           ^
% Invalid input detected at '^' marker.

SW2(config)#spanning-tree portfast default
                           ^
% Invalid input detected at '^' marker.

SW2(config)#vtp domain CCNA
                ^
% Invalid input detected at '^' marker.

SW2(config)#vtp mode client
                ^
% Invalid input detected at '^' marker.

SW2(config)#interface FastEthernet0/11
SW2(config-if)# switchport mode trunk
SW2(config-if)#interface FastEthernet0/12
SW2(config-if)# switchport mode trunk
SW2(config-if)# spanning-tree portfast trunk
                                       ^
% Invalid input detected at '^' marker.

SW2(config-if)#interface Vlan1
SW2(config-if)# shutdown
SW2(config-if)#interface Vlan999
SW2(config-subif)# ip address 192.255.255.12 255.255.255.0
SW2(config-subif)# no shutdown
SW2(config-subif)#ip default-gateway 192.255.255.1
SW2(config)#interface FastEthernet0/1
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 11
SW2(config-if)#interface FastEthernet0/2
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 12
SW2(config-if)#end
00:31:07: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to up
00:31:07: %LINK-3-UPDOWN: Interface FastEthernet0/11, changed state to down
00:31:07: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to up
00:31:07: %LINK-3-UPDOWN: Interface FastEthernet0/12, changed state to down

Cisco Employee

Setting up basic configs for a 2651 router and 2 x 2950 switches

Hi Paul,

Can you please post the show version output from your SW2? Also, did the suggested configuration work on SW1 - was it accepted without errors?

Best regards,

Peter

New Member

Setting up basic configs for a 2651 router and 2 x 2950 switches

Peter

Sw1 went fine with no errors.  Below is Sw2 show version output.

Paul

Switch 2 - show version output

User Access Verification

Password:
SW2>en
Password:
Password:
SW2#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-C3H2S-M), Version 12.0(5.3)WC(1), MAINTENANCE INT                                                                                        ERIM SOFTWARE
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Mon 30-Apr-01 07:56 by devgoyal
Image text-base: 0x80010000, data-base: 0x8031A000

ROM: Bootstrap program is CALHOUN boot loader

SW2 uptime is 1 minute
System returned to ROM by power-on
System image file is "flash:c2950-c3h2s-mz.120-5.3.WC.1.bin"


cisco WS-C2950-24 (RC32300) processor (revision C0) with 22260K bytes of memory.
Processor board ID FOC0612W2B2
Last reset from system-reset

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
24 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:09:43:D9:51:40
Motherboard assembly number: 73-5781-09
Power supply part number: 34-0965-01
Motherboard serial number: FOC06120G3V
Power supply serial number: DAB06121ECZ
Model revision number: C0
Motherboard revision number: A0
Model number: WS-C2950-24
System serial number: FOC0612W2B2
Configuration register is 0xF

SW2#

Cisco Employee

Setting up basic configs for a 2651 router and 2 x 2950 switches

Hi Paul,

Thank you. The IOS on your SW2 is very old. You should probably replace it with the IOS running on your SW1, assuming that SW1 is of the same type as SW2. Will you be able to do it?

Best regards,

Peter

New Member

Setting up basic configs for a 2651 router and 2 x 2950 switches

Peter

I thought it would be something like this.

Can I take the IOS from Sw1 and copy it to my laptop using tftp and then copy it accross to Sw2 ?

If this is possible, can I trouble you for some advice on this?

Paul

Cisco Employee

Re: Setting up basic configs for a 2651 router and 2 x 2950 swit

Paul,

You are welcome.

With a little bit of luck, we can configure SW1 to be a TFTP server itself, and offer its IOS to SW2. This way, you can download it directly from SW1 to SW2 without an intermediate TFTP server on your PC.

Interconnect both SW1 and SW2 with a crossover cable (Fa0/1), and configure them as follows:

SW1: Before configuring, enter the dir flash: command and note or copy to the clipboard the exact name of the IOS image in the FLASH.

hostname SW1

!

interface FastEthernet0/1

switchport mode access

switchport access vlan 1

!

interface Vlan1

ip address 10.0.0.1 255.255.255.0

no shutdown

!

tftp-server flash:exact_name_of_IOS_image_in_FLASH

SW2:

hostname SW2

!

interface FastEthernet0/1

switchport mode access

switchport access vlan 1

!

interface Vlan1

ip address 10.0.0.2 255.255.255.0

no shutdown

After configuring them this way, try pinging SW1 (10.0.0.1) from SW2. If that is successful, you will need to erase your current FLASH (I do not believe it is large enough to hold both IOSes) and copy the new IOS from SW1:

erase flash:

copy tftp://10.0.0.1/exact_name_of_IOS_image_in_FLASH flash:


This should start the procedure of transferring the IOS image from SW1 to SW2. After this is completed, restart SW2.

If anything goes wrong after you've erased the FLASH on SW2, do not panic. If possible, do not unplug the switch and do not reload it. Even if you do, we can easily salvage it, just the operation will need to be performed through the COM port, and that will take much longer than through Ethernet.

Let me know.

Best regards,

Peter

Cisco Employee

Re: Setting up basic configs for a 2651 router and 2 x 2950 swit

Paul,

Contact me at Peter.Paluch@fri.uniza.sk - the instructions to do a switch recovery are better explained over e-mail.

Best regards,

Peter

681
Views
0
Helpful
9
Replies
CreatePlease to create content