Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Setting up ISDN and ADSL on same router for resilience

Hi All,

Am struggling to provide redundancy between an ADSL and an ISDN lin I am setting up for one of my clients. The scenario is that I have a Cisco 2811 router with ISDN and ADSL links on Site A. These connect to another Cisco router with ISDN (p2p) on site B and another router with ADSL terminated on site C. I have connectivity up and running between sites A and site C using ADSL. I am trying to setup the network such that if I lose connectivity via the ADSL (primary), I would like the ISDN (backup) to take over. However, I am still not able to get the traffic to go via the ISDN connection (site A to B).

I configured NAT outside on dialer interface on router on site A. Am not too sure if it is permissible to configured another NAT outside on the BRI interface of router on site A.

Can anyone advise how I can get traffic to go through the ISDN connection if I lose the ADSl link. Can I configure multiple NAT outside commands on the router on site A?

Find below sample config of the setup on the 3 routers.

Site A

interface loopback0

ip add 10.94.81.1 255.255.255.55

interface fa0/0

ip add 10.247.x.x 255.255.255.0

ip nat inside

int atm0/0/0

(usual config for ADSL)

int bri0/1/0

ip add 10.94.82.1 255.25.255.0

(usual config for ISDN)

int dialer0

ip add negotiated

ip access-group WORD in

ip nat outside

ip nat pool TRAFFIC 10.94.81.129 10.94.81.254 prefix-length 25

ip nat inside source list ABA_NAT pool TRAFFIC overload

ip access-list extended ABC_NAT

permit ip 10.247.x.x 0.0.0.255 any

Site B

interface fa0/0

ip add 10.10.10.2 255.255.255.0

ip nat inside

standby 1 ip 10.10.10.3

standby 1 priority 199

standby 1 preempt

standby 1 track 1 decrement 10

interface bri0/0/0

ip add 10.94.82.2 255.255.255.0

(usual config for ISDN)

access-list 1 permit 10.247.32.0 0.0.0.255

Site C

interface fa0/0

ip add 10.10.10.1 255.255.255.0

ip nat inside

standby 1 ip 10.10.10.3

standby 1 priority 200

standby 1 preempt

standby 1 track ATM0/0/0

interface ATM0/0/0

(usual config for ADSL)

int dialer0

ip add negotiate

ip access-group WORD in

ip nat outside

Any input would be appreciated

A

202
Views
0
Helpful
0
Replies
CreatePlease to create content