Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

settings for etherchannel

Two isp for point to point link etherchannel concept

Isp 1 has auto neigiotation seetings

Isp2 2 has full duplex and speed 100

Does this creates problem for etherchannel

Thus both isp should have same seetings such as auto

I am geeting suspended error for etherchannel

Everyone's tags (2)
8 REPLIES
Hall of Fame Super Silver

settings for etherchannel

Hello Prashant,

already answered in another thread in LAN forum

yes it can cause problems as the speed and duplex settings are not identical even if both are 100 full one is the result of negotiation and one is manually set

You have to make both links identical also for speed and duplex and you have to contact ISP tech stuff to see how to to do it.

Hope to help

Giuseppe

Community Member

settings for etherchannel

Please find attachement of my config

Community Member

Re: settings for etherchannel

Hi  Giuseppe

I am successfuly in bundling the link.But not able to obtain redudancy particular with one link only.

As I told you  there are two links eg isp1 and isp2.

If isp1 goes down there is no problem.

If isp2 goes down than entire concetivity will be lost ?

Please suggest.

Please suggest

Hall of Fame Super Silver

settings for etherchannel

Hello Prashant,

may you post the following:

a) with both link operational

show etherchannel N  detail

from both switches where N is the port channel number

b) with only one link operational  (ISP2 down)

show etherchannel N  detail

from both switches where N is the port channel number

You have to check if both links are operational on both sides according to switches

Hope to help

Giuseppe

Community Member

Re: settings for etherchannel

interface GigabitEthernet1/32

no ip address

channel-group 77 mode on

end

nihilent01#show running-config int gi2/32

Building configuration...

Current configuration : 112 bytes

!

interface GigabitEthernet2/32

description "p2p airtel 10 Mbps"

no ip address

channel-group 77 mode on

end

interface Port-channel77

ip address 192.168.2.52 255.255.255.0

77     Po77(RU)         -        Gi1/32(P)      Gi2/32(P)

---------------------------------------------------------------------------------------------------

on site 2

47     Po47(RU)         -        Gi1/0/39(P) Gi2/0/39(P)

interface GigabitEthernet1/0/39

no switchport

no ip address

channel-group 47 mode on

end

interface GigabitEthernet2/0/39

description " p2p airtel 10mbps"

no switchport

no ip address

channel-group 47 mode on

end

interface Port-channel47

no switchport

ip address 192.168.2.51 255.255.255.0

---------------------------------------------------------------------

Port-channel: Po77

------------

Age of the Port-channel   = 16d:17h:50m:40s

Logical slot/port   = 14/26          Number of ports = 2

GC                  = 0x00000000      HotStandBy port = null

Passive port list   = Gi1/32 Gi2/32

Port state          = Port-channel L3-Ag Ag-Inuse

Protocol            =    -

Fast-switchover     = disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     55     Gi1/32   On    4

  1     AA     Gi2/32   On    4

Time since last port bundled:    0d:14h:35m:40s    Gi2/32

Time since last port Un-bundled: 0d:14h:36m:07s    Gi2/32

Port-channel: Po47

------------

Age of the Port-channel   = 1d:00h:07m:28s

Logical slot/port   = 10/47          Number of ports = 2

GC                  = 0x00000000      HotStandBy port = null

Passive port list   = Gi1/0/39 Gi2/0/39

Port state          = Port-channel L3-Ag Ag-Inuse

Protocol            =    -

Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     00     Gi1/0/39 On                 0

  0     00     Gi2/0/39 On                 0

Time since last port bundled:    0d:23h:21m:24s    Gi2/0/39

Time since last port Un-bundled: 0d:23h:25m:34s    Gi1/0/39

Community Member

Re: settings for etherchannel

Hi Giuseppe ,

Today I observed a strange behaviour.

On site when 1shut down the interface gi1/32  than from site 1 i was not able to ping site2 end servers(from site 2 i didnot shutdown gi1/0/32)

But when from site 2 i was able to ping site 1 servers.strange

Than i decided to shutdown the interface gi1/32 from site 1 and gi1/0/39 from site 2 than both side were able to access the servers.And also the data was getting replicated through others isp link.Failover is taking place.

Than question

As I have two links with 20 Mbps each  so tottaly 40 MBPs.

Is it possible to load balance 20mbps data on each link.As this is L3 etherchannel how can i achieve this.

Hall of Fame Super Silver

settings for etherchannel

Hello Prashant,

without a control protocol like LACP you can face issues like the one you have described.

I know that you have already tried to use LACP with no success. I would suggest you to try again.

Load balancing will be based on  IP source address EXOR IP destination address

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/12.2_58_se/configuration/guide/swethchl.html#wp1275503

Hope to help

Giuseppe

Community Member

Re: settings for etherchannel

Thanks a lot for your guidance.

Not able to bundle using lacp.

can u explain load statement.  On one side it indicates load as 55 and AA.

And one side it indicate 00

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     55     Gi1/32   On    4

  1     AA     Gi2/32   On    4

I

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     00     Gi1/0/39 On                 0

  0     00     Gi2/0/39 On                 0

535
Views
0
Helpful
8
Replies
CreatePlease to create content