Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

setup a new config

Need help to figure out how to configure a router with two int FA0/0 and FA0/1

with GWY address 64.46.16.45

Current running config

no logging console

enable secret 5 $1$nbe3$/KUMMRlDYoG14hUK5Nc3f0

enable password 7 06025B2543400C0B4B04140708

!

clock timezone pst -8

ip subnet-zero

!

!

!

call rsvp-sync

!

!

interface FastEthernet0/0

description LAN

ip address 64.50.72.1 255.255.255.240

no ip mroute-cache

speed 10

full-duplex

!

interface FastEthernet1/0

description WAN

ip address 65.46.16.46 255.255.255.252

no ip mroute-cache

speed 10

full-duplex

!

ip default-gateway 65.46.16.46

no ip classless

no ip http server

ip pim bidir-enable

!

!

dial-peer cor custom

!

line con 0

password 7 000047020B550E1441324A420D

login

line aux 0

line vty 0

password 7 110D4D01181C0E1E4A392D282C

login

line vty 1 4

password 7 06025B2543400C0B4B04140708

login

!

end

10 REPLIES
Hall of Fame Super Silver

Re: setup a new config

Raheel

First a clarification: your explanation talks about address 64.46.16.45 but the interface in the config is ip address 65.46.16.46 255.255.255.252. Can I assume that your explanation meant 65.46.16.45 instead of 64.46.16.45?

I see that your configuration includes this:

ip default-gateway 65.46.16.46

I believe that you probably do not understand the relationship between default gateway and default route. A default gateway is used by a host (which can not route). It is possible (and sometimes beneficial) to configure ip default-gateway on a router (in fact I frequently do configure this). But we need to understand why it may be beneficial: there are some circumstances where the router may be acting as an IP host and not as a router. In particular if the router has booted into rxboot mode (usually because of some error) then it is acting as an IP host and not as a router. In that case ip default-gateway is helpful. So configuring ip default-gateway is like insurance - it is something that we may need when there is a problem. But it is not helpful in normal circumstances on a router.

What you need on the router in normal circumstances is a default route. It would be configured like this:

ip route 0.0.0.0 0.0.0.0 65.46.16.45

HTH

Rick

New Member

Re: setup a new config

I am not able to ping WAN interface which is 65.46.16.46

Any help will be highly appreciated

Hall of Fame Super Silver

Re: setup a new config

Raheel

Where are you when you attempt to ping 65.46.16.46? Are you directly connected to that interface, directly connected to some other interface, or are you remote from the router?

What is the status of the interfaces? Can you post the output of show ip interface brief?

Have you implemented the change that I gave to implement the static default route?

Can the router ping to the connected address 65.46.16.45?

HTH

Rick

New Member

Re: setup a new config

Rick sorry I confused you

As per your suggestion take out default GWY and added ip route 0.0.0.0 0.0.0.0 65.46.16.45 and it works fine.

I am able to pring and browse the internet from other interface

But some website like cnn, yahoo takes little longer time then usual?

Any suggestion

Thanks to your help.

Re: setup a new config

If you are connected to the Internet via cable/DSL then you may be running into fragmentation problems and that could be the reason for the delay accessing certain web sites. The added overhead on pppoe links may result in fragmentation issues. Try configuring 'ip tcp adjust-mss 1400' under the interface and see if that helps.

HTH

Sundar

New Member

Re: setup a new config

Hello Sundar

(config-if)#ip tcp adjust-mss 1400

^

% Invalid input detected at '^' marker.

I have these options available

(config-if)#ip tcp ?

compression-connections Maximum number of compressed connections

header-compression Enable TCP header compression

Hall of Fame Super Silver

Re: setup a new config

Raheel

I am glad that my suggestion to add the default route has gotten it to work. And I was not necessarily saying that you needed to remove the default-gateway. If the default-gateway remains in the config it will not hurt anything or prevent anything from working.

If you can get to the web sites then taking longer than usual is not likely to be an issue of routing. There are some other things that can affect performance. I note that both of the FastEthernet interfaces are configured with:

speed 10

full-duplex

the combination of 10 Mb speed with full duplex is not common. I wonder if this combination is part of the performance issue. Is there a particular reason that they are configured that way?

I believe that there are 2 aspects of this to be considered. Why specify 10 Mb? Is it that you connect to some device that is limited to 10 Mb? If so then you have little choice. But if the connected device is capable of 100 Mb and you force the connection to 10 then you are limiting the performance. The other aspect is half duplex/full duplex. Most interfaces that operate at 10 Mb operate in half duplex mode. If the device that you are connected to is limited to 10 Mb and half duplex and you configure your interface at full duplex then you are creating a problem. It is important that both devices in a connection have the same setting for duplex. If one device is set for full duplex but the other device is set for half duplex it is likely to produce performance problems (especially because the duplex mismatch is likely to produce a high number of late collisions and retransmissions of data).

So check on the connected devices and the interface settings and let us know what you find.

HTH

Rick

New Member

Re: setup a new config

Actually we upgrade one of our remote site from 3MB to 10MB thats why interface setup as 10/full instead of 100/full

and I am testing this router with the same speed dont know do I should change to 100 or leave it to 10 so I am testing and noticed browsing the internet is quite slow

Hall of Fame Super Silver

Re: setup a new config

Raheel

It matters what kind of device your router is connected to and how that device interface is configured. It does not matter, for the configuration of your interface, what the speed of the remote device is.

As I indicated there is a potential performance impact of interface speed (is it 10 or 100) and there is a potential performance impact of duplex mismatch (in fact the duplex mismatch is probably a more likely cause of poor performance than the speed is).

So can you check the device you connect to on both interfaces and how those device interfaces are set up?

HTH

Rick

New Member

Re: setup a new config

We are getting 10/Full speed from remote site

I also tried change from full to half duplex same result

130
Views
0
Helpful
10
Replies