Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

setup dhcp at switch

dear sir,

I wish to setup dhcp server at switch. Refer to below config, this is the configuration for switch. however i'm not sure of the meaning as below :-

network 165.204.184.0 255.255.255.0(How many ip address it will lease) ?

dns-server 165.204.164.235

option 150 ip 165.204.184.4 (what's the meaning of option 150 ip 165.204.184.4)?

default-router 165.204.184.99 ( it did default-router 165.204.184.99 ) ? What's the meaning?

Please advise.

Below is the sample working config.

thanks.

interface Vlan1

ip address 165.204.184.99 255.255.255.0

end

Switch#sh run | begin dhcp

ip dhcp excluded-address 165.204.184.99 165.204.184.240

ip dhcp excluded-address 165.204.184.1 165.204.184.10

!

ip dhcp pool DataVLAN

network 165.204.184.0 255.255.255.0

dns-server 165.204.164.235

option 150 ip 165.204.184.4

default-router 165.204.184.99

1 REPLY
Blue

Re: setup dhcp at switch

network 165.204.184.0 255.255.255.0(How many ip address it will lease) ?

A: this will lease 254 ip addresses in the range of 165.204.184.1 - 165.204.184.254

(be sure to examine the 'dhcp excluded-address' commands to see what addresses from the range are excluded from being handed out)

option 150 ip 165.204.184.4 (what's the meaning of option 150 ip 165.204.184.4)?

A: option 150 is used to define the TFTP server that is provided to the phones. the phones/devices then use this TFTP server to download their configuration.

default-router 165.204.184.99 ( it did default-router 165.204.184.99 ) ? What's the meaning?

A: the default-router is the gateway that all packets of unknown destination networks are forwarded too. if a router does not know of a network, it will forward the packet destined for that network to the default-Router aka default-Gateway. in your case, the default-router is the ip address of the VLAN1 interface. this would be typical for devices connected to VLAN1.

93
Views
4
Helpful
1
Replies
CreatePlease to create content