Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

sh ip igmp interface question

Dear all,

 

While troubleshooting a multicast issue, I came a across out put from sh ip igmp interface which shows IGMP querying router is 0.0.0.0.

Comparing to another with similar IOS and config, I can see what i expect to see, and that is an Ip address instead of 0.0.0.0. followed by (this system).

Election wise, this router is only one on the segment, and has lowest IP address.

 

What does 0.0.0.0 mean and if it means this system, why not consistent with other IOS for similar platform?

 

TIA

 

/Samir

  • WAN Routing and Switching
5 REPLIES
New Member

Hi Samir,If the switch is not

Hi Samir,

If the switch is not the multicast querier then it uses 0.0.0.0 as the IP source address and proxies the queries.  The switch will not use its own IP address in this case.

 

Please rate helpful posts.

Hi Jeff, That was also what I

Hi Jeff,

 

That was also what I thought, then run a short debug and noticed following on this particular node:

 

v2 querier for Vlan20 is this system

Received v2 Query on Vlan20 from 0.0.0.0

This suggests to me this node is indeed the querier. Do you agree ?

However, I don't see Send v2 general Query on Vlan20 messages. I also expect this router to show the IP address of the actual querier and not just 0.0.0.0.

 

Release notes for 12.2(40)SG running on 4500 Sup V are not showing any bugs, even cosmetic.

Any thoughts ?

/Samir

Hmmm, after a quick search I

Hmmm, after a quick search I can see few examples online which shows following:

 

IGMP querying router is 0.0.0.0 (this system)

I noticed IGMP querying

I noticed IGMP querying router is flaps between 0.0.0.0 and 192.168.10.1 ( router address on vlan20)

sh ip igmp snooping querier vlan 20 does not return any entries contrary to what I expected.

What I am troubleshooting here is group leaves which are not leaving until after 3min, this causes high BW utilisation on receiving hosts.

So far I am suspecting querier is not doing what it is supposed to.

Finally got to the bottom of

Finally got to the bottom of it.

I noticed there were other users on LAN sending trying  to act as IGMP querier despite the fact that they have higher IP addresses than actual querier.

On the other hand, I also have a L3 ACL in SVI blocking PIM messages inbound...not seen any hits here.

After adding another ACL on offending/oblivious customer facing trunk to block PIM, issue was resolved and IGMP querier shows IP address of the router itself.

Also solved by ip pim passive command.

Too many features and commands not acting as intended here.

 

/Sam

133
Views
0
Helpful
5
Replies
This widget could not be displayed.