Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SHDSL not working - 1841 HWIC-2SHDSL

Hi folks,

just configuring a Cisco 1841 router with an HWIC-2SHDSL card and I cannot get it to work, it receives no packets from the ISP, it doesn't even get PADO. The client needs this up and working by Thursday so I'm trying to fix this for Wednesday latest (with your help hopefully )

The ISP have verified the link is up with their modem and they used the same cable I used connected to the 1841. When they connected their modem I connected my laptop to it and could browse the web. All setting on the Modem were the same as the one listed below.

I have attached the running config, debugs and a bunch of show commands. As well the settings from the ISP

ISP Settings;

AMCOM

Username:yyy
Password:xxx
IP Address:X.X.X.X
Encapsulation:PPPoE
Modulation:Auto
Authentication Type:CHAP
VPI & VCI:VPI: 8 VCI: 35
DNS Server:203.161.127.1, 203.153.224.42

Any help would be fantastic!

Dave

12 REPLIES
New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Sorry some other ISP settings;

2-wire

Annex B

PPPoE

2Mbps

Re: SHDSL not working - 1841 HWIC-2SHDSL

Shouldn't be too difficult, have you tried running the ATM wizard in Cisco SDM? It's very easy and will generate the required terminal commands for you. You can download it at www.cisco.com/go/sdm

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Hi Sander,

yeah I've tried SDM, unfortunatly it doesn't allow for the configuration of an SHDSL link, only PPP over ATM. It actually states in the SDM that I need to use the CLI to configure it.

thanks anyway

Dave

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Does anyone have a configuration example of an ANNEX B 2-wire SHDSL Link with PPPoE?

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Use the right (or the other) Modem Pair,

your sh controller output indicates there is no sdsl modem connection.

Do use Cable with just the contacts connected you will use for the connection,

the others should not be connected to anything.

After establishing the sdsl connection, we may look further into PPPoE over it.

Juergen.

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

you are consuming dialer-group 1 but there ist no

dialer-list 1 ip permit

in your config.

Since there is no interesting traffic, why should it dail-in ?

Also, you may want to have

int dialer 1

dialer idle-timeout 0

dialer persistent

and

ip tcp adjust-mss 1280

on both int dialer 1 and int fas 0/0

but no ip mtu... on int fas 0/0 .

on int di 1, chap and pap passwod should be yyy and not xxx .

your surf-nat should use fas0/0, not fas 0/1 which is shutdown.

Also on modern IOS, ip nat inside source list ... works well,

no need for those route-map's from ancient IOS .

Why are you using a 1841+WIC ?

1803 has SDSL-Modem buildin, 1 real FastEthernet plus 8 switched FastEthernet Ports,

and is normally cheaper than 1841+hwic .

When you know your fixed external IP-Adress, bind it on an interface loopback 0

and use ip unnumbered loopback 0 on the dialer interface.

I have the following for PPPoEoA on 878/1803, so controller- and atm interface name may vary:

!
controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zero
! other pair: line-mode 2-wire line-one
dsl-mode shdsl symmetric annex B
line-rate auto
no shutdown
!
track 11 interface ATM0.1 line-protocol
!
bridge irb
!
vc-class atm gshdsl20v
  vbr-nrt 2240 2240 224
  oam-pvc manage
  oam retry 2 3 5
!
vc-class atm gshdsl192v
  vbr-nrt 1920 1920 192
  oam-pvc manage
  oam retry 2 3 5
!
interface ATM0
no ip address
no shutdown
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
description CPE
no shutdown
no snmp trap link-status
pvc CPE 8/35
  class-vc gshdsl20v
! or class-vc gshdsl192v
  oam-pvc manage
  encapsulation aal5snap
  pppoe max-sessions 1
  pppoe-client dial-pool-number 1
!
no cdp enable
!
interface Loopback0
description WAN
ip address X.X.X.X 255.255.255.255
no shutdown
!
interface Dialer1
description DSL Dialer
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
! probably keepalive 30
! maybe mtu 1456
! maybe ip tcp adjust-mss 1280

! and dont forget it also on LAN interface
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxx
ppp chap password yyy
ppp pap sent-username xxx password yyy
no shutdown
! place crypto map here
! perhaps ip nat outside
!
dialer-list 1 protocol ip permit
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!

! perhaps ip nat inside source list surf-nat interface Loopback0 overload
!

Hope this help's,

Juergen.

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Hi Juergen,

so I'll remove the dial-group 1, I will add the persistant commands.

I agree with you comments about the router type, however my client purchased the router and only got me involved to configure it.

thanks

Dave

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Hi Juergen,

are you saying change - dsl-group 0 pairs 0 to - dsl-group 0 pairs 1?

thanks

Dave

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Dave,

the 878/1803/hwic-2shdsl have 2 sdsl modems in front of one atm-part on the 6pin RJ12 Connector.

(The hwic-4shdsl has 2 sets of this on and 8pin RJ45/48c Connector)

If the "... pair 0" does not get a dsl connection you have a chance that the cable is for the other pair

so you may try to use ",,, pair 1" . (the last option is to bundle them)

If this does not work, you must check the cabling.

Be sure no other equipment is connected to the line (wire-pair),

esp. no telephone and no filters (or the correct ones).

In your case, other modem works on that line so this may be not the problem,

so i guess it's the pinout of the sdsl cable.

You should at least get a dsl sync like

router# sh controllers dSL 0

DSL 0 controller UP
Globespan xDSL controller chipset
Line Mode: Two Wire
DSL mode: Trained with SHDSL Annex B
Frame mode: Utopia
Configured Line rate: Auto
Line Re-activated 4 times after system bootup
LOSW Defect alarm: ACTIVE
CRC per second alarm: ACTIVE
Line termination: CPE

        Current 15 min counters
                CRC : 0 LOSW Defect : 0 ES : 0  SES : 0 UAS : 0

        Previous 15 min counters
                CRC : 0 LOSW Defect : 0 ES : 0  SES : 0 UAS : 0

        Current 24 hr counters
                CRC : 0 LOSW Defect : 0 ES : 0  SES : 0 UAS : 0

        Previous 24 hr counters
                CRC : 0 LOSW Defect : 0 ES : 0  SES : 0 UAS : 0

Line-0 status
Chipset Version:  0
Firmware Version:  R4.2.1
Modem Status:  Data, Status 1
Last Fail Mode:  No Failure status:0x0
Line rate:  2312 Kbps
Framer Sync Status: In Sync
Rcv Clock Status: In the Range
Loop Attenuation:  13.6 dB
Transmit Power:  14.5 dB
Receiver Gain:  27.420 dB
SNR Sampling:  35.6120 dB
Receive HEC Error Count:  0
Dying Gasp: Present

It takes some time for the modem to get in sync,

and setting the controller dsl to automatik will even take longer.

So check the cabling first, the dsl cable from an other modem/router's vendor may not fit

Juergen.

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Thanks Juergen,

it turned out to be that the ISP is using a Siemens DSLAM and that the WIC card doesn't support it. I've had to use the ISP modem in bridge mode, not ideal but it works.

thanks for all your help and effort!

fyi "pair 1" doesn't work, it can only be configured as "pair 0" (2-Wire) or "pair 0-1" (4-wire), I cannot configure it as "pair 1"

Dave

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

Strange, according to Cisco Documentation,

the HWIC-2SHDSL uses infineon chipset (which is "siemens semiconductor") ;

we also had never problems against Lucent or Huawai dslam's.

Also, G.SHSDL is a much better standardised than a-dsl so no interop-issues should occour.

Looks like it's some prop. sdsl flavor, not g.shdsl .

On my 1803 (and also on the HWIC-4SHDSL) i can select the line-pair:

test(config-controller)#line-mode ?
  2-wire  two-wire mode
  4-wire  four-wire mode
  auto    auto wire mode

test(config-controller)#line-mode 2-wire ?
  line-one   Line one (RJ-11 pins 3&4)
  line-zero  Line zero (RJ-11 pins 2&5)
 

test(config-controller)#line-rate ?

192   256   320   384   448   512   576   640   704   768
832   896   960   1024  1088  1152  1216  1280  1344  1408
1472  1536  1600  1664  1728  1792  1856  1920  1984  2048
2112  2176  2240  2304

  <192-2304>  SHDSL Rate in kbps (line will train at selected rate plus 8kbps of DSL framing overhead)
  auto        auto rate mode

test(config-controller)#line-term ?
  co   Central Office
  cpe  Customer Premise Equipment

test(config-controller)#dsl-mode shdsl symmetric annex ?
  A         Annex A of G.991.2 standard
  A-B       Annex A-B
  A-B-ANFP  Annex A-B-ANFP
  B         Annex B of G.991.2 standard
  B-ANFP    Annex B-ANFP

test(config-controller)#

and from 1841+HWIC-4SHDSL:

!
controller SHDSL 0/0/0
termination cpe
dsl-group 0 pairs  0
  shdsl annex B
  shdsl rate auto
!
dsl-group 1 pairs  2
  shdsl annex B
  shdsl rate auto
!
!

probably ...

conf t

controller SHDSL 0/0/0
no dsl-group 0 pairs 0

dsl-group 0 pairs 1

...

?

Jürgen.

New Member

Re: SHDSL not working - 1841 HWIC-2SHDSL

dsl-group 0 pairs 0 (is a valid command)

dsl-group 0 pairs 1 (is invalid command)

dsl-group 0 pairs 0-1 (is valid command)

rgds

Dave

2869
Views
0
Helpful
12
Replies
CreatePlease login to create content