Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

show ip bgp

Hi,

I need some light about the "show ip bgp" output in one of my router.

RT2# show ip bgp

BGP table version is 2, local router ID is 192.168.0.253

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* i192.168.0.0/20 192.168.0.252 0 100 0 i

* i 192.168.0.254 0 100 0 i

*> 192.168.0.141 20 32768 i

RT2#

192.168.0.141 is not running BGP but OSPF. Why would the "show ip bgp" choose it as best?

IOS is 12.4(10b) ADVANCED ENTERPRISE SERVICES

3 REPLIES

Re: show ip bgp

What is 192.168.0.141? Do you have a network diagram?

-John

Hall of Fame Super Blue

Re: show ip bgp

Hi Danilo

I'm not sure of your topology so i could be wrong but it looks like the route for 192.168.0.0/20 is being learnt from both EBGP and also the IGP which in your case is OSPF.

A route learned from EBGP gets a weight of 0. A route learned from the IGP gets a weight of 32768. Weight is used above all else to determine which route to insert into the routing table.

We have the same issue here where i work and we add 40000 to the EBGP learned route to ensure that is the route inserted into the routing table.

Do you have a network statement for 192.168.0.0/20 on your RT2 router.

HTH

Jon

Re: show ip bgp

Hi All,

Thanks for your replies.

Jon, your right its IGP/OSPF. When I execute "show ip bgp", I'm expecting only BGP (eBGP/iBGP) routes not EGP/IGP routes so I was surprise to see IGP/OSPF learned routes in the "show ip bgp" output. The output of "show ip bgp" in RT1 and RT3 is different though. I'm curious whether local traffic will loop as I noticed some funny bandwidth utilization in R3 interface connected to R2 and SW3. I'll post R1 and R3 output tomorrow.

I'm currently in the internet cafe now so I can't post a decent diagram.

# Connections

R1 crossed-cable to R2

R2 crossed-cable to R3

R1 GRE Tunnel to R3

SW1 patch cable to R1

SW2 patch cable to R2

SW3 patch cable to R3

SW1 crossed-cable to SW2

#Loopback0 IP Address and use

R1/loopback0(BGP/OSPF source)=192.168.0.254

R2/loopback0(BGP/OSPF source)=192.168.0.253

R3/loopback0(BGP/OSPF source)=192.168.0.252

SW1/loopback0(OSPF source)=192.168.1.254

SW2/loopback0(OSPF source)=192.168.1.253

SW3/loopback0(OSPF source)=192.168.1.252

#HSRP

HSRP between R1/R2 and SW1/SW2

R1=192.168.0.130/28

R2=192.168.0.131/28

R1/R2-VIP=192.168.0.129

SW1=192.168.0.141/28

SW2=192.168.0.142/28

SW1/SW2-VIP=192.168.0.140/28

#BGP

R1 BGP Statement

!

router bgp 65123

bgp router-id 192.168.0.254

network 192.168.0.0/20

aggregate-address 192.168.0.0 255.255.240.0 summary-only

neighbor 192.168.0.252 remote-as 65123

neighbor 192.168.0.252 description BGP with RT3

neighbor 192.168.0.252 password secret

neighbor 192.168.0.252 update-source Loopback0

neighbor 192.168.0.252 version 4

neighbor 192.168.0.252 next-hop-self

neighbor 192.168.0.252 soft-reconfiguration inbound

neighbor 192.168.0.253 remote-as 65123

neighbor 192.168.0.253 description BGP with RT2

neighbor 192.168.0.253 password secret

neighbor 192.168.0.253 update-source Loopback0

neighbor 192.168.0.253 version 4

neighbor 192.168.0.253 next-hop-self

neighbor 192.168.0.253 soft-reconfiguration inbound

-removed_external_peer_statement-

maximum-paths 2

no auto-summary

!

R2 BGP Statement

!

router bgp 65123

bgp router-id 192.168.0.253

network 192.168.0.0/20

aggregate-address 192.168.0.0 255.255.240.0 summary-only

neighbor 192.168.0.252 remote-as 65123

neighbor 192.168.0.252 description BGP with RT3

neighbor 192.168.0.252 password secret

neighbor 192.168.0.252 update-source Loopback0

neighbor 192.168.0.252 version 4

neighbor 192.168.0.252 next-hop-self

neighbor 192.168.0.252 soft-reconfiguration inbound

neighbor 192.168.0.254 remote-as 65123

neighbor 192.168.0.254 description BGP with RT1

neighbor 192.168.0.254 password secret

neighbor 192.168.0.254 update-source Loopback0

neighbor 192.168.0.254 version 4

neighbor 192.168.0.254 next-hop-self

neighbor 192.168.0.254 soft-reconfiguration inbound

-removed_external_peer_statement-

maximum-paths 2

no auto-summary

!

R3 BGP Statement

!

router bgp 65123

bgp router-id 192.168.0.252

network 192.168.0.0/20

aggregate-address 192.168.0.0 255.255.240.0 summary-only

neighbor 192.168.0.253 remote-as 65123

neighbor 192.168.0.253 description BGP with RT2

neighbor 192.168.0.253 password secret

neighbor 192.168.0.253 update-source Loopback0

neighbor 192.168.0.253 version 4

neighbor 192.168.0.253 next-hop-self

neighbor 192.168.0.253 soft-reconfiguration inbound

neighbor 192.168.0.254 remote-as 65123

neighbor 192.168.0.254 description BGP with RT1

neighbor 192.168.0.254 password secret

neighbor 192.168.0.254 update-source Loopback0

neighbor 192.168.0.254 version 4

neighbor 192.168.0.254 next-hop-self

neighbor 192.168.0.254 soft-reconfiguration inbound

-removed_external_peer_statement-

maximum-paths 2

no auto-summary

#OSPF

R1/R2/R3/SW1/SW2/SW3 OSPF

!

router ospf 65123

router-id R1_R2_R3_SW1_SW2_SW3_loppback0_ip_address

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 192.168.0.0 0.0.15.255 area 0

392
Views
0
Helpful
3
Replies
CreatePlease to create content