Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Simple BGP MED lab:why traffic does not flow via Edge2?

Hi there, I have reviewed everything possible and I still can't figure out:

I shut down interface from Edge-1 to Primary ISP router. Then from Edge-1 I ping Primary router and I was expecting to see traffic flowing thru Edge-2. That does not work though. I already reviewed route-map and prefix-list and I can't understand what is wrong.

Please find attached diagram and show run for both Edge-1 and Edge-2 routers that I configured.

5 REPLIES
New Member

Re: Simple BGP MED lab:why traffic does not flow via Edge2?

Please ignore previous files. I fixed an issue on the route-map.

Consider these ones here. Issue still persists though.

Hall of Fame Super Silver

Re: Simple BGP MED lab:why traffic does not flow via Edge2?

Hello Marlon,

link between the two edges is in another FR subinterface.

What are you shutting down to emulate the fault?

and also you need to advertise the prefixes for which you want to modify MED check they are advertised on iBGP session

also you should try to ping primary on an ip address different from wan link

Hope to help

Giuseppe

Re: Simple BGP MED lab:why traffic does not flow via Edge2?

i think i found it a bit strange

if you want to effect your traffic tward primary and back up why you use MED in out direction

this will effect the incoming traffic from primary and back up

for traffic to primary and back up

you couuse lcal prefrence, orign, as path in the inbound direction

HTH

New Member

Re: Simple BGP MED lab:why traffic does not flow via Edge2?

The purpose of the exercise is:

There are e-commerce servers (network 65.7.128.0/18) close to Edge-1 router.

For that reason Edge-1 advertises 65.7.128.0/18. Then I want to control incoming

traffic from the ISP destined to those servers by making traffic flow thru Edge-1.

I apply the same concept for the other network 197.1.1.0/24 and advertise it from

Edge-2, so that incoming traffic from ISP should be directed to Edge-2. To my understanding one way to control incoming traffic this way is MED. Let me know if I am missing something.

I will add the advertisement below on Edge-1 and Edge-2 and test it then.

!

interface Serial0/0.1 point-to-point

description Edge-1 to Edge-2

ip address 172.16.1.6 255.255.255.252

frame-relay interface-dlci 101

!

interface Serial0/0.2 point-to-point <==== I shutdown this for testing.

description Edge-1 to Primary

ip address 140.1.0.1 255.255.255.252

shutdown

frame-relay interface-dlci 102

!

router bgp 123

no synchronization

bgp log-neighbor-changes

!include this

network 172.16.1.0 mask 255.255.255.252 <=== including this on advertisement

network 140.1.0.0 mask 255.255.255.252 <====including this on advertisement

network 65.7.128.0 mask 255.255.192.0

neighbor 140.1.0.2 remote-as 145

neighbor 140.1.0.2 route-map SetMED out

neighbor 172.16.0.2 remote-as 123

neighbor 172.16.0.2 update-source Loopback0

no auto-summary

!

Re: Simple BGP MED lab:why traffic does not flow via Edge2?

ok in this case you are correct

you can MED, AS path or if you go a bit advanced you can use conditional advertisment

anyway good luck with your learning

201
Views
0
Helpful
5
Replies
CreatePlease to create content