Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Simple EIGRP and Default Route Question

I have a simple PTP "hub-and-spoke" setup and EIGRP running between four offices. I am installing addtional circuits now to connect the four to each other for redundancy. My main office provides intrenet access to the others so the branches have default routes pointing to the WAN interface they connect to at the main office.

My question is will I need to add an additonal DEFAULT ROUTE in case the path they normally take changes for internet is not accessible? EIGRP will take care of ther known routes, but not the default for internet access.

Will rate posts.

Thanks!

6 REPLIES
Hall of Fame Super Silver

Re: Simple EIGRP and Default Route Question

Michael

If I am understanding your explanation you have multiple remote sites in a hub and spoke. You are running EIGRP to advertise "interior" routes to the spokes. And each spoke has a static default route pointed to the hub. If this is correct then I believe that yes you would need an additional default route (probably a floating static default route) pointing to a neighboring spoke.

An alternative to consider would be to have the hub advertise the default route to the spokes. If the hub advertises the default to the spokes then the spokes should advertise it to each other. And if a spoke loses its connection to the hub then it should learn a default route from its spoke neighbor(s).

HTH

Rick

New Member

Re: Simple EIGRP and Default Route Question

Thanks, Rick. Yes, you are correct.

So with those two suggestions, do you have a quick sample of how to configure it the two methods you mentioned?

Thanks again.

Hall of Fame Super Silver

Re: Simple EIGRP and Default Route Question

Michael

alternative 1 floating static default route: If a spoke router has serial0/0 as the link to the hub where the default normally should be and if it has a link to another spoke for backup on serial 0/1 then your config might look something like this:

ip route 0.0.0.0 0.0.0.0 serial 0/0

ip route 0.0.0.0 0.0.0.0 serial 0/1 250

With this configuration the spoke would use the default route on serial 0/0 to the hub as its preferred default route. And if serial 0/0 goes down then the router will use the route with AD 250 on serial 0/1.

alternative 2 hub router advertises the default route: remove static default routes from the spoke routers. How you get the hub router to advertise the default depends on how the hub router is getting its default route. If the hub router has a configured static default route then you just redistribute static into EIGRP.

HTH

Rick

New Member

Re: Simple EIGRP and Default Route Question

Thanks for clearing this up Rick. I may give alternative 1 a shot.

New Member

Re: Simple EIGRP and Default Route Question

Hi mparella,

There are two ways to inject a default route into EIGRP: redistribute a static route or summarize to 0.0.0.0/0. Use the first method when you want to draw all traffic to unknown destinations to a default route at the core of the network. This method is effective for advertising connections to the Internet. For example:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet)

!

router eigrp 100

redistribute static

default-metric 10000 1 255 1 1500The static route that is redistributed into EIGRP does not have to be to network 0.0.0.0. If you use another network, you must use the ip default-network command to mark the network as a default network.

OR

Summarizing to a default route is effective only when you want to provide remote sites with a default route. Since summaries are configured per interface, you do not need to worry about using distribute-lists or other mechanisms to prevent the default route from being propagated toward the core of your network. Note that a summary to 0.0.0.0/0 overrides a default route learned from any other routing protocol. The only way to configure a default route on a router using this method is to configure a static route to 0.0.0.0/0. (Beginning in Cisco IOS Software 12.0(4)T, you can also configure an administrative distance on the end of the summary-address command, so the local summary does not override the 0.0.0.0/0 route).

router eigrp 100

network 10.0.0.0

!

interface serial 0

encapsulation frame-relay

no ip address

!

interface serial 0.1 point-to-point

ip address 10.1.1.1

frame-relay interface-dlci 10

ip summary-address eigrp 100 0.0.0.0 0.0.0.0

After the new link are in place, you can also do load balancing.

EIGRP puts up to four routes of equal cost in the routing table, which the router then load-balances. The type of load balancing (per packet or per destination) depends on the type of switching being done in the router. EIGRP, however, can also load-balance over unequal cost links.

Note: Using max-paths, you can configure EIGRP to use up to six routes of equal cost.

Let us say there are four paths to a given destination, and the metrics for these paths are:

path 1: 1100

path 2: 1100

path 3: 2000

path 4: 4000

The router, by default, places traffic on both path 1 and 2. Using EIGRP, you can use the variance command to instruct the router to also place traffic on paths 3 and 4. The variance is a multiplier: traffic will be placed on any link that has a metric less than the best path multiplied by the variance. To load balance over paths 1, 2, and 3, use variance 2, because 1100 x 2 = 2200, which is greater than the metric through path 3. Similarly, to also add path 4, issue variance 4 under the router eigrp command.

For detail visit the below link.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009437d.shtml

Kindly rate.

New Member

Re: Simple EIGRP and Default Route Question

Interesting. Thanks for your input! I'll have to review the doc and see how this will work in my network.

138
Views
8
Helpful
6
Replies
CreatePlease to create content