Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Simple PAT problem

Im using a Cisco 877 and I have one global IP address, and inside local network on 192.168.0.0. I have one machine 192.168.0.5 which is a VNC server, RDP server, and video recorder which uses a range of ports. I would like to forward all these ports to that one server and was wondering how to configure it. I also have a 10.0.5.0 subnet on the network, which needs access to the internet via the cisco 877.

Can anyone give me some advice on the best way to set it up?

8 REPLIES

Re: Simple PAT problem

First setup a NAT translation from the outside to the inside server.

ip nat inside source static tcp 192.168.0.5 3389 interface Dialer0 3389

ip nat inside source static tcp 192.168.0.5 5900 interface Dialer0 5900

Do the same for the ports for your video recorder. Add the ports to your outside ACL.

For adding the 10.0.5.0 network, just add the network to your ACL or NAT statement (depends on how it is currently configured). If you're using a different interface, don't forget to add ip nat inside under the interface.

Hope that helps.

Community Member

Re: Simple PAT problem

would my outside acl look something like this?

access-list 102 permit tcp any host wanip eq 3389.

Do I need to apply that to the interface too using access-group 102 in?

Re: Simple PAT problem

Yup, you got it!

Community Member

Re: Simple PAT problem

when I do this all outbound from 10.0.5.0 and 192.168.0.0 is blocked. How do I resolve this?

Re: Simple PAT problem

Blocked? What are you seeing in the logs?

Community Member

Re: Simple PAT problem

I must have my access lists wrong,

I have been entering access-list 101 permit tcp any host 192.168.0.5 eq 3389 which is the internal host instead of...

access-list 101 permit tcp any host dialer0 IP eq 3389

Re: Simple PAT problem

It should be the public IP address or if you get the IP dynamically, you'll have to use the any keyword again.

Community Member

Re: Simple PAT problem

This is my config . Can you have a look and tell me if it will work

155
Views
0
Helpful
8
Replies
CreatePlease to create content