cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
566
Views
0
Helpful
2
Replies

Simple QoS problem

jquintard
Level 1
Level 1

Hello,

I try to configure QoS on my router. My configuration is very simple but I have a little problem I dont understand.

First step, I use an ACL to match packets and set DSCP to af41 :

access-list 101 permit tcp any any eq 3389

access-list 101 permit tcp any any eq 22

class-map match-all MarkRDP

match access-group 101

policy-map ClassificationQoS

class MarkRDP

  set ip dscp af41

interface GigabitEthernet0/1.101

encapsulation dot1Q 101

ip address 10.10.10.1 255.255.255.0

ip nat inside

...

service-policy input ClassificationQoS

My conf is correct, it's working :

#sh policy-map interface Gi0/1.101

GigabitEthernet0/1.101

  Service-policy input: ClassificationQoS

    Class-map: MarkRDP (match-all)

      10050 packets, 825827 bytes

      5 minute offered rate 4000 bps, drop rate 0 bps

      Match: access-group 101

      QoS Set

        dscp af41

          Packets marked 7021

    Class-map: class-default (match-any)

      56700 packets, 7301625 bytes

      5 minute offered rate 43000 bps, drop rate 0 bps

      Match: any

Second step, I try to regulate the output bandwidth for af41 on Dialer0 (my ADSL link) :
class-map match-all MatchRDP
match ip dscp af41
policy-map RegulationTrafic
class MatchRDP
  bandwidth percent 5
class class-default
  fair-queue
  random-detect
  random-detect precedence 6 30 40 4
interface Dialer0
bandwidth 768
bandwidth receive 3776
ip nat outside
...
service-policy output RegulationTrafic
But that don't work, allways 0 pkts mached :
#sh policy-map interface Dialer0
Dialer0
  Service-policy output: RegulationTrafic
    Class-map: MatchRDP (match-all)
      3090 packets, 229558 bytes
      5 minute offered rate 2000 bps, drop rate 0 bps
      Match: ip dscp af41 (34)
      Queueing
        Output Queue: Conversation 267
        Bandwidth 5 (%)
        Bandwidth 38 (kbps)Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
Whhhhhhhhyyyyyy ?
Jerome
2 Replies 2

gatlin007
Level 4
Level 4

This does appear to be working.  The class map 'MatchRDP' is matching traffic as demonstrated by the 3090 packets in line 4 of the 'show policy-map interface dialer 0' output.

CBWFQ engages when there is congestion.  If there isn't any congestion the queuing counters at the bottom of the output will not increase.


Chris

Tharak Abraham
Level 3
Level 3

Is your layer 2 encap ppp ?

Could you post a sh run of the interfaces and the complete dialer config ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card