Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Simple(?) routing issue

Hi all, I have a routing problem. I can ping Lan2 from Router1, and I can ping Lan1 from Router2. Also I can ping the Serial side of Router1 from Lan2, and the Serial side of Router2 from Lan1. However I cannot ping LAN to LAN, and I cannot ping the ethernet side of Router1 from Lan2, or the ethernet side of Router2 from Lan1. This is a T1 leased line(Point to Point). Thanks for any help.

(Lan 1)

192.168.5.208

(Router 1)

192.168.5.2

192.168.4.3

(Router2)

192.168.6.2

192.168.7.2

(Lan 2)

192.168.7.208

6 REPLIES

Re: Simple(?) routing issue

Can you paste a sh ip route from either ends. Have you verified, all default gateways are properly set, as well as no ACLs of any sort configured on the router ?

Also why arent your serial interface ip's from the same subnet ..? (4.x on one end and 6.x on other end)

New Member

Re: Simple(?) routing issue

Thanks for the reply, The Serial interfaces were on the same subnet, I changed them today as something else to try. Router1 was 192.168.4.3 (which it still is) and Router2 was 192.168.4.2. Router1 is still showing Router2 as the gateway of last resort.Once again thanks.

routes are as follows.

**Router1**

C 192.168.4.0/24 is directly connected, Serial0

C 192.168.5.0/24 is directly connected, FastEthernet0

S* 0.0.0.0/0 [1/0] via 192.168.4.2

**Router2**

C 192.168.7.2 is directly connected, FastEthernet0

S 192.168.4.0/24 is directly connected, Serial1

S 192.168.5.0/24 is directly connected, Serial1

C 1.2.3.4 is directly connected, Serial0

C 192.168.6.0/24 is directly connected, Serial1

S 192.168.1.0/24 [1/0] via 192.168.7.208

S* 0.0.0.0/0 [1/0] via 1.2.3.4

I'm trying to keep the public address edited out, I hope your getting the info you need.

New Member

Re: Simple(?) routing issue

Here are the router configs, I've edited some info, as in passwords, and public addresses but the pertinent stuff is there. Thanks again.

***Router1***

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router1

!

!

ip subnet-zero

ip name-server 1.2.3.4

!

!

!

!

interface Serial0

description connected to Cisco1720

ip address 192.168.4.3 255.255.255.0

no ip directed-broadcast

no ip route-cache

service-module t1 timeslots 1-24

service-module t1 remote-alarm-enable

!

interface FastEthernet0

description LAN

ip address 192.168.5.2 255.255.255.0

no ip directed-broadcast

!

router rip

version 2

network 192.168.4.0

network 192.168.5.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.4.2

ip route 0.0.0.0 0.0.0.0 192.168.6.2

ip route 192.168.1.0 255.255.255.0 192.168.7.2

!

!

line con 0

exec-timeout 0 0

login

transport input none

line aux 0

line vty 0 4

login

!

end

***Router2***

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router2

!

logging buffered 4096 debugging

!

ip subnet-zero

no ip finger

ip name-server 1.2.3.4

!

!

!

!

interface Serial0

description Internet T1

ip address 1.2.3.4 255.255.255.252

no ip directed-broadcast

no ip route-cache

no fair-queue

service-module t1 timeslots 1-24

!

interface Serial1

description point to point

ip address 192.168.6.2 255.255.255.0

no ip directed-broadcast

service-module t1 clock source internal

service-module t1 timeslots 1-24

!

interface FastEthernet0

description LAN

ip address 192.168.7.2 255.255.255.0

no ip directed-broadcast

!

router rip

version 2

passive-interface Serial0

network 192.168.7.0

network 192.168.6.0

no auto-summary

!

ip classless

ip route 192.168.4.0 255.255.255.0 Serial1

ip route 192.168.5.0 255.255.255.0 Serial1

ip http server

ip http access-class 1

!

!

line con 0

transport input none

line aux 0

line vty 0 4

access-class 1 in

login

!

end

Re: Simple(?) routing issue

When you connect two routers via a leased line, that segment needs to be in the same subnet. Your router 1's serial is 192.168.4.3 while your router 2's serial is 192.168.6.2. Change one of the sides to belong to the same subnet (Say change 192.168.6.2 to 192.168.4.2)

HTH

Re: Simple(?) routing issue

You have a lot of routes messed up which needs to be fixed.

First things first - Is router 1's serial 0 connected to router 2's serial 1 ? Your routing table seem to indicate that.

Remove the following routes from Router 1:

no ip route 0.0.0.0 0.0.0.0 192.168.6.2

no ip route 192.168.1.0 255.255.255.0 192.168.7.2 (I dont see a 192.168.1.0 in your router, remove this route, unless you need it)

On Router 2 which has serial connection to Internet, Remove the following router.

no ip route 192.168.4.0 255.255.255.0 Serial1

and Add the following routes to the Router 2.

ip route 192.168.5.0 255.255.255.0 serial 1

ip route 0.0.0.0 0.0.0.0 serial 0 --> default route to Internet.

This should work.

HTH

New Member

Re: Simple(?) routing issue

Thanks, I'll try your suggestions right now.

108
Views
0
Helpful
6
Replies