Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Simple serial config on 1721 router

i have a t1 router, i am trying to only use the 1 ip address on the either the serial or fastethernet interface. If i put the ip on the serial interface i can ping something ont he internet but if i put it ont he f0 interface i can't ping it. I thought if i only put the ip address on the f0 interface it would work. could someone please take a look at this and tell me what going on wrong. thanks

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Exp_T1_2

!

boot-start-marker

boot-end-marker

!

enable password 7 xxxxxxxxxxxxx

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

ip address 207.54.xx.xx 255.255.255.240

speed auto

!

interface Serial0

no ip address

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no fair-queue

service-module t1 timeslots 1-24

!

ip classless

ip route 0.0.0.0 0.0.0.0 207.54.x.x

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 7 xxxxxxxxxxxx

login

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Simple serial config on 1721 router

Darren

I see the issue and it is the configuration of your default route:

ip route 0.0.0.0 0.0.0.0 207.54.xx.xx

Since the 207.54 is on the FastEthernet the router is attempting to go through that interface as the default. It should work if you do this:

ip route 0.0.0.0 0.0.0.0 serial0

That should take care of the default route and being able to ping the default gateway from the router.

As I think about it I wonder if this is what your provider had in mind when they gave you that IP address. With the router configured this way there would be PCs on the FastEthernet who will have addresses in that subnet. Is the provider expecting to see multiple addresses in that subnet coming from your router? I do not know what service you contracted with them or what their expectations are. But I wonder if a more appropriate solution might be the suggestion that I made to configure private addressing on the FastEthernet and to configure address translation.

HTH

Rick

6 REPLIES
Hall of Fame Super Silver

Re: Simple serial config on 1721 router

Darren

One of the basic principles of IOS routers is that an interface that does not have an IP address will not forward IP packets at layer 3. So your basic problem here is that if you put the IP address on the FastEthernet then the serial interface does not have an IP address and will not forward IP packets.

I believe that there are a couple of alternatives which might work for you - depending on what your provider will support.

- one alternative is to configure the serial interface with ip unnumbered FastEthernet0. This is a legitimate configuration within IOS and allows both the serial interface and the FastEthernet interface to use the same address. It would depend on your provider supporting this.

- another alternative would be to put the provider supplied (public) address on the serial interface, configure private address (perhaps 192.168.0.0) on the FastEthernet interface and configure address translation so that the private addresses get translated into the public address as they go to the provider.

- and of course the most simple alternative would be to ask the provider for another IP address.

HTH

Rick

New Member

Re: Simple serial config on 1721 router

thanks for the info, here is the issue i come up with when i do this.

i give the ip to the serial 0 interface, i go into the fastethernet 0 interface and i issue the command on int fastethernet 0

ip unnumbered serial 0

or

ip unnubererd fastethernet 0

Point-to-point (non-multi-access) interfaces only

so here is my config right now

interface FastEthernet0

no ip address

speed auto

!

interface Serial0

ip address 207.54.xx.xx 255.255.255.240

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no fair-queue

service-module t1 timeslots 1-24

Hall of Fame Super Silver

Re: Simple serial config on 1721 router

Darren

ip unnumbered can only be configured on point to point connections (and in very recent versions of IOS on VLAN subinterfaces). So you can not configure the FastEthernet as ip unnumbered. As I suggested in my first post, leave the IP address configured on FastEthernet and configure the serial with ip unnumbered fastethernet0.

HTH

Rick

New Member

Re: Simple serial config on 1721 router

ok here is my current config, i changed it up the way you suggested. now i can't ping my default gateway. just wonderign if i did it the right way?

!

hostname Exp_T1_2

!

boot-start-marker

boot-end-marker

!

enable password 7 050F051B334D405F4E

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

ip address 207.54.xx.xx 255.255.255.240

speed auto

!

interface Serial0

ip unnumbered FastEthernet0

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no fair-queue

service-module t1 timeslots 1-24

!

ip classless

ip route 0.0.0.0 0.0.0.0 207.54.xx.xx

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 7 045F08121D2042185E

login

!

end

Hall of Fame Super Silver

Re: Simple serial config on 1721 router

Darren

I see the issue and it is the configuration of your default route:

ip route 0.0.0.0 0.0.0.0 207.54.xx.xx

Since the 207.54 is on the FastEthernet the router is attempting to go through that interface as the default. It should work if you do this:

ip route 0.0.0.0 0.0.0.0 serial0

That should take care of the default route and being able to ping the default gateway from the router.

As I think about it I wonder if this is what your provider had in mind when they gave you that IP address. With the router configured this way there would be PCs on the FastEthernet who will have addresses in that subnet. Is the provider expecting to see multiple addresses in that subnet coming from your router? I do not know what service you contracted with them or what their expectations are. But I wonder if a more appropriate solution might be the suggestion that I made to configure private addressing on the FastEthernet and to configure address translation.

HTH

Rick

New Member

Re: Simple serial config on 1721 router

thanks, that was it.

actually i needed it like for a reason. i have an asa behind the router with an address of 207.54.xx.xx+1 that vpns connect to, also i wanted it like this to be able to use the blocks of ip to use as NAT addresses for vairous things we have

207
Views
0
Helpful
6
Replies