Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Site to Site VLAN setup

Good Afternoon,

The following has been racking my brain for hours now but I have been unable to configure my switches to do complete the following scenario:

Site A

- Will have 1 3560 Switch that end users will plug into

- In addition there exists 4 3COM switches at this site that will have to plug into the C3560 switch

- the current network for it is 172.16.9.0

- there is no DHCP server at this site now but there will be one

- it will connect to Site B via dark fiber

- Site B houses the new switch 3560 Gig Switch

- this site has a DHCP server that is providing IP addresses for 172.16.9.0 network (via a helper addresses on the existing router, etc)

- dark fiber will eliminate router scenario and helper address, etc

- Trunking is not needed since everything is through a SM fiber connection

Can someone please tell me how I should go about creating a config file for these two switches?

Here is what I have been thinking of to get them to communicate

Essentially Site A's network will come into Site B's network via a VLAN and then it will be routed out a router on Site B's.

Can someone give me some guidance here. I know what I want to do but, I can not get the verbose down on paper.

Thank you very much for all of your help!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Site to Site VLAN setup

If Site_B switch currently does not have 'interface vlan 2' configured, users at site_B quite likely use router at that site as default gateway. If users/servers at site_B and site_A need to communicate with each other and also access the internet, you'll also need to set appropriate routes:

on the switch at site_B:

ip route 0.0.0.0 0.0.0.0

on the router:

ip route 172.16.9.0 255.255.255.0

12 REPLIES
Hall of Fame Super Bronze

Re: Site to Site VLAN setup

Configure the fiber connection as an access port on both switch A and B and they should be able to see each just like they were connected on the same wiring closet.

New Member

Re: Site to Site VLAN setup

because I do not want to do this in a prod environment, I connected two ethernet ports (GiEth0/23) from Switch A and B together. I added Switch A's GigEth port to VLAN 3 on Switch B. Is this the correct thing to do and would this work if this was the fiber connection?

In addition, how do I route the traffic from Switch A to Switch B that is connected to a router. Please note that Switch A's network will be different from Switch B's network. Essentially I need to set up two VLAN's on Switch B. One to handle local traffic coming into switch and the other to handle traffic across the access port from Switch A.

Your help is appreciated and very valuable. Thank you very much.

Hall of Fame Super Bronze

Re: Site to Site VLAN setup

In your initial post you mentioned that everything would be on a single VLAN. If you are having multiple VLANs, I suggest you configure the Fiber connection as a trunk port.

If you are planning to route between the VLANs, you need to create a SVI on either switch and change the clients default gateway to that SVI.

New Member

Re: Site to Site VLAN setup

Edison,

Do you think that you can provide me with a dummy config to point me in the right direction?

Hall of Fame Super Bronze

Re: Site to Site VLAN setup

See attachment, let me know if it helps.

I have a hard time understanding what you really want.

New Member

Re: Site to Site VLAN setup

EdisonOrtiz,

This is exactly it except that site B will route/handle traffic for 172.16.9.0 and 172.16.8.0 all to be forwarded out to the router (just as your picture states). I imagine Site B (Switch B) will need to be VLAN'd like the following VLAN 2 = 172.16.9.0 and VLAN 3 = 172.16.8.0. How do I express this in a configuration file that will work on the switch?

Does this make sense now?

Hall of Fame Super Bronze

Re: Site to Site VLAN setup

Yes, it does make sense now that you mentioned another subnet (172.16.8.0/24).

172.16.9.0 /24 will be Site A

172.16.8.0 /24 will be Site B

On the Site A switch you would configure VLAN 2 on layer 2 with the following commands:

vlan 2

name 172.16.9.0_VLAN

exit

and the ports will have the following:

switchport mode access

switchport access vlan 2

spanning-tree portfast (except on the fiber port to switch A)

On switch B you need the following commands:

vlan 2

name 172.16.9.0_VLAN

vlan 3

name 172.16.8.0_VLAN

exit

switchport mode access

switchport access vlan 3

spanning-tree portfast

On the fiber port connected to switch A

switchport mode access

switchport access vlan 2

Configuring the SVI on Site B:

interface vlan 2

ip address 172.16.9.x 255.255.255.0

ip helper-address 172.16.8.x

interface vlan 3

ip address 172.16.8.x 255.255.255.0

Please rate helpful posts.

Re: Site to Site VLAN setup

If Site_B switch currently does not have 'interface vlan 2' configured, users at site_B quite likely use router at that site as default gateway. If users/servers at site_B and site_A need to communicate with each other and also access the internet, you'll also need to set appropriate routes:

on the switch at site_B:

ip route 0.0.0.0 0.0.0.0

on the router:

ip route 172.16.9.0 255.255.255.0

New Member

Re: Site to Site VLAN setup

ilya,

After looking at the configuration that Edison posted (and a great config by all means), your aforementioned statement is needed as well. Packets would not know how to get out unless you set up a route for them.

Thank you very much. You guys have been extremely helpful and its great to know that my thoughts even though I could not lay out the syntax was right alongside the way you guys think.

Thank you again.

New Member

Re: Site to Site VLAN setup

Just one more last question, if you guys do not mind. How do I test this with the fiber connection. Is it just as simple as:

- configuring both ports Gi0/10 on both switches to join VLAN 2

- connect a laptop to both switches and determine if they see each other.

Is this correct? Please advise as to the proper way to test. Thanks guys.

Hall of Fame Super Bronze

Re: Site to Site VLAN setup

Yes, 'show cdp neighbors' should provide layer 2 visibility between switches.

New Member

Re: Site to Site VLAN setup

In addition:

- i placed two laptops on either switch

- placed them both in the same VLAN (vlan2)

- provided them both with static IP's

- and I was able to successfully ping each other

Thanks guys.

260
Views
17
Helpful
12
Replies
CreatePlease login to create content