Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Slow speed when connecting router and switch to cable modem

Hello

I am fairly new to cisco gear.

I am getting extremely slow internet speeds when I try using my router and switch.

This is how I have it configured.

Cable modem is plugged into Gi0/0 of router (1941)

Switch (48Port 3560 PoE) is plugged into Gi0/1

Gi0/0 is set to pull an address from modem (DHCP)

Gi0/1 has an ip address of x.x.x.1 assigned to it

Router is acting as DHCP for network

Switch has one vlan x.x.x.3

I am also using an Air Port Extreme configured as an Wireless Access Point.

If I connect to the wireless or straight to a port on the switch I feel like I am back in the days of 56K modems.

 

If I go from the modem straight to a wireless router I get around 21 Down/12 Up

 

Thanks for you help

Mike

Everyone's tags (1)
3 REPLIES

Hi, Have you done following

Hi,

 Have you done following this on your cisco router 

1) DHCP pool configured for LAN Subnet is defined with Proper DNS provided by your service provider 

2) cisco router is configured with Proper PAT towards Gi0/0 with LAN subnets x.x.x.x/24 .

3)  Any traffic goes out from router must be NATED , if you dont want to do NATing .In this you case your modem must have reverse route of your LAN subnet x.x.x.x/24 pointing to WAN Interface IP address of your router 

 

Share me IPconfig/all connecting directly to your modem & IP config/all directly connecting to LAN switch . 

HTH

Sandy

New Member

Here is the config of the

Here is the config of the router.

 


Current configuration : 1571 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 1941RT
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 /sZEgK86jBjVXzoruM2Z28WmHDqHI9MhmweSfguco3U
!
no aaa new-model
!
ip cef
!
!
!
ip dhcp excluded-address 172.20.20.1 172.20.20.20
!
ip dhcp pool DATA
 import all
 network 172.20.20.0 255.255.255.0
 default-router 172.20.20.1
 dns-server 75.75.75.75 75.75.75.76
!
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941/K9 sn FTX1726804V
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.20.20.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat source list 101 interface GigabitEthernet0/0 overload
ip nat inside source list 101 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 98.224.43.228
!
access-list 101 permit ip any any
access-list 101 permit ip 172.20.20.0 0.0.0.255 any
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
!
end

 

 

 

New Member

Output of ipconfig /all from

Output of ipconfig /all from PC when plugged into modem.

 


Windows IP Configuration

   Host Name . . . . . . . . . . . . : Mike-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : hsd1.fl.comcast.net.

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : hsd1.fl.comcast.net.
   Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controlle
r
   Physical Address. . . . . . . . . : 00-19-B9-75-72-6B
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 67.190.198.114(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.248.0
   Lease Obtained. . . . . . . . . . : Wednesday, June 11, 2014 11:00:07 PM
   Lease Expires . . . . . . . . . . : Thursday, June 12, 2014 12:00:07 AM
   Default Gateway . . . . . . . . . : 67.190.192.1
   DHCP Server . . . . . . . . . . . : 76.96.92.132
   DNS Servers . . . . . . . . . . . : 75.75.75.75
                                       75.75.76.76
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.hsd1.fl.comcast.net.:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : hsd1.fl.comcast.net.
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6abd:1019:2e4c:bc41:398d(Pref
erred)
   Link-local IPv6 Address . . . . . : fe80::1019:2e4c:bc41:398d%13(Preferred)
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter 6TO4 Adapter:

   Connection-specific DNS Suffix  . : hsd1.fl.comcast.net.
   Description . . . . . . . . . . . : Microsoft 6to4 Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2002:43be:c672::43be:c672(Preferred)
   Default Gateway . . . . . . . . . : 2002:c058:6301::
   DNS Servers . . . . . . . . . . . : 75.75.75.75
                                       75.75.76.76
   NetBIOS over Tcpip. . . . . . . . : Disabled

21
Views
0
Helpful
3
Replies