Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Small Site Multihoming

Hello,

I'm trying to make multihoming on cisco 892 router.

I Managed to build configuration which works as I wanted but I ran into problem which I can't solve till now.

I'm trying to do port forwarding on cisco with 2 working WAN interfaces.

Configuration:

interface FastEthernet8

description ISP_B

ip address 192.168.150.10 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex full

speed auto

!       

!        

interface GigabitEthernet0

description ISP_A

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!       

!        

interface Vlan1

ip address 192.168.100.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!       

!        

ip forward-protocol nd

no ip http server

no ip http secure-server

!        

!        

ip nat inside source route-map ISP_A interface GigabitEthernet0 overload

ip nat inside source route-map ISP_B interface FastEthernet8 overload

ip nat inside source static tcp 192.168.100.100 22 19.168.150.10 65022 route-map ISP_B extendable

ip nat inside source static tcp 192.168.100.100 80 192.168.0.199 80 route-map ISP_A extendable

ip nat inside source static tcp 192.168.100.100 22 192.168.0.199 65022 route-map ISP_A extendable

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 192.168.0.1 10

ip route 0.0.0.0 0.0.0.0 FastEthernet8 192.168.150.1 251

!

route-map ISP_A permit 10

match interface GigabitEthernet0

set interface GigabitEthernet0

!        

route-map ISP_B permit 10

match interface FastEthernet8

set interface FastEthernet8

Interface gig0 have IP 192.168.0.199 in my lab environment.

Problem is with when I'm using gig0 as gateway of last resort all packets which arrive by fe8 interface are sent by gig0 interface and I can't access any devices by second link.

I was trying to use different approaches to force that traffic to come back on same interface by which it came in but up till now I haven't got any luck with that.

Have anybody done such a thing in past or is this even possible?

Everyone's tags (3)
1 REPLY
New Member

Small Site Multihoming

Hello,

Any Ideas at all?

400
Views
0
Helpful
1
Replies
CreatePlease to create content