Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Snmp Issue

Hi ALL:

I am having some issue with my snmp configuration on 2960.

I have a third party NMS tool which provide me all the network information through SNMp.

But once my switch get reload i do not see the device up in my NMS tool .

I have to remove the SNMP configuration from the switch and put it back and it works.If the remove the device from the NMS tool and add it did not work.

I did debug on the switch when the switch come up my snmp is active .

Any idea why ?

c2960-lanbase-mz.122-35.SE5.bin----IOS

Debug SNMP LOGS

Jul 9 17:59:33.992: SNMP: Packet received via UDP from x.x.x.x--NMS IP

.Jul 9 17:59:33.996: SNMP: Get request, reqid 13720652, errstat 0, erridx 0

lsystem.58.0 = NULL TYPE/VALUE

cisco.5.1.1.8.0 = NULL TYPE/VALUE

.Jul 9 17:59:34.004: SNMP: Response, reqid 13720652, errstat 0, erridx 0

lsystem.58.0 = NO_SUCH_OBJECT_EXCEPTION

cisco.5.1.1.8.0 = NO_SUCH_OBJECT_EXCEPTION

.Jul 9 17:59:34.020: SNMP: Packet received via UDP from x.x.x.x

.Jul 9 17:59:34.020: SNMP: Packet sent via UDP to 172.25.xx.xx

.Jul 9 17:59:34.024: SNMP: Get request, reqid 13720654, errstat 0, erridx 0

ciscoMemoryPoolEntry.5.1 = NULL TYPE/VALUE

ciscoMemoryPoolEntry.5.1 = NULL TYPE/VALUE

ciscoMemoryPoolEntry.6.1 = NULL TYPE/VALUE

.Jul 9 17:59:34.040: SNMP: Response, reqid 13720654, errstat 0, erridx 0

ciscoMemoryPoolEntry.5.1 = NO_SUCH_OBJECT_EXCEPTION

ciscoMemoryPoolEntry.5.1 = NO_SUCH_OBJECT_EXCEPTION

ciscoMemoryPoolEntry.6.1 = NO_SUCH_OBJECT_EXCEPTION

TEST#sh snmp gr | b v3

groupname: snmpv3group security model:v3 auth

readview :<no readview specified> writeview: <no writeview specified>

notifyview: *tv.FFFFFFFF.FFFFFFFF.FFF

row status: active

Configuration SNMP:

snmp-server user username test v3 auth md5 authpassword

snmp-server host xx.xx.xx.xx traps version 3 auth test

snmp-server group test v3 auth

Chao

Vishwa

4 REPLIES
New Member

Re: Snmp Issue

Any suggestions guys.

Chao

Vishwa

Re: Snmp Issue

It sounds like a bug, although of the 52 SNMP-related bugs, reported by the Bug Toolkit, none seems to apply to your case.

Try upgrading the switch to a more recent IOS version to see if the problem stops occurring.

New Member

Re: Snmp Issue

Hi Ran,

There is no change after the upgrade i have tried with many version.

Chao

Vishwa

Re: Snmp Issue

Is the SNMPv3 user password encrypted on the configuration? If so, there may be a bug when the router is not able, after the reload, to correctly read/decrypt the encrypted MD5 password. That may account for the SNMP to start work as soon as you reconfigure the SNMP password.

I don't recall if you can configure a clear-text SNMP password. If you can, then try configuring the password in clear-text.

You can also give it a shot with SNMPv2.

Good luck.

698
Views
0
Helpful
4
Replies