Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Solution for a routing topology with 8x Cisco 2811

I want to make a real lab topology to compare different routing protocols with maximum 4 routing interfaces per router. The problem is that i have 8x Cisco 2811 routers, each has only 2 x routing interfaces + 8 x feSW interfaces.  

I tried to resolve this as fallows: use 2 x 2811 router for equivalent of one router with 4 routing interfaces (I connected the two routers between them by SW interfaces) (see attachment)

I configured EIGRP and I can`t ping between any two LANs connected to cisco 2811 routers. (EIGRP updates can`t be propagated between the two LANs connected to 2 different routers)

Is there any solution to resolve this VLANs or something like this) or to make a topology with the purpose of comparing RIP, EIGRP and OSPF on a platform with 8 x Cisco 2811 routers?

Sorry for my poor english!

1 ACCEPTED SOLUTION

Accepted Solutions

Sorry, but i can't open

Sorry, but i can't open packet tracer. Also your diagram doesn't says which router is R4, R5, R6 or R7. But below is what i understood:

SW interfaces will be in VLAN1 by default, as you have not defined any other Vlans.

Sso if you try to make connection via SW interfaces, then you need to define IPs on vlan 1 and make the subnet in eigrp. In real world it will be simmiler to a Routering Interfaces and reffered as SVI.

For example, if you have two router and they are connected via SW interfaces as:

R1-Fa0/1/0 ---- R2-Fa0/1/0

Then on R1

!

vlan 10

 name L3-SVI-10

!

Int vlan 10

 ip add 192.168.1.1 255.255.255.0

!

Interface fa0/1/0

 switchport mode access

 switchport access vlan 10

!

router eigrp

 network 192.168.1.0

 no auto-summary

end

!

======================================

and on R2

!

vlan 10

name L3-SVI-10

!

Int vlan 10

ip add 192.168.1.2 255.255.255.0

!

Interface fa0/1/0

switchport mode access

switchport access vlan 10

!

router eigrp

network 192.168.1.0

 no auto-summary

end

!

4 REPLIES

Can you share the configs ?

Can you share the configs ?

 Basically, the problem i had

 

Basically, the problem i had illustrated in packet tracer in the attachment. 

 

R7

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 1

network 192.168.1.0

auto-summary

 

 

R4

 

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1/0

switchport mode access

!

interface FastEthernet0/1/1

switchport mode access

!

interface FastEthernet0/1/2

switchport mode access

shutdown

!

interface FastEthernet0/1/3

switchport mode access

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 1

network 192.168.1.0

network 192.168.2.0

auto-summary

!

 

 

R5

 

interface FastEthernet0/0

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1/0

switchport mode access

!

interface FastEthernet0/1/1

switchport mode access

!

interface FastEthernet0/1/2

switchport mode access

shutdown

!

interface FastEthernet0/1/3

switchport mode access

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 1

network 192.168.1.0

network 192.168.2.0

auto-summary

 

 

R6

 

 

interface FastEthernet0/0

ip address 192.168.2.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 1

network 192.168.2.0

auto-summary

 

 

Sorry, but i can't open

Sorry, but i can't open packet tracer. Also your diagram doesn't says which router is R4, R5, R6 or R7. But below is what i understood:

SW interfaces will be in VLAN1 by default, as you have not defined any other Vlans.

Sso if you try to make connection via SW interfaces, then you need to define IPs on vlan 1 and make the subnet in eigrp. In real world it will be simmiler to a Routering Interfaces and reffered as SVI.

For example, if you have two router and they are connected via SW interfaces as:

R1-Fa0/1/0 ---- R2-Fa0/1/0

Then on R1

!

vlan 10

 name L3-SVI-10

!

Int vlan 10

 ip add 192.168.1.1 255.255.255.0

!

Interface fa0/1/0

 switchport mode access

 switchport access vlan 10

!

router eigrp

 network 192.168.1.0

 no auto-summary

end

!

======================================

and on R2

!

vlan 10

name L3-SVI-10

!

Int vlan 10

ip add 192.168.1.2 255.255.255.0

!

Interface fa0/1/0

switchport mode access

switchport access vlan 10

!

router eigrp

network 192.168.1.0

 no auto-summary

end

!

New Member

Plz disable auto summary of

Plz disable auto summary of Eigrp

97
Views
20
Helpful
4
Replies
CreatePlease to create content