Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SR520-ADSLi issue

Hi,

i want to ask about my Cisco SR520-ADSLi router problem.

I need only a basic configuration for PPPoA ADSL with NAT.

- DSL connection is established sucessfuly (i have a IP address from ISP, atm interface is up, protocol is up) - i can ping from router to any web sites wiht no poroblems.

- I can ping router inside interface 172.21.4.33 from my local pc with no problems (DHCP give me ip, gateway....).

But i cant do a ping or access to internet from my local PC. Maybe a problem with NAT or routing?

Can sameone help where is the problem?

Many thanks.

Here is configuration of SR520:

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CnT

!

boot-start-marker

boot-end-marker

!

logging count

logging message-counter syslog

logging buffered 4096

no logging console

no logging monitor

enable secret .............

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-1290105854

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1290105854

revocation-check none

rsakeypair TP-self-signed-1290105854

!

!

crypto pki certificate chain TP-self-signed-1290105854

certificate self-signed 01

.

.

.

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 172.21.4.33 172.21.4.42

!

ip dhcp pool inside

import all

network 172.21.4.32 255.255.255.224

default-router 172.21.4.33

domain-name ex.com

dns-server 195.146.132.59 195.168.1.2

!

!

ip cef

ip domain name express.sk

ip name-server 195.146.128.60

ip name-server 195.146.132.59

!

no ipv6 cef

multilink bundle-name authenticated

!

!

username <username> privilege 15 secret 5 <password>

!

!

!

archive

log config

hidekeys

!

!

!

class-map type inspect match-all sdm-invalid-src

match access-group 100

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description WAN via ADSL

pvc 1/32

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

switchport access vlan 75

!

interface FastEthernet1

switchport access vlan 75

!

interface FastEthernet2

switchport access vlan 75

!

interface FastEthernet3

switchport access vlan 75

!

interface Vlan1

no ip address

shutdown

!

interface Vlan75

description $FW_INSIDE$

ip address 172.21.4.33 255.255.255.224

ip access-group 105 in

ip nat inside

ip virtual-reassembly

!

interface Dialer0

description $FW_OUTSIDE$

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname <hostname>

ppp chap password <password>

ppp pap sent-username <hostname> password <password>

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 101 interface Dialer0 overload

!

logging trap debugging

access-list 100 remark SDM_ACL Category=128

access-list 100 permit ip host 255.255.255.255 any

access-list 100 permit ip 127.0.0.0 0.255.255.255 any

access-list 100 permit ip any any

access-list 101 remark NAT

access-list 101 permit ip 172.21.4.32 0.0.0.31 any log

access-list 101 permit icmp 172.21.4.32 0.0.0.31 any log

access-list 105 remark Inside_To_Outside

access-list 105 permit ip any any

access-list 105 permit icmp any any

access-list 110 remark Crypto_VPN

access-list 110 permit ip 172.21.4.32 0.0.0.31 any log

access-list 110 permit icmp 172.21.4.32 0.0.0.31 any log

dialer-list 1 protocol ip permit

!

!

!

!

!

control-plane

!

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

281
Views
0
Helpful
0
Replies
CreatePlease login to create content