Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Static Default route redistribution via route map fails in EIGRP

I am attempting to redistribute a default route into my eigrp process via a route map and acl, but the route is not being injected into EIGRP. I'm using the following commands, and I see the static in the routing table, as well as matching against the acl. Any thoughts on why this is not working?

router eigrp 1

redistribute static route-map redistribute-statics-eigrp

passive-interface default

no passive-interface Vlanxx

no passive-interface Vlanyy

network 1.1.1.0 0.0.0.255

network 2.2.2.0 0.0.0.255

auto-summary

route-map redistribute-statics-eigrp permit 10

match ip address 20

access-list 20 permit 0.0.0.0

ip route 0.0.0.0 0.0.0.0 null 0

Thanks,

-Scott

2 REPLIES
New Member

Re: Static Default route redistribution via route map fails in E

To clarify, I see the static default route in the routing table on the local router, but I do not see the default route in the routing table of any eigrp neigbor routers.

Hall of Fame Super Bronze

Re: Static Default route redistribution via route map fails in E

Your:

redistribute static route-map redistribute-statics-eigrp

Change it to:

redistribute static route-map redistribute-statics-eigrp metric 1 1 1 1 1

(1 1 1 1 1) are arbitrary numbers (bandwidth, delay, reliability, load and MTU).

Also, disable auto-sumary with no auto-summary

263
Views
0
Helpful
2
Replies
CreatePlease to create content