Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

static pat or asymmetric routing, whatever u may call it?

i have an application/web server on my private subnet, to which clients from internet connect. i have 2 wan links , (1 E1 and 1 ADSL) terminating on my 2811.

now i want to nat/pat client landing on my real IPs to be natted/patted to my server and the returning traffic should take the path where it originated from ( E1 or DSL)

the configuration is:

ip cef (by default)

int fa0/0

****DSL LINK ****

ip add 11.0.0.1

ip nat outside

int serial 0/0/0:2

******E1 LINK *******

ip add 12.0.0.1

ip nat outside

int fa0/1

*****SERVER SUBNET******

ip add 10.0.0.1

ip nat inside source static tcp 10.0.0.2 8090 11.0.0.1 8090 route-map one extendable

ip nat inside source static tcp 10.0.0.2 8090 12.0.0.1 8090 route-map two extendable

route-map one

match ip add 1

set interface fa0/0

route-map two

match ip add 2

set inter serial 0/0/0:2

acccess-list 1 permit any any

access-list 2 permit any any

ip route 0.0.0.0 0.0.0.0 fa0/0

ip route 0.0.0.0 0.0.0.0 serial 0/0/0:2

is there something i am missing?

the result are quite random. is there someother way to do this?

help required!!

thanks

RAZA

1 REPLY
New Member

Re: static pat or asymmetric routing, whatever u may call it?

have an application/web server on my private subnet, to which clients from internet connect. i have 2 wan links , (1 E1 and 1 ADSL) terminating on my 2811.

now i want to nat/pat client landing on my real IPs to be natted/patted to my server and the returning traffic should take the path where it originated from ( E1 or DSL)

the configuration is:

ip cef (by default)

int fa0/0

****DSL LINK ****

ip add 11.0.0.1

ip nat outside

int serial 0/0/0:2

******E1 LINK *******

ip add 12.0.0.1

ip nat outside

int fa0/1

*****SERVER SUBNET******

ip add 10.0.0.1

ip nat inside

ip nat inside source static tcp 10.0.0.2 8090 11.0.0.1 8090 route-map one extendable

ip nat inside source static tcp 10.0.0.2 8090 12.0.0.1 8090 route-map two extendable

route-map one

match ip add 1

set interface fa0/0

route-map two

match ip add 2

set inter serial 0/0/0:2

acccess-list 1 permit any any

access-list 2 permit any any

ip route 0.0.0.0 0.0.0.0 fa0/0

ip route 0.0.0.0 0.0.0.0 serial 0/0/0:2

is there something i am missing?

the result are quite random. is there someother way to do this?

help required!!

thanks

RAZA

329
Views
0
Helpful
1
Replies
CreatePlease to create content