Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Static route done..can't ping other PC?

I've made a static route between a  Cisco Router 1760 and a Cisco Router 2651xm using crossover cable to  connect to their Fast-Ethernet ports

so this is the configuration:

2651xm(config)#ip route 192.168.10.0 255.255.255.128 192.168.1.0.

and the other router's configuration:

2651xm(config)#ip route 192.168.10.0 255.255.255.128 192.168.1.0

Same thing.

The IP of the 2651xm is 192.168.10.2
The IP of the 1760 is 192.168.10.1.3

I'm I doing it wrong? is the destination wrong? I can't seem to ping any  other IP. I've got another laptop. I've put a static IP of  192.168.10.5, the primary Laptop is using has an IP of 192.168.1.138.  I'm trying to PING the 192.168.10.5 laptop. But this doesn't work.

Please help.

Sorry to mention, the 2561xm has another interface connected to a Cisco 2950 switch..with an IP of 192.168.1.3

Everyone's tags (6)
35 REPLIES
Hall of Fame Super Silver

Static route done..can't ping other PC?

Hello Abdulrahman,

you need a common IP subnet on the direct link between the two routers that can be 192.168.22.0 in order to perform routing. It is not possible to hop from an IP subnet to another.

you assign IP address 192.168.22.1 to C2651xm and 192.168.22.2 on C1760

at this point you can configure static routes on c2651xm for IP subnet that is behind the C1760

example:

C2651XM

ip route 192.168.10.0 255.255.255.128 192.168.22.2

let's suppose that 192.168.1.0/24 is on the C2651XM

C1760:

ip route 192.168.1.0 255.255.255.0 192.168.22.1

the static routes use as next-hops the IP addresses in the shared in common IP subnet

Hope to help

Giuseppe

New Member

Static route done..can't ping other PC?

Hi there,

I did what you told me but it still doesnt work. I've allowed "Allowed incoming echo requests" for the ICMP but it still doesn't work aswell..

Purple

Static route done..can't ping other PC?

Hi,

post the configs from both routers here.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Hi there,

Config for the 2651xm

Building configuration...

Current configuration : 1539 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2651xm

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$RGkX$JSGK9R3cUhpCcowFqA4xp.

enable password Aldabbagh1992

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username admin privilege 15 secret 5 $1$ia72$n7i3yF9VU4Ji9lEPrkeY//

!

!

!

!

!

!

!

interface ATM0/0

no ip address

shutdown

atm restart timer 300

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0/0

ip address 192.168.22.1 255.255.255.128

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

ip address 192.168.1.3 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

interface BRI1/0

no ip address

encapsulation hdlc

shutdown

!

interface BRI1/1

no ip address

encapsulation hdlc

shutdown

!

interface BRI1/2

no ip address

encapsulation hdlc

shutdown

!

interface BRI1/3

no ip address

encapsulation hdlc

shutdown

!

ip forward-protocol nd

ip route 192.168.22.0 255.255.255.128 192.168.1.0

!

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

password (not showing)

login local

transport input telnet ssh

Config for 1760:

CROUTER1760#sh run

Building configuration...

Current configuration : 837 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CROUTER1760

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$rTlq$oc5otiWPTW3WQZeW/MCX6/

enable password Aldabbagh1993

!

no aaa new-model

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.22.2 255.255.255.128

speed auto

full-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface BRI1/0

no ip address

encapsulation hdlc

shutdown

!

ip forward-protocol nd

ip route 192.168.1.0 255.255.255.0 192.168.22.0

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password (no showing)

login

!

end

CROUTER1760#

Purple

Static route done..can't ping other PC?

Hi,

1) on the 2651xm, you can get rid of this static route as it has no effect anyway as 192.168.22.0/25 is directly connected

2) on the 1760, the static route is not correct, just get rid of it and enter this one:

ip route 192.168.1.0 255.255.255.0 192.168.22.1

3) Now I only see a LAN on one side but where is the LAN on the 1760 ?

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Hi.

What LAN? There's only 1 FastEthernet on the 1760.

Purple

Static route done..can't ping other PC?

Hi,

ok I thought you were trying to ping from LAN to LAN.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Yes, I've got one network which is on 192.168.1.x and the Routers are 192.168.22.x

But the problem I can't ping from 192.168.1.x to the 192.168.22.x

Purple

Static route done..can't ping other PC?

Hi,

just make sure the default gateway for 192.168.1.0/24 network hosts is 192.168.1.3 which is the 2651xm ip address in this subnet.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Hi,

This is the ping results from the laptop:

E:\Documents and Settings\Admin>ping 192.168.1.3

Pinging 192.168.1.3 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 192.168.1.3:

    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

E:\Documents and Settings\Admin>ping 192.168.22.16

Pinging 192.168.22.16 with 32 bytes of data:

Reply from 192.168.22.16: bytes=32 time=1ms TTL=128

Reply from 192.168.22.16: bytes=32 time<1ms TTL=128

Reply from 192.168.22.16: bytes=32 time<1ms TTL=128

Reply from 192.168.22.16: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.22.16:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 1ms, Average = 0ms

E:\Documents and Settings\Admin>ping 192.168.22.11

Pinging 192.168.22.11 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 192.168.22.11:

    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

E:\Documents and Settings\Admin>ping 192.168.22.19

Pinging 192.168.22.19 with 32 bytes of data:

Control-C

^C

E:\Documents and Settings\Admin>ping 192.168.22.10

Pinging 192.168.22.10 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 192.168.22.10:

    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

I can ping the other laptop, but i still can't ping the 192.168.1.x network or even the routers on the 192.16.22.x network.

The 192.168.22.16 is the other laptop. 192.168.22.10 is the 2651xm router.

Purple

Static route done..can't ping other PC?

Hi,

can you post a diagram of your topology because I had understood in the initial posts that the 192.168.22.x network was the one between the 2 routers and now you say you have a laptop in this subnet ??

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Basically I've been trying to create static route between 2 networks. 192.168.1.x and 192.168.22.x, trying to ping the 192.168.22.x, but without any luck.

The primary Lapotp is has an IP of 192.168.1.x

The secondary Laptop is has an IP od 192.168.22.x (I'm using the 192.168.1.4 as the default gateway)

This is the topology.

Gold

Static route done..can't ping other PC?

Hi,

with regards to the config u post earlier, you have the network 198.168.22.1 & 192.168.22.2 on the 2651xm and 1760 respectively. here from the routers you should be able to ping these ip addresses. then depends on the where the other subnet is located; for example if its behing 2651xm, the you have to add this static route on the 1760:

ip route 192.168.1.0 255.255.255.0 192.168.22.1

you should point the first router to its NEXT router that have access to the subnet, and set the default gateways for users as their LOCAL router's interface which directly faces them

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
Purple

Static route done..can't ping other PC?

Hi,

repost the configs from both routers because the addressing is not clear and also the ip config from PCs.

Is 2651xm like this:  f0/0 192.168.1.4/24 and f0/1 192.168.22.10/24 ?

if it is the case then on the right switch the host must be in 192.168.22.0/24 network and have 192.168.22.10 as default gateway and if you've  got a host on the 1760 then you must have default route on 1760 pointing to 2651xm 192.168.1.4

and this host must be in another subnet than those already used and have its default gateway as the 1760 IP address in the same subnet.

Note that the  default gateway of a host must be in the same subnet so this can't work:

The secondary Laptop is has an IP od 192.168.22.x (I'm using the 192.168.1.4 as the default gateway)

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

The 192.168.22.x network is on a /25 subnet. 255.255.255.128.

Purple

Static route done..can't ping other PC?

Hi,

just use a 192.168.x.0/24 instead and it will work with the 192.168.22.0/24 between the routers  because I really don't understand exactly what you did with all the contradicting and partial infos you gave us up to now.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

This is the static route on the 1760.

CROUTER1760#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.22.1 to network 192.168.1.0

     192.168.22.0/25 is subnetted, 1 subnets

C       192.168.22.0 is directly connected, FastEthernet0/0

S*   192.168.1.0/24 [1/0] via 192.168.22.1

Purple

Static route done..can't ping other PC?

So from the 1760 you should be able to ping 192.168.1.x  being the ip address of 2651xm and the 192.168.1.x host if

firewall disabled and it has the correct default gateway.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

So i should use 192.168.1.4 as the gateway?

Purple

Static route done..can't ping other PC?

for the 192.168.1.x host: yes

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Now this is weird..the 1760 can ping the IP 192.168.1.4 and the main internet router which is 192.168.1.254, but other than that it can't.

Purple

Static route done..can't ping other PC?

Hi,

really you should post an uptodate  diagram with all ip addressing info as well as where the PCs are and also the latest configs from all devices as well as IP config of hosts. It will be much simpler to understand your problem because this is still very vague about the devices you want to ping between and their position in the network.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Cisco 2651xm has 2 ports

fa0/0 has an IP of 192.168.22.12

fa0/1 has and IP of 192.168.1.4 (this port is connected a Cisco Catalyst 2950 24 port switch)

Cisco 1760 has 1 port:

fa0/0 has an IP 192.168.22.13

Laptop 1 has an IP 192.168.1.138 with the default gateway of 192.168.1.254

Laptop 2 has an  IP 192.168.22.15 with the default gateway of 192.168.1.4

Purple

Static route done..can't ping other PC?

Laptop 2 has an  IP 192.168.22.15 with the default gateway of 192.168.1.4

As I already said this won't work:  the default-gateway must be in the same subnet as the PC

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Yeah, I get it now

Laptop 1 uses the gateway 192.168.1.254

Laptop 2 uses 192.168.22.14

Purple

Static route done..can't ping other PC?

where is laptop 2 connected to ?

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

To a normal 24 port Netgear Switch, the Netgear switch is connected to the Cisco Switch.

Purple

Static route done..can't ping other PC?

what's the use of the 1760 router then ?

I suppose they are in the same vlan( both PCs) and the 192.168.22.x on the 2651xm is going to 1760 ?

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Static route done..can't ping other PC?

Static route between them, i'm using it's FastEthernet port to connect to the 2651xm router..they don't have serial WAN cards.. WIC 1T

The problem, the router has 1 fastethernet port....

9438
Views
7
Helpful
35
Replies