Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Static route Problem

Can anyone point me in the right direction? i don seem to get my cisco router to work in my house. I have a comcast cable and which is connected to my little linksys router. The little linksys router is 192.168.20.1 and the g0/0 ip address works on my laptop when configured. My basic configuration is below:
Int g0/0
Desc WAN Uplink
ip address 192.168.20.15 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
  media-type rj45
negotiation auto
!
Int g0/1
Desc LAN Uplink
ip address 172.16.10.1 255.255.0.0
ip nat inside
duplex auto
speed auto
media-type rj45
negotiation auto
!
ip dhcp exclude address 172.16.10.1
ip dhcp pool LAN-INTERFACE
   network 172.16.10.0 255.255.0.0
   default-router 172.16.10.1
   domain-name dns.mydomain.com
   dns-server 4.10.101.20 6.8.10.2
   lease 0 2
!
ip domain name mydomain.com
ip name-server 4.10.101.20
ip name-server 6.8.10.2
!
username user privilege 15 secret 5 $1839040944IhZhOTy5kMG04hlHDPn0
ip route 0.0.0.0 0.0.0.0 192.168.20.1
ip routing
6 REPLIES
Hall of Fame Super Blue

Re: Static route Problem

Can you ping the linksys from your router ?

Is the linksys responsible for NAT or is to meant to be this router ?


Does "sh ip int brief" on the router show both interfaces up ?

What does "sh ip route" show on the router ?

Jon

Re: Static route Problem

You have NAT configured, but I don't see any NAT statements. Traffic will not route unless you configure the NAT rules for exemptions and NAT traffic.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

Try:

ip nat inside source list 1 interface g0/0 overload

access-list 1 permit 172.16.10.0 0.0.0.255

Community Member

Re: Static route Problem

I really appreciate the response I am getting from this forum:

I have tried running:

ip nat inside source list 1 interface g0/0 overload

access-list 1 permit 172.16.10.0 0.0.0.255

Below is detail my result from all my ping tests:

ip address of my laptop via dhcp connected on the g0/1 interface:


C:\Documents and Settings\admin.HOME-0H5JYFL4V7>ipconfig /all

Ethernet adapter Local Area Connection:

      Connection-specific DNS Suffix  . : dns.mydomain.com
     Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
        Physical Address. . . . . . . . . : 00-E2-94-G0-D3-71
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 172.16.10.2
        Subnet Mask . . . . . . . . . . . : 255.255.0.0
        Default Gateway . . . . . . . . . : 172.16.10.1
        DHCP Server . . . . . . . . . . . : 172.16.10.1
        DNS Servers . . . . . . . . . . . : 4.10.101.20
                                                    6.8.10.2
        Lease Obtained. . . . . . . . . . : Wednesday, August 04, 2010 7:35:40 P
M
        Lease Expires . . . . . . . . . . : Wednesday, August 04, 2010 9:35:40 P


pinging gateway from the my laptop:
C:\>ping 172.16.10.1

Pinging 172.16.10.1 with 32 bytes of data:

Reply from 172.16.10.1: bytes=32 time<1ms TTL=255
Reply from 172.16.10.1: bytes=32 time<1ms TTL=255
Reply from 172.16.10.1: bytes=32 time<1ms TTL=255
Reply from 172.16.10.1: bytes=32 time<1ms TTL=255

Ping statistics for 172.16.10.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

pinging int G0/0 interface from the laptop:
Pinging 192.168.20.15 with 32 bytes of data:

Reply from 192.168.20.15: bytes=32 time<1ms TTL=255
Reply from 192.168.20.15: bytes=32 time<1ms TTL=255
Reply from 192.168.20.15: bytes=32 time<1ms TTL=255
Reply from 192.168.20.15: bytes=32 time<1ms TTL=255

Ping statistics for 192.168.20.15:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Pinging the linksys (gateway) from the laptop:
Pinging 192.168.20.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.20.1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

On the router:
"Show ip int brief" gives:

GigabitEthernet0/0         192.168.20.15   YES NVRAM  up           up
GigabitEthernet0/1         172.16.10.1      YES NVRAM  up           up

"show ip route" gives:

Gateway of last resort is 192.168.20.1 to network 0.0.0.0

C    192.168.20.0/24 is directly connected, GigabitEthernet0/0
C    172.16.10.0/16 is directly connected, GigabitEthernet0/1
S*   0.0.0.0/0 [1/0] via 192.168.20.1

On the router:
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
router#ping 192.168.20.15

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.15, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
router#ping 192.168.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

router#ping google.com

Translating "google.com"...domain server (4.10.101.20) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 66.102.7.99, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/92/96 ms

Re: Static route Problem

Can your host, 172.16.10.x ping an internet host? For example, 4.2.2.2?

I would guess that your Linksys has no idea how to return packets to 172.16.10.x if NAT is not properly happening... Can we get an updated sanitized "show run" from your Cisco Router?

Community Member

Re: Static route Problem

I think what Tim suggested on having NAT could solve your problem.

try it ip nat inside source .... interface x/x overload

then your ACL statement..

Best Regards,

Christopher

Community Member

Re: Static route Problem

Thank you all for help. The problem was actually my NAT configuration. I cleaned up my config and applied your suggestions. It is now working.

717
Views
0
Helpful
6
Replies
CreatePlease to create content