Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Static routes and SAA remote tracking

I have a question regarding an SAA-type scenario at a customer site (see diagram).

We are deploying a central 2800 series router which has a 10M LES circuit into the customers service provider MPLS cloud (int FE 0/0). This 2800 also has an ISDN i/f for the remote routers to dial into in the event of their WAN links going down.

The remote devices are 3 1800 series routers each with ISDN backup i/f's. One of these routers has a IP numbered X21 link (WIC-1T) into the cloud, whilst the other two have IP Unnumbered DSL circuits (dialer i/f has ip unnumbered FastEthernet0/0).

My problem is this: the SP does not allow a routing protocol to be used over the WAN, so we have to make do with static routes. This is not a problem in the remote sites, as the only links out are the X21/DSL circuits and the ISDN's (which are used when the primary's fail) (tested & working). The problem is at the central site. The central router basically has no way of knowing when the remote WAN links go down, be they X21 or DSL, as they are into some POP elsewhere in the country. So the 2800 cannot track those links. If I use static & floating static routes on the 2800, the routes with the higher weight are always prevelant, as the ISDN and LES interfaces are always up.

The static routes used on the router are thus:

ip route 172.31.89.0 255.255.255.0 10.1.0.3 (remote ISDN i/f)

ip route 172.31.89.0 255.255.255.0 10.31.85.1 200 (other end of local LES cct)

ip route 172.31.91.0 255.255.255.0 10.1.0.2 (remote ISDN i/f)

ip route 172.31.91.0 255.255.255.0 10.31.85.1 200 (other end of local LES cct)

ip route 172.31.93.0 255.255.255.0 10.1.0.4 (remote ISDN i/f)

ip route 172.31.93.0 255.255.255.0 10.31.85.1 200 (other end of local LES cct)

I tried this approach to get the ISDN routes to be used only when the remote devices dial in, but since the local ISDN i/f is always up, the ISDN route always takes preference. Likewise, the LES circuit always takes preference when it has a higher weight than the ISDN route.

I have looked at the SAA method of tracking the remote interfaces, and applying it to the static route, and this would work on the X21 link, but the ADSL circuits are unnumbered, so I am struggling to find a solution.

Can anyone out there think of a solution to this?

Thanks in advance.

1 REPLY

Re: Static routes and SAA remote tracking

Dear,

The Tunnels interfaces between the central and the remote sites will completely solve your issue, try to create GRE tunnels and then point the static route for the remote destination on this tunnel which will automatic removed from the routing table once the link going down for Ex:

Centeral#

interface Tunnel1

description Connection to SITE(1)

ip address 1.1.1.1 255.255.255.252

keepalive 10 3

tunnel source FastEthernet0/1

tunnel destination 10.31.91.2

!

interface Tunnel2

description Connection to SITE(2)

ip address 2.2.2.1 255.255.255.252

keepalive 10 3

tunnel source FastEthernet0/1

tunnel destination 172.31.89.1

!

interface Tunnel3

description Connection to SITE(3)

ip address 3.3.3.1 255.255.255.252

keepalive 10 3

tunnel source FastEthernet0/1

ip route 10.93.91.0 255.255.255.255 FastEthernet0/1

ip route 172.31.89.1 255.255.255.255 FastEthernet0/1

ip route 172.31.93.1 255.255.255.255 FastEthernet0/1

Branches Config:

SITE(1)

interface Tunnel1

description Connection to Main Site

ip address 1.1.1.2 255.255.255.252

keepalive 10 3

tunnel source S0/0/0

tunnel destination 10.31.85.2

SITE(2)

interface Tunnel1

description Connection to Main Site

ip address 2.2.2.2 255.255.255.252

keepalive 10 3

tunnel source Any numbered interface

tunnel destination 10.31.85.2

Then added the static routes of the tunnel destination on the physical interface and point the default route on the tunnel interface on each remote branch, also use default route or the remote networks with high AD pointing on the physical ISDN interface

Ip route 0.0.0.0 0.0.0.0 BRI0/0/1

Best Regards,

Mounir Mohamed

109
Views
0
Helpful
1
Replies