Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Static routes not getting redistributed into OSPF Database !!!

Hi,

When I check ""show ip ospf database external 10.130.3.96"" & ""show ip ospf database external adv-rou 0.0.0.0"" on ROUTER-A, I can't see external routes. I have verified that this route is in the routing table but somehow it is not getting redistributed into OSPF. Even in show ip route 10.130.3.96 it clearly says that known via static & redistributing into OSPF.

Ideally this should work & this should appear as external LSAs in Database table locally as well as on downstream routers.........

I am really wondering why this thing is not working here whereas it is working on other routers & the only difference there is ispf & nsf are not there.

I can't remove ispf & nsf as this is a production router.....

ROUTER-A

router ospf 1
router-id 10.190.0.1
ispf
log-adjacency-changes
nsf
redistribute static subnets

network 2.2.20.1 0.0.0.0 area 0
network 10.10.0.1 0.0.0.0 area 0
network 10.11.0.1 0.0.0.0 area 0
network 10.11.0.5 0.0.0.0 area 0
network 10.11.0.9 0.0.0.0 area 21
network 10.11.0.33 0.0.0.0 area 0
network 10.11.0.37 0.0.0.0 area 0
network 10.11.0.49 0.0.0.0 area 0
network 10.11.0.53 0.0.0.0 area 0
network 10.11.2.2 0.0.0.0 area 22
network 10.11.3.1 0.0.0.0 area 24
!

ip route 10.130.3.96 255.255.255.224 10.11.2.7

Any hints on this would be appreciated... Thanks.

Akhtar

7 REPLIES
Hall of Fame Super Silver

Re: Static routes not getting redistributed into OSPF Database !

Hello Aktar,

post sh ip route 10.11.2.7

if the next-hop is not known with an internal route the static route is not redistributed

I see also

network 10.11.2.2 0.0.0.0 area 22

this has an effect on how forwarding address field is filled in the external LSA

see

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009405a.shtml

Hope to help

Giuseppe

Community Member

Re: Static routes not getting redistributed into OSPF Database !

Hi Giuseppe,

#show ip route 10.11.2.7
Routing entry for 10.11.2.0/24
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Routing Descriptor Blocks:
  * directly connected, via Vlan15
      Route metric is 0, traffic share count is 1

show ip route 10.130.3.96

Routing entry for 10.130.3.96/27

Known via "static", distance 1, metric 0

Redistributing via ospf 1

Routing Descriptor Blocks:

* 10.11.2.7

Route metric is 0, traffic share count is 1

I dont see any reason why this is not getting redistributed.

Regards,

Akhtar

Hall of Fame Super Silver

Re: Static routes not getting redistributed into OSPF Database !

Hello Aktar,

I see redistributing via  OSPF but I don't see the line "advertising in OSPF".

Are you sure there is no route filter applied in OSPF for redistribution of static routes?

also a distribute-list out applied in the OSPF process could have this effect.

post

sh ip ospf database external   10.130.3.96

and the the OSPF process configuration

Hope to help

Giuseppe

Community Member

Re: Static routes not getting redistributed into OSPF Database !

We are not using any route filtering here.

R-A:

router ospf 1
router-id 10.10.0.1
ispf
log-adjacency-changes
auto-cost reference-bandwidth 10000
nsf
area 0 authentication message-digest
area 21 authentication message-digest
area 22 authentication message-digest
area 24 authentication message-digest
redistribute static subnets tag 1291
network 2.2.2.1 0.0.0.0 area 0
network 10.10.0.1 0.0.0.0 area 0
network 10.11.0.1 0.0.0.0 area 0
network 10.11.0.5 0.0.0.0 area 0
network 10.11.0.9 0.0.0.0 area 21
network 10.11.0.33 0.0.0.0 area 0
network 10.11.0.37 0.0.0.0 area 0
network 10.11.0.49 0.0.0.0 area 0
network 10.11.0.53 0.0.0.0 area 0
network 10.11.2.2 0.0.0.0 area 22
network 10.11.3.1 0.0.0.0 area 24

ip route 10.130.3.96 255.255.255.224 10.11.2.7

R-B:

router ospf 1
router-id 10.10.0.2
ispf
log-adjacency-changes
auto-cost reference-bandwidth 10000
nsf
area 0 authentication message-digest
area 21 authentication message-digest
area 22 authentication message-digest
redistribute static subnets tag 1292
network 10.10.0.2 0.0.0.0 area 0
network 10.11.0.2 0.0.0.0 area 0
network 10.11.0.6 0.0.0.0 area 0
network 10.11.0.13 0.0.0.0 area 21
network 10.11.0.41 0.0.0.0 area 0
network 10.11.0.45 0.0.0.0 area 0
network 10.11.0.57 0.0.0.0 area 0
network 10.11.0.61 0.0.0.0 area 0
network 10.11.1.21 0.0.0.0 area 24
network 10.11.2.3 0.0.0.0 area 22
network 10.11.3.5 0.0.0.0 area 24

ip route 10.130.3.96 255.255.255.224 10.11.2.7

External LSA entry should also appear for 10.10.0.1(adv-router) as well. I should see 2 LSAs in this.


R-A#show ip ospf database external 10.130.3.96

            OSPF Router with ID (10.10.0.1) (Process ID 1)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 298
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 10.130.3.96 (External Network Number )
  Advertising Router: 10.10.0.2
  LS Seq Number: 80003B51
  Checksum: 0xF86
  Length: 36
  Network Mask: /27
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 10.11.2.7
        External Route Tag: 1292

External LSA entry should also appear for 10.10.0.1(adv-router)as well. I should see 2 LSAs in this.

R-B#show ip ospf database external 10.130.3.96

            OSPF Router with ID (10.10.0.2) (Process ID 1)

                Type-5 AS External Link States

  LS age: 499
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 10.130.3.96 (External Network Number )
  Advertising Router: 10.10.0.2
  LS Seq Number: 80003B51
  Checksum: 0xF86
  Length: 36
  Network Mask: /27
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 10.11.2.7
        External Route Tag: 1292

R-A router-id==10.10.0.1

R-B router-id==10.10.0.2

Hall of Fame Super Silver

Re: Static routes not getting redistributed into OSPF Database !

Hello Aktar,

what type of area is area 22 where the forwarding address is present?

I think here device with highest router-id wins the competition and is the only one advertising an LSA type 5.

This could be normal if area 22 is an NSSA area, but area 22.

I remember another recent thread where this suppression was happening.

An important aspect of the surviving LSA is the forwarding address field.

Forward Address: 10.11.2.7

because the forwarding address is not 0.0.0.0 the two possible LSAs are compared and only one wins.

In other words, from the point of view of OSPF area 0 and other areas until there are two paths for FA 10.11.2.7 there is no need to publish two copies of the external LSA.

if the forwarding address were 0.0.0.0 this LSA type 5 suppression wouldn't have happened and two copies would be seen.

see section 16.4 of RC 3228 that defines OSPFv2 behaviour

If the forwarding address is non-zero, look up the
            forwarding address in the routing table.[24] The matching
            routing table entry must specify an intra-area or inter-area
            path; if no such path exists, do nothing with the LSA and
            consider the next in the list.

Hope to help

Giuseppe

Community Member

Re: Static routes not getting redistributed into OSPF Database !

Hi Giuseppe,

You are right. Its very clear in the RFC 2328 pg 141.

if two routers, both reachable from one another, originate functionally equivalent AS-external-LSAs (i.e., same destination, cost and non-zero forwarding address), then the LSA originated by the router having the highest OSPF Router ID is used.  The router having the lower OSPF Router ID can then flush its LSA.

Thanks for your valuable feedback.

Regards,

Akhtar

VIP Super Bronze

Re: Static routes not getting redistributed into OSPF Database !

Hello Akhtar,

Can you provide a diagram of your OSPF areas and how every thing is connected.

Why router-a and router-b static routes pointing to the same next hop IP address?

ip route 10.130.3.96 255.255.255.224 10.11.2.7 router-a

ip route 10.130.3.96 255.255.255.224 10.11.2.7 router-b

HTH

Reza

3627
Views
5
Helpful
7
Replies
CreatePlease to create content