Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Stop Advertising OSPF routes from 3750 Interfaces

Please find below DCN network overview. All Generic Routers and 3750 switch running OSPF. All interfaces of 3750, server IP and router interfaces connected to 3750 are in same network of 192.168.1.0 /24. Server is accessing whole network via 3750.

Now, each router is showing all other router in OSPF neighbors and exchanging routes packet with each other via 3750. My 3750 switches also showing all routers as neigbhours. But I want only 3750 to learn routes from each connected router but not advertise routes to other connected router. This way other routers will have only routes of their own connected network and Server will be able to reach to all Nodes in the network.

 

What configuration I need to do ?

 

 

10 REPLIES
New Member

OSPF Config in 3750:

OSPF Config in 3750:

 

interface Vlan1
 ip address 192.168.1.200 255.255.255.0
 ip ospf dead-interval 30
 ip ospf priority 255
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0.0.0.1

 

Was trying to use :

ip ospf database-filter all out (not sure how to configure and will it solve my issue)

ip ospf prefix-suppression(but it's not available in 3750 switch)

Hello"But I want only 3750 to

Hello

"But I want only 3750 to learn routes from each connected router but not advertise routes to other connected router"

So basically you don't want each spoke to have any intra/inter area routes whatsoever and just a default ? - If so you could make each spoke router a STUB, but then you will need to put each spoke in a different area.

 

res

Paul
 

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Hi Paul,Yes, I don't want

Hi Paul,

Yes, I don't want each router which are in spoke in above diagram to learn any routes from other spoke routers. Basically, the routers shown here are transmission Nodes which act like router but not full fledged router, so different OSPF parameters are not present in those. And each spoke router here is connected to many(60-70) such routers running OSPF. Changing Area of each and every router is not possible. I need to change or, modify 3750 only to achieve desired result. I can put Server and port of 3750 connected to server in one area and remaining all in different area but I don't think it will serve required purpose.

-Nishant

 

 

Hi Kumar,The best way is STUB

Hi Kumar,

The best way is STUB as recommended PAUL. there are multiple ways to achieve your goal.

one is  DISTRIBUTE-LIST on every spoke IN direction 

 

HTH

kazim

Hello"But I want only 3750 to

Hello

"But I want only 3750 to learn routes from each connected router but not advertise routes to other connected router"

So basically you don't want each spoke to have any intra/inter area routes whatsoever and just a default ? - If so you could make each spoke router a STUB, but then you will need to put each spoke in a different area.

 

res

Paul
 

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

HI Nishant, You can suceed

HI Nishant,

 

You can succeed this either with distribute list or prefix lists. Please check the below link :

http://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/routmap.html

http://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/fiarospf.html

 

HelloI suppose you could

Hello

I suppose you could advertise a default route to all 3750 spokes and then on the spokes filter all prefixes other than the advertised default but this all depend how you have the adjacencys setup, via broadcast/non=broadcast etc//

3750
router ospf x
default-information originate always

 

spokes
ip prefix-list TST seq 5 permit 0.0.0.0/0

router ospf x
 distribute-list prefix TST in xxx

or
router ospf 1
distance ospf intra-area 255

 

 

res

Paul

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

3750router ospf xdefault

3750
router ospf x
default-information originate always

 

spokes
ip prefix-list TST seq 5 permit 0.0.0.0/0

router ospf x
 distribute-list prefix TST in xxx

 

This configuration was possible if router in spokes be proper routers, but as I told earlier these are Transmission Nodes behaving as router running OSPF, we can't change any OSPF parameters in SPOKE routers here.

Any suggestion which makes configuration changes in only 3750 to have same result will serve my purpose.

 

depend how you have the adjacencys setup, via broadcast/non=broadcast ??

Could not understand this. I am not that good in OSPF. In 3750, I have put interface vlan1 in same IP network and simply run OSPF in that network as shown in below config. No other configuration is done in any interfaces.

3750:

interface Vlan1
 ip address 192.168.1.200 255.255.255.0
 ip ospf dead-interval 30
 ip ospf priority 255

 ip ospf database-filter all out

!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0.0.0.1

Not sure how adjancency be setup(broadcast/non-broadcast)

HelloHumm not sure how this

Hello

Humm ,

The "hub" router needs all the routes from each spoke to provide a path to the spokes, as this is in the backbone Im not sure how to do this!!
filter-list or distribute-list wont work from the hub outbound!

You say the spokes CANNOT be amended whatsoever? - Im interested to know how is ospf running on the spokes - i mean how is the protocol enable for adjacency to establish etc..

 


res

Paul

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

In the spoke we can only

In the spoke we can only define IP, OSPF network, Area, And OSPF timers.

600
Views
0
Helpful
10
Replies
CreatePlease login to create content