Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Straight-Through or Crossover for Port Channels

Hi All,

In everything I've read, there shoudl be a crossover when connecting two switches. However, at my company we use straight-throughs when connecting our core switch to our distribution switches. The distro is a 2960G (or S), and the core uses a X6748 module in a 6500 chassis. We use EtherChannel between the two as well.

I thought this worked because of auto-MDIX, but that is showing disabled on both sides of the cable.

2960G output - (Auto-MDIX                             :  Off   )

The 6500 has a static speed and duplex setting so I believe that disables auto-MDIX (per this, "if you specify either the speed or duplex setting MDI-X is lost.") (Located here: http://www.gossamer-threads.com/lists/cisco/nsp/85412)

So, can anyone tell me why this works?

14 REPLIES
Purple

Straight-Through or Crossover for Port Channels

Hi,

I don't know this module but if it is a layer 3 module you need a straight-through cable if auto MDI/MDI-X is off and that could explain why it is working with this cable.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Community Member

Straight-Through or Crossover for Port Channels

I believe it should be considered a layer 2 module per this:

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps708/prod_bulletin0900aecd800f6e27.html

So, it's a switch. Though Cisco calls it, "multilayer." Could just be marketing mumbo-jumbo referring to layer 1 and layer 2.

Hall of Fame Super Blue

Straight-Through or Crossover for Port Channels

Patrick

Are the etherchannels from the 2960s to the 6500s L2 or L3 etherchannels ie. where is the inter vlan routing done ?

Jon

Community Member

Straight-Through or Crossover for Port Channels

They are trunk etherchannels, so they have L2 VLAN tagged frames.

The inter-VLAN routing is done at our router: a different module in the 6500 chassis. We have a SUP720.

Thanks for the help guys.

Hall of Fame Super Blue

Re: Straight-Through or Crossover for Port Channels

Patrick

Are you absolutely sure about the cables being used ?

The 6500 is a very capable switch but i still can't see how this is working.

BTW multilayer switch generally just means it can switch packets at L2 and L3 ie. the L3 part is done in hardware so it is called L3 switching.

Jon

Community Member

Straight-Through or Crossover for Port Channels

I'm 100% sure they are straight-through. We have a bunch of 2960's (G & S), all doing the same trunk back to the core over straight-through cables. Some are 2 interface bundles, some are 4.

I don't understand why either, even after a ton of reading. Hence, the post here

Hall of Fame Super Blue

Straight-Through or Crossover for Port Channels

There's one way of finding out:  Run a TDR from the 2960G/S. 

I have no idea why network admin blindly disable MDI/MDI-X.  This feature is every network admin's best friend. 

Community Member

Straight-Through or Crossover for Port Channels

I already checked the 2960G with this command:

show controllers ethernet-controller GigabitEthernet 0/24 phy det

And got this output (partial, obviously)

Auto-MDIX                             :  Off   [AdminState=1   Flags=0x000104C8]

The main network admin keeps auto-mdix disabled when he sets speed to static. He prefers for an interface to completely go down instead of auto-negotiating to 10 or 100Mbps. Gigabit or nothing. I don't really disagree with that outlook, but lets not get sidetracked

Speed is set to static (as is duplex) on the side of the X6748 blade as well, so I am assuming that auto-MDIX is off. The above command that I used for the 2960G cannot be used on the X6748.

Hall of Fame Super Blue

Straight-Through or Crossover for Port Channels

so I am assuming that auto-MDIX is off

Don't assume.  Run a TDR.  The result will show you the wire map.  It will give you a guarantee which pair goes to where. 

Do not run the TDR on the 6500 because this will take FOREVER to finish. 

Community Member

Straight-Through or Crossover for Port Channels

It's straight-through. Here are the TDR results:

Interface Speed Local pair Pair length        Remote pair Pair status

--------- ----- ---------- ------------------ ----------- --------------------

Gi0/24    1000M Pair A     8    +/- 10 meters Pair A      Normal             

                Pair B     8    +/- 10 meters Pair B      Normal             

                Pair C     8    +/- 10 meters Pair C      Normal             

                Pair D     8    +/- 10 meters Pair D      Normal  

Hall of Fame Super Blue

Re: Straight-Through or Crossover for Port Channels

Patrick

           

Can you post the config of a port channel plus the member ports between a 2960 and the 6500 ?

Jon

Community Member

Straight-Through or Crossover for Port Channels

2960G

interface GigabitEthernet0/24

description REMOVED

switchport mode trunk

logging event link-status

media-type rj45

speed 1000

duplex full

channel-group 2 mode desirable

interface Port-channel2

description REMOVED

switchport mode trunk

speed 1000

duplex full

no keepalive

6500

interface GigabitEthernet2/35

description REMOVED

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

mtu 9000

logging event link-status

speed 1000

duplex full

channel-group 203 mode desirable

interface Port-channel23

description REMOVED

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

mtu 9000

logging event link-status

speed 1000

duplex full

no keepalive

Community Member

Straight-Through or Crossover for Port Channels

Patrick Harrold wrote:

So, can anyone tell me why this works?

Because it's 1000Base-T?

While it's not exactly been mandated by 802.3-whatever, the principle of operation of 1000Base-T made it trivial to support both crossover and straight cables (remember that it's no longer one twisted pair for TX and one for RX, but all four TPs are working in parallel and doing echo-compensated TX and RX at the same time). Actually, any permutation of rewiring the four twisted pairs would have been supportable, but AFAIK not all are typically implemented (ISTR 802.3 only speaks about one specific crossover scheme, but I don't remember if it was 4/5 and 7/8 straight or crossed as well). This is not exactly the same thing as Auto-MDI-X, which usually just cycles the 10Base-T/100Base-TX PHYs through two settings until link pulses are detected (note that Auto-MDI-X for 10/100 was standardized way later than 1000Base-T), so the CLI may not denote it as Auto-MDI-X being used. But that's cosmetic.

HTH,

Andre.

Community Member

Straight-Through or Crossover for Port Channels

So, what you're saying is, it works for some reason, and that reason may or may not be auto-MDIX.

But that doesn't really answer why it works. I know you're saying it would be easy for them to support any mixing and matching of pairs, and just "re-wire" it corectly on the NIC side of one of the devices, but that just begs even more questions. What hardware is actually doing this? Is it standardized or documented somewhere?

Probably most importantly: is there some other name out there besides auto-MDIX that I should look for to ready up on?

Note: I don't want to be hand-fed the answer, I'd just like to at least be pointed in the right direction so I know exactly what is going on under the covers.

969
Views
18
Helpful
14
Replies
CreatePlease to create content