Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Strange EIGRP problem

Hi there.

I have three equipments in the same LAN. One 6500 switch, one 2800 router and one very old 1600 router. The thing is 2800 and 6500 can establish EIGRP neighborhood. Neither 6500 nor 2800 can establish EIGRP neighborhood with 1600 router. 6500 and 2800 added 1600 on their Neighbor tables, but 1600 didn't.

I run "debug eigrp packets hello". All of them send Hello messages, but for some reason 1600 does not see Hello packets from other equipments. 1600 is connected via serial interface with other router and they could establish neighborhood. I wonder if it is some issue with 1600 Ethernet interface.

Any ideas?

Thanks.

18 REPLIES
Hall of Fame Super Bronze

Re: Strange EIGRP problem

Can you post configs along with show ip eigrp interface and show ip proto from each device ?

Re: Strange EIGRP problem

Is there any access-list configured on the ethernet interface of the 1600?

If yes, then it should allow the eigrp protocol to successfully exchange hellos and establish adjacencies.

HTH

Narayan

New Member

Re: Strange EIGRP problem

Thank you very much for your answers. There is not access-lists configured on 1600. Right now I am out office, until next monday. I will send the output of the commands you asked for, I am not sure I would be able to send the complete configuration, but I can answer specific configuration questions. Thank you bery much.

One more thing I did'nt metion before, while I am not able to see Hello packets on 1600, I CAN see other type of EIGRP packets (Update packets, for instance).

Thank you very much.

Jorge Corrales

Silver

Re: Strange EIGRP problem

Hellos are Multicasts. Can problem be in Multicasts?

Bronze

Re: Strange EIGRP problem

Hi

EIGRP will not form neighborship if "K" value mismatch, Please check

You can also send config and debug informations.

-Minu

New Member

Re: Strange EIGRP problem

Try using the "neighbor" command under router eigrp in all 3 (2800, 6500, 1600).

New Member

Re: Strange EIGRP problem

These are outputs for "sh ip eigrp interfaces" and "sh ip proto" commands. The network in which all of them should establish neighborbood is 10.149.224.0/22

I had to split the message becuase it was so long

6500

IP-EIGRP interfaces for process 2146

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Gi1/1 1 0/0 1 0/10 50 0

Gi1/2 1 0/0 1 0/10 50 0

Gi1/3 1 0/0 6 0/10 50 0

Gi1/7 1 0/0 1 0/10 50 0

Gi1/8 0 0/0 0 0/10 0 0

Gi2/1 1 0/0 3 0/10 50 0

Gi2/2 1 0/0 1 0/10 50 0

Gi2/3 1 0/0 1 0/10 50 0

Gi2/4 2 0/0 0 0/10 50 4

Gi2/5 0 0/0 0 0/10 0 0

Gi2/9 2 0/0 1 0/10 50 0

Gi2/13 0 0/0 0 0/10 0 0

Gi2/24 0 0/0 0 0/10 0 0

Gi2/48 1 0/0 1 0/10 50 0

Gi2/11 0 0/0 0 0/10 0 0

--------------------------

Routing Protocol is "eigrp 2146"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: connected, static, eigrp 2146

Automatic network summarization is not in effect

Maximum path: 4

Routing for Networks:

10.0.0.0

192.168.225.0

192.168.231.0

192.168.233.0

192.168.244.0

192.168.247.0

192.168.248.0

Passive Interface(s):

Vlan1

Routing Information Sources:

Gateway Distance Last Update

10.149.172.2 90 00:00:00

Gateway Distance Last Update

10.149.168.2 90 00:00:01

10.149.164.2 90 00:00:01

10.149.212.2 90 00:00:01

10.149.208.2 90 00:00:01

10.149.224.5 90 01:12:07

10.149.224.2 90 04:03:47

10.128.8.1 90 00:00:01

10.135.24.1 90 00:00:01

10.128.16.1 90 00:00:01

10.129.112.2 90 00:00:01

10.129.112.4 90 00:00:01

Distance: internal 90 external 170

New Member

Re: Strange EIGRP problem

2800

IP-EIGRP interfaces for process 2146

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Fa0/0 0 0/0 0 0/10 0 0

Fa0/1 2 0/0 0 0/10 50 4

Se0/0/0 1 0/0 1 0/11 50 0

Se0/1/0 1 0/0 8 0/11 50 0

Se0/1/1 1 0/0 9 0/11 50 0

Se0/2/0 1 0/0 1 0/15 50 0

Se0/3/0 0 0/0 0 5/10 0 0

-----------------------

Routing Protocol is "eigrp 2146"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: connected, static, eigrp 2146

EIGRP NSF-aware route hold timer is 240s

Automatic network summarization is not in effect

Address Summarization:

0.0.0.0/0 for Serial0/1/0

Summarizing with metric 28160

Maximum path: 4

Routing for Networks:

10.0.0.0

Routing Information Sources:

Gateway Distance Last Update

(this router) 90 01:12:53

10.133.168.2 90 00:01:15

10.133.164.2 90 00:01:15

10.129.164.1 90 00:01:14

10.133.176.2 90 00:01:15

10.149.224.5 90 01:11:39

10.149.224.1 90 04:03:57

Distance: internal 90 external 170

Routing Protocol is "rip"

Sending updates every 30 seconds, next due in 26 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 2, receive version 2

Interface Send Recv Triggered RIP Key-chain

FastEthernet0/0 2 2

FastEthernet0/1 2 2

Serial0/0/0 2 2

Serial0/1/0 2 2

Serial0/1/1 2 2

Serial0/2/0 2 2

Serial0/3/0 2 2

Automatic network summarization is in effect

Maximum path: 4

Routing for Networks:

10.0.0.0

Routing Information Sources:

Gateway Distance Last Update

Distance: (default is 120)

--------------------------

1600

IP-EIGRP interfaces for process 2146

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

BR0 0 0/0 0 10/10 0 0

Et0 0 0/0 0 0/10 50 0

Se0 1 0/0 6 0/11 50 0

--------------------

Routing Protocol is "eigrp 2146"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: connected, static, eigrp 2146

Automatic network summarization is in effect

Automatic address summarization:

192.168.249.0/24 for BRI0, Ethernet0, Serial0

Routing for Networks:

192.168.249.0

10.0.0.0

Routing Information Sources:

Gateway Distance Last Update

10.133.164.1 90 00:00:13

10.149.224.2 90 04:04:47

10.149.224.1 90 01:10:09

Distance: internal 90 external 170

Hall of Fame Super Bronze

Re: Strange EIGRP problem

You have summarization enabled on the 1600. Please disable it with the no auto-summary command under the EIGRP process.

New Member

Re: Strange EIGRP problem

I just disabled it as you advice, but neighborhood doesn't establish yet.

Hall of Fame Super Bronze

Re: Strange EIGRP problem

Can we see the 1600's config ?

New Member

Re: Strange EIGRP problem

Here is it. I just deleted password information.

Current configuration:

!

! Last configuration change at 18:32:04 UTC Mon Jul 23 2007

! NVRAM config last updated at 18:32:35 UTC Mon Jul 23 2007

!

version 11.2

service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname ROT-AGN01-CAR

!

enable secret 5

!

username sanjose password 7

username ROT-AGN01-CAR password 7

ip domain-name ice.go.cr

ip name-server 10.129.20.21

isdn switch-type basic-net3

!

interface Ethernet0

description ROT-AGN01-CAR-LAN-ETH000

ip address 10.133.8.1 255.255.252.0 secondary

ip address 10.149.224.5 255.255.252.0

!

interface Serial0

description ROT-AGN01-CAR-CTLCAR-SER000

backup delay 0 0

backup interface BRI0

ip address 10.133.164.2 255.255.252.0

bandwidth 2048

no fair-queue

!

interface BRI0

description ROT-AGN01-CAR-SJO-BRI000

ip address 10.131.196.23 255.255.252.0

encapsulation ppp

dialer map ip 10.131.196.1 name sanjose broadcast 2589480

dialer-group 1

no fair-queue

ppp multilink

!

router eigrp 2146

redistribute connected

redistribute static

network 192.168.249.0

network 10.0.0.0

no auto-summary

eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.133.164.1

logging buffered 10000 debugging

snmp-server community RW

snmp-server community RO

snmp-server trap-authentication

snmp-server host 10.129.20.74 snmp

dialer-list 1 protocol ip permit

banner motd ^Ctod

***************************************************

* *

* ROUTER AGENCIA CARTAGO *

* *

* I . C . E . T . E . L *

* *

* INFRAESTRUCTURA DE CONECTIVIDAD *

* *

* D . A . T . I *

* *

***************************************************

^C

!

line con 0

password 7

login

line vty 0 4

password 7

login

!

ntp clock-period 17042050

ntp server 10.149.164.2

end

New Member

Re: Strange EIGRP problem

This is "sh version" output, maybe it would be helpful.

Cisco Internetwork Operating System Software

IOS (tm) 1600 Software (C1600-NSY-L), Version 11.2(11)P, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1998 by cisco Systems, Inc.

Compiled Tue 06-Jan-98 05:52 by dschwart

Image text-base: 0x080254D4, data-base: 0x02005000

ROM: System Bootstrap, Version 11.1(10)AA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc

1)

ROM: 1600 Software (C1600-BOOT-R), Version 11.1(10)AA, EARLY DEPLOYMENT RELEASE

SOFTWARE (fc1)

ROT-AGN01-CAR uptime is 1 week, 2 hours, 5 minutes

System restarted by power-on at 19:57:17 UTC Mon Jul 16 2007

System image file is "flash:c1600-nsy-l.112-11.P", booted via flash

cisco 1603 (68360) processor (revision C) with 3584K/512K bytes of memory.

Processor board ID 07856241, with hardware revision 00000000

Bridging software.

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

Basic Rate ISDN software, Version 1.0.

1 Ethernet/IEEE 802.3 interface(s)

1 serial(sync/async) network interface(s)

1 ISDN Basic Rate interface(s)

System/IO memory with parity disabled

2048K bytes of DRAM onboard 2048K bytes of DRAM on SIMM

System running from FLASH

8K bytes of non-volatile configuration memory.

8192K bytes of processor board PCMCIA flash (Read ONLY)

Configuration register is 0x2102

Hall of Fame Super Bronze

Re: Strange EIGRP problem

You have a 1998 IOS release running there, very old and I wonder if that's the problem here.

Is it possible to upgrade the IOS on this router ?

Can I see the show run from the 2800 router ?

New Member

Re: Strange EIGRP problem

Do you know where I can get a newer version? You know a 1600 router is not a brand new hardware...

This 2800 configuration

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ROT-CTL01-CAR

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret 5

!

no network-clock-participate aim 0

no network-clock-participate aim 1

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

ip domain name

ip name-server 10.129.20.21

no ftp-server write-enable

!

username monitor privilege 15 secret 5

!

!

!

interface FastEthernet0/0

description RED CTRL. CARTAGO

ip address 10.31.128.1 255.255.192.0 secondary

ip address 10.133.4.1 255.255.252.0

duplex full

speed 100

!

interface FastEthernet0/1

description CONEXION CON 6500-SAN PEDRO-PB

ip address 10.149.224.2 255.255.252.0

duplex full

speed 100

!

interface Serial0/0/0

description ROT-CTL01-CAR-SPE7500-SER000 (195-7430)

bandwidth 2048

ip address 10.129.164.2 255.255.252.0

!

interface Serial0/1/0

description ROT-CTL01-CAR-AGNCAR-SER010 (195-7533)

bandwidth 2048

ip address 10.133.164.1 255.255.252.0

!

interface Serial0/1/1

description ROT-CTL01-CAR-CTLEMP-SER001

bandwidth 2048

ip address 10.133.176.1 255.255.252.0

!

interface Serial0/2/0

description ROT-CTL01-CAR-CTLTUR-SER011 (195-5711)

ip address 10.133.168.1 255.255.252.0

!

interface Serial0/3/0

description ROT-CTL01-CAR-CTLPAR-SER030

bandwidth 128

ip address 10.133.180.1 255.255.252.0

encapsulation ppp

!

interface Serial0/3/1

no ip address

shutdown

clockrate 2000000

!

interface Group-Async24

physical-layer async

no ip address

!

router eigrp 2146

redistribute connected

redistribute static

network 10.0.0.0

no auto-summary

!

router rip

version 2

network 10.0.0.0

!

no ip classless

ip route 0.0.0.0 0.0.0.0 10.129.164.1

ip route 10.133.12.0 255.255.252.0 10.133.4.22

ip route 10.133.20.0 255.255.252.0 10.133.4.112

ip route 10.133.24.0 255.255.252.0 10.133.4.111

ip route 10.133.28.0 255.255.252.0 10.133.4.120

ip route 10.133.32.0 255.255.252.0 Serial0/1/1

ip route 10.133.36.0 255.255.252.0 Serial0/3/0

ip http server

ip http authentication local

ip http timeout-policy idle 5 life 86400 requests 10000

!

!

snmp-server community

snmp-server community

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server host 10.129.20.74 snmp

!

control-plane

!

banner motd ^Ctod

*************************************************************

* *

* C E N T R A L C A R T A G O *

* *

* INFRAESTRUCTURA DE CONECTIVIDAD *

* *

* D . A . T . I *

* *

*************************************************************

^C

!

line con 0

password 7

login local

line aux 0

line vty 0 4

privilege level 15

password 7

login local

transport input telnet

line vty 5 15

privilege level 15

password 7

login local

transport input telnet

!

scheduler allocate 20000 1000

sntp server 10.149.164.2

!

end

Hall of Fame Super Bronze

Re: Strange EIGRP problem

Any reason why you have a secondary network on the 1600 router E0/0's interface ?

Can you remove it and see if EIGRP starts to work ?

New Member

Re: Strange EIGRP problem

Hi Jorge,

I think there is a configuration problem with 6500. Either there is a interface in passive mode or there is an access list blocking EIGRP hello packets.

It would be better if u could send config of 6500 and tell us on which ports r these 3 equipments connected to each other.

Thanks

Deepinder Singh Babbar

New Member

Re: Strange EIGRP problem

I c that ur VLAN 1 is in passsive mode, remove it from passive mode. I hope all the neighbors will form adjacancy after that.

If this info was helpfull please rate that.

Thanks & Regards

Deepinder Singh Babbar

227
Views
0
Helpful
18
Replies
CreatePlease login to create content