Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Strange ppp multilink speed issue

I have a customer using ppp multilink with two T-1s on a Cisco 1721. Running 12.3(16) firmware, 32meg flash 32 meg NVRAM. My customer is accessing a secure www site, that with both T-1s connected the www site is very, very slow. When my customer disconnects one of the T-1s(it does not matter which T-1) the speed of the www site increases 90%.

As I said it does not matter which T-1 is disconnected, the speed changes are the same. We have worked with the www site admins who state they do not see anything wrong. One of my admins suggested upgrading the firmware on the 1720 from 12.2(6c) to the current 12.3(16). This change actualy made the speed worse.

Any suggestions???

3 REPLIES

Re: Strange ppp multilink speed issue

Your connection is proably suffering from out-of-sequence packets. Many application do not handle this well. Best advice I can give is:

1: try to determine if this is indeed happening. You will need a protocol analyser for this.

2: alter the load balancing such that all traffic for one particular session is always routed via the same link.

Regards,

Leo

New Member

Re: Strange ppp multilink speed issue

We are looking into the protocol analyser option at this time. As for the load balancing we have all traffic routed to the multilink interface.

interface Multilink1

ip unnumbered FastEthernet0

no cdp enable

ppp multilink

no ppp multilink fragmentation

multilink-group 1

!

!

interface Serial0

description Connected to

no ip address

encapsulation ppp

no ip route-cache

no fair-queue

ppp multilink

multilink-group 1

!

interface Serial1

description Connected to

no ip address

encapsulation ppp

no ip route-cache

no fair-queue

ppp multilink

multilink-group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 Multilink1

Re: Strange ppp multilink speed issue

Still I expect an out-of-sequence issue. It would be good if you could confirm this via an analyser trace.

I have looked up some info about ways to get around this:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080110bd7.html#wp1025043

Hope this helps you a bit further

Regards,

Leo

230
Views
0
Helpful
3
Replies