Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

sub interfaces on 4948

hi, currently i am using cisco cat4000-I9S-M), Version 12.2(25)EWA8, my question is that i want to configure sub interfaces on it. when i issue the command int gig1/1.100 it didn't recongnize that commmand.How can i configure sub interfaces on 4948 switch.

Thanks

12 REPLIES

Re: sub interfaces on 4948

I dont think sub interfaces are supported on the 4948 platform

Narayan

Re: sub interfaces on 4948

Hi,

In order to configure a subinterface the port must be Layer3 (routed port). Try with the command:

interface gig1/1

no switchport

And then create the subinterface with the command

interface gig1/1.100

I hope this helps.

Best regards.

Massimiliano.

Community Member

Re: sub interfaces on 4948

hi,

i have configured the port layer 3 and then issue the command interface gig1/1.100 it doesnot recongnize the sub interface command. it gives " % Invalid input detected at '^' marker." message.

Super Bronze

Re: sub interfaces on 4948

Unsure, but is there some VLAN trunking command required at the Ethernet parent interface before Ethernet subinterfaces can be defined?

Community Member

Re: sub interfaces on 4948

hi,

any idea how to configure sub interfaces on 4948 switch

Super Bronze

Re: sub interfaces on 4948

As I wrote, I'm unsure. Hoping someone else might comment if my vague recollection about the parent interface was correct. Don't have a Cisco box to test on.

Hall of Fame Super Blue

Re: sub interfaces on 4948

You don't need to do anything special once configured as a routed port.

If you type in

int gi1/1.100 and it gives an invalid input error then i think Narayan is right in that the 4948 doesn't support subinterfaces.

Can i ask why you need subinterfaces when you can use L3 SVI's on the 4948 ?

Jon

Community Member

Re: sub interfaces on 4948

hi,

Actually i am getting internet bandwidth and i have eight sites connected to my router. My service provider provides my cable in which they pass all the vlans for this i have to configured dot1q and subinterfaces.

Silver

Re: sub interfaces on 4948

"i have eight sites connected to my router. My service provider provides my cable in which they pass all the vlans"

connection from ur service provider is terminated on router or 4948 switch?

Community Member

Re: sub interfaces on 4948

hi,

connection from my service provider is terminated on my 4948 switch. I have router but don't have spare FastEthernet port.

Thanks

Hall of Fame Super Blue

Re: sub interfaces on 4948

If the service provider is sending all the vlans down the link then it must be a trunk link. So you could use subinterfaces but then again you could use SVI's. So lets say you have 3 vlans

vlan 10 = 192.168.5.0/24

vlan 11 = 192.168.6.0/24

vlan 12 = 192.168.7.0/24

make the interface that the cable connects into a trunk

int gi0/24

switchport trunk encapsulation dot1q

switchport mode trunk

then

int vlan 10

ip address 192.168.5.1 255.255.255.0

no shut

int vlan 11

ip address 192.168.6.1 255.255.255.0

no shut

int vlan 12

ip address 192.168.7.1 255.255.255.0

no shut

Jon

Community Member

Re: sub interfaces on 4948

hi,

my service provider is providing me ip with /30 mask. what ip should i give to svi interface and what ip in that vlan.

661
Views
0
Helpful
12
Replies
CreatePlease to create content