Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Subinterfaces configured with HSRP

Hello,

I have two ASR 1001s.  They both run HSRP.  Recently I have had to take one router and configure it as a subinterface and bind another ip address to it.  As a result of testing HSRP fail over I noticed that the secondary did not take over.  Even when I did a show standby brief the primary didnt know who its standby device was.  Is there a problem with placing HSRP on a subinterface?

Below is the config

Primary

interface GigabitEthernet0/0/3.1

encapsulation dot1Q 1400

ip address 192.30.212.2 255.255.252.0

standby 10 ip 192.30.212.1

standby 10 priority 150

standby 10 preempt

end

interface GigabitEthernet0/0/3.2

encapsulation dot1Q 59

ip address 209.31.119.236 255.255.255.224

end

Secondary

interface GigabitEthernet0/0/3

description USFS LAN Network

ip address 192.30.212.3 255.255.252.0

standby 10 ip 192.30.212.1

standby 10 priority 140

standby 10 preempt

negotiation auto

end

One big question is if I need to make the interface match?  Do I need to place a matching subinterface on the secondary router as well.  At this point in time the primary cant ping the physical ip address on the secondary and vise versa.

5 REPLIES

Re: Subinterfaces configured with HSRP

Hi,

HSPR uses link-local Multicast IP-Addresses, so you need to have layer-2 connectivity between the active and standby interfaces.

As far as I can see, the primary side tags frames (1400) whereas the secondary is a main-interface, which doesn't tag. Is there a switch in between with corresponding switchport configurations (trunk / access vlan 1400)?

Regards

Rolf

Hall of Fame Super Blue

Subinterfaces configured with HSRP

Is gii0/0/3 on the secondary router in vlan 1400 ?

What does "sh standby brief" show ?

Jon

Hall of Fame Super Silver

Subinterfaces configured with HSRP

The original poster asks " Is there a problem with placing HSRP on a subinterface?" . The answer is that no there is not a problem with placing HSRP on a subinterface - as long as both ends of the connection treat it the same way. As Rolf and Jon have pointed out it appears that one end of this connection now is doing trunking with tagged frames while the other end of the connection is treating it as a physical interface with no tagging. It is the mismatch that is causing the problem and not any restriction on HSRP.

HTH

Rick

Subinterfaces configured with HSRP

Thanks you all for your assistance.

I am in good shape now.

Hall of Fame Super Silver

Re: Subinterfaces configured with HSRP

I am glad that you are in good shape now and hope that our answers were helpful.

HTH

Rick

Sent from Cisco Technical Support iPhone App

250
Views
0
Helpful
5
Replies