Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

sup32 boot problem

Hi,

Can anyone please help me with this problem:

When I'm booting Catalyst6500 with sup32 It first goes to ROMMON mode:

if I issue "boot" command then it starts booting but with IOS version that doesn't exist

---------------------------------

rommon 1 > set

BOOT=disk0:s3223-advipservicesk9_wan-mz.122-18.SXF9.bin

rommon 2 > dir disk0:

Initializing ATA monitor library...
Directory of disk0:

19752    51583012  -rw-     s3223-advipservicesk9_wan-mz.122-18.SXF9.bin

rommon 3 > boot

Initializing ATA monitor library...
string is bootdisk:s3223-advipservicesk9_wan-mz.122-18.SXF7.bin

00:00:06: %OIR-SP-6-CONSOLE: Changing console ownership to route processor

------------------------------------

Then it starts ROMMON mode again but on RP:

-------------------------------------

rommon 1 > set

BOOT=disk0:s3223-advipservicesk9_wan-mz.122-18.SXF9.bin

BOOTLDR=

?=0

rommon 2 > boot disk0:s3223-advipservicesk9_wan-mz.122-18.SXF9.bin

an alternate boot helper program is not specified

(monitor variable "BOOTLDR" is not set)

and unable to determine first file in bootflash

loadprog: error - on file open

boot: cannot load "disk0:s3223-advipservicesk9_wan-mz.122-18.SXF9.bin"

rommon 3 > dir disk0:

bad device name (Device not supported)


-----------------------------------

It is the same thing if I boot on SP with

rommon 1> boot disk0:s3223-advipservicesk9_wan-mz.122-18.SXF9.bin

it ends up on RP rommon with the same problem

Thanks in advance.

Regards,

A.

3 REPLIES
New Member

sup32 boot problem

Hello,

I took another Catalyst 6500 and still have the same problem:

(I put on SP and RP boot variables that I have read from one of running 6500 with sup32 in my network - I issued show bootvar on RP and SP)

On SP rommon I have variables:

------------------------------------------------------------------
rommon 1 > set
PS1=rommon ! >
SLOTCACHE=cards;
ACL_DENY=0
BOOT=bootdisk:s3223-advipservicesk9_wan-mz.122-18.SXF7.bin
CONFIG_FILE=
BOOTLDR=
confreg=0x2102
BSI=
PF_REDUN_CRASH_COUNT=1
SUPW_1=1
CRASHINFO=crashinfo_FAILED
RET_2_RTS=09:06:46 UTC Tue Nov 15 2011
RET_2_RCALTS=1321348008
?=0

rommon 2 > dir bootdisk:

Directory of bootdisk:

2 50604580 -rw- s3223-advipservicesk9_wan-mz.122-18.SXF7.bin

----------------------------------------------------------------------------------

I issue

rommon 3> boot

Initializing ATA monitor library...

string is bootdisk:s3223-advipservicesk9_wan-mz.122-18.SXF7.bin

Self extracting the image... [OK]
Self decompressing the image : ################################################################################################### [OK]

MAC based EOBC installed

00:00:05: %SYS-3-LOGGER_FLUSHING: System pausing to ensure console debugging output.

00:00:05: %PFREDUN-6-ACTIVE: Initializing as ACTIVE processor

00:00:07: %SYS-SP-3-LOGGER_FLUSHING: System pausing to ensure console debugging output.

00:00:05: %SYS-3-LOGGER_FLUSHED: System was paused for 00:00:00 to ensure console debugging output.

00:00:07: %OIR-SP-6-CONSOLE: Changing console ownership to route processor

System Bootstrap, Version 12.2(17r)SX3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2004 by cisco Systems, Inc.
Cat6k-MSFC2A platform with 524288 Kbytes of main memory

rommon 1 > set 
PS1=rommon ! >
CONFIG_FILE=
BOOTLDR=
confreg=0x2102
?=0
BOOT=sup-bootdisk:s3223-advipservicesk9_wan-mz.122-18.SXF7.bin

Then I issue:

rommon 2 > boot sup-bootdisk:s3223-advipservicesk9_wan-mz.122-18.SXF7.bin
.......
00:03:08: %SYS-SP-3-LOGGER_FLUSHING: System pausing to ensure console debugging output.

00:03:08: %SYS-SP-3-LOGGER_FLUSHED: System was paused for 00:00:00 to ensure console debugging output.

00:03:08: %OIR-SP-6-CONSOLE: Changing console ownership to switch processor

*** System received a Software forced crash ***
signal= 0x17, code= 0x24, context= 0x42355684
  PC = 0x4040001c, SP = 0x415a6548, RA = 0x403fae14
  Cause Reg = 0x00001020, Status Reg = 0x34008002
rommon 2 >

-------------------------------------------------------------------

Then again goes back to SP rommon.

This is the second 6500 that doen't want to boot. What am I doing wrong?

Please any help

Thanks,

A.

New Member

Hello Antonio, i'm facing

Hello Antonio,

 

i'm facing this issue also. Did you ever manage to overcome it?

 

regards,

Nuno

Cisco Employee

Could you please try the

Could you please try the following steps:

- Try to run ‘load_helper’ command, which initialize the bootloader to look for boot locations.
- After that ‘flash_init’ should initialize the flash.
- Once the flash is initialized, we should be able to set the boot variable through ‘boot disk0:<image>’.
- This should reset and reload the switch with the IOS image.

also, once you have set the boot variables, press "i" and enter. This should sync the boot variables.

Other things i would say is, before starting the above process, unset the variables.

Hope this helps.

Thanks

Vinit

Thanks
--VJ
1867
Views
0
Helpful
3
Replies