Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

%SYS-4-NV_BLOCK_INITFAIL

Has anyone any idea what this means?

I have found this http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_system_message_guide_chapter09186a008009e7a4.html

that tries to explain the problem and how to fix it, but I'm apparently stupid because I don't know how to "Reduce the configurations in the NVRAM at least by 2 KB".

Infact I don't see anything in the NVRAM, it's all gone both Startup-config and private-config.

And every time I try to save the running-config into startup-config, I get that error message "%SYS-4-NV_BLOCK_INITFAIL".

Please let me know if you need extra info.

Router is a 2650XM running adipservicesk9 12.3(14)T4 with a NM-1V and a VIC-2BRI-S/T-TE and CCME 3.3

10 REPLIES

Re: %SYS-4-NV_BLOCK_INITFAIL

Try this from the global config:

service compress-config

Then try saving the config to NVRAM.

Good Luck!!

--Sundar Palaniappan

Bronze

Re: %SYS-4-NV_BLOCK_INITFAIL

Good thinking, thats what I thougt would fix it, but sadly no.

I've posted what happens when I try and save the config:

Router#cop ru st

Destination filename [startup-config]?

startup-config file open failed (Unknown error 0)

Router#

Nov 11 23:39:32 DK: %SYS-4-NV_BLOCK_INITFAIL: Unable to initialize the geometry of nvram

Router#

Ive allso tried testing the NVRAM, and this is what I get:

Router#test memory nvram-multibus

Testing NVRAM card will remove all files! Continue [y/n] ? y

Warning: This test will result in the loss of the NVRAM configuration!

Continue [y/n] ? y

Passed

Router#

Nov 11 23:44:33 DK: %SYS-4-NV_BLOCK_INITFAIL: Unable to initialize the geometry of nvram

Nov 11 23:44:33 DK: %SYS-4-NV_BLOCK_INITFAIL: Unable to initialize the geometry of nvram

Nov 11 23:44:33 DK: %SYS-4-NV_BLOCK_INITFAIL: Unable to initialize the geometry of nvram

Router#

Do I have a faulty chip or something?

The router has been running on and off, with different IOS versions for over a year now without problems.

Re: %SYS-4-NV_BLOCK_INITFAIL

If I have to guess, probably a faulty chip.

Try one other thing. Remove all the config and do a write mem. That should rule out insufficient NVRAM problem.

Bronze

Re: %SYS-4-NV_BLOCK_INITFAIL

The last time it reloaded and came up all empty, I tried the copy run start right away, and got the same error message.

I'll try a swap it for new 2600XM on Monday, hope that helps.

Thanks for helping out.

New Member

Re: %SYS-4-NV_BLOCK_INITFAIL

hi,

i have the same problem:SYS-4-NV_BLOCK_INITFAIL.

i found a big statup-conf and underliying-config in nvram and couldn't delet it:

1 -rw- 6593 startup-config

2 ---- 5 private-config

3 -rw- 6593 underlying-config

i try to erase nvram:

erase /all nvram:

and got the following error:

%SYS-4-NV_BLOCK_INITFAIL: Unable to initialize the geometry of nvram

has anyone any idea wich could help me?

Bronze

Re: %SYS-4-NV_BLOCK_INITFAIL

The problem is that the NVRAM in the 2600XM isn't that big, only 29688 bytes. So if the Startup-config is bigger then the space in the NVRAM, the router doesn't load the startup doing reloading, and you can't save the config any longer.

Workaround is to reload the router (hope you have the config on backup) and break the router into ROMMON. Change the confreg to 0x2142, and reload again.

Now the router comes up completly empty, change the confreg back to 0x2102, erase the NVRAM and save the empty running config to startup.

Now paste the backup configuration back in to the router, making sure that the size of the running config doesn't exceed the size of the NVRAM.

use "sh run | inc Current configuration" to see the size of the running config and "sh start | inc uncompressed size" to see the maximum size of the NVRAM. On my 2600XM it looks like this:

Router#sh run | inc Current configuration

Current configuration : 17639 bytes

Router#

Router#

Router#sh start | inc uncompressed size

Using 8974 out of 29688 bytes, uncompressed size = 17639 bytes

2650XM-Router#

Hopefully this would have solved your problem.

I actually had to delete my banner and move an ISDN card and config to another router, in order to get below the 29688 bytes, which is the maximum of the 2600XM.

New Member

Re: %SYS-4-NV_BLOCK_INITFAIL

my model is an 801. i've tried your tip without any success(breaking into rommon and so on..), because erasing nvram is not possible:

write erase and erase /all nvram: doesnt work, the router responses with the error message %SYS-4-NV_.......

I can see 3 files in the nvram:

startup-config 6895 bytes

private-config

underlying-confg 6895 bytes.

It is not possible to delete any of this files!

commands like write mem doesn't work also..

i think the route has an hardware failure????

Bronze

Re: %SYS-4-NV_BLOCK_INITFAIL

I guess you only have 8000 bytes of NVRAM in your 801 router.

Once you have rebooted the router, using confreg 0x2142, try and save the empty running-config into startup-config. If that works, change the confreg back to 0x2102 and reboot again. Now hopefully you should be able to erase all the files in the NVRAM, without getting that anoying %SYS-4-NV_BLOCK_INITFAIL error.

I thougt it was a hardware failure to, but changing to another 2600XM router, didn't help at all.

New Member

Re: %SYS-4-NV_BLOCK_INITFAIL

I had the same problem today. And what I did, I'm not sure will it help you but I hope it will, I've just put through CLI "Router#erase nvram:" I've got a message from the router "Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

[OK]

Erase of nvram: complete"

And after this I've copied from tftp to startup-configure backup configuration then reload router. My router is 2611XM IOS 12.3(18).

New Member

This fixed it for me on Cisco

This fixed it for me on Cisco 2901. Thanks!

4180
Views
10
Helpful
10
Replies
CreatePlease login to create content