Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

System Boot Command

I'm looking to boot one of two images available on internal flash of a 1921 router.  Currently 151-1.T1.bin is being loaded at boot.

Router#sho ver | in System image

System image file is "usbflash0:c1900-universalk9-mz.SPA.151-1.T1.bin

Router#dir
Directory of usbflash0:/

    1  -rw-    47130480  Sep 14 2010 08:56:54 -05:00  c1900-universalk9-mz.SPA.151-1.T1.bin
    2  -rw-    66539863  Sep 23 2013 13:32:48 -05:00  c1900-universalk9-mz.SPA.153-2.T1.bin

256610304 bytes total (142934016 bytes free)


Router#sho fla
-#- --length-- -----date/time------ path
1     47130480 Sep 14 2010 13:56:54 c1900-universalk9-mz.SPA.151-1.T1.bin
2     66539863 Sep 23 2013 18:32:48 c1900-universalk9-mz.SPA.153-2.T1.bin

142934016 bytes available (113676288 bytes used)

At this point I have tried a few commands, neither of them giving me the correct results.

Router#sho run | in boot sys

boot system usbflash0:c1900-universalk9-mz.SPA.153-2.T1.bin

and

Router#sho run | in boot sys

boot system flash:c1900-universalk9-mz.SPA.153-2.T1.bin

I have used the boot system command in the past and for some reason, these two are not working.  I'm hesitent to erase c1900-universalk9-mz.SPA.151-1.T1.bin and hope 153-2.T1.bin works.  This I havn't tried yet. 

Has anyone had similar issues with the 1921 platform or know what my command error could be?

Thank you,

  • WAN Routing and Switching
Everyone's tags (3)
2 REPLIES
Cisco Employee

System Boot Command

Hi Eric,

There are two main posibilities row check firstly:

1. Earlier image can be set in boot variable differently and thus not seen with "sho run | in boot sys". Check

"show bootvar" and see what are the current images set to boot and in which order. Then you will be able to delete earlier one if needed.

2. Other thing is that newer image file can be corrupted. thus during boot system may fail to start it and failover to other existent image. So before removing earlier one - pls verify the image md5 hash and compare to CCO one ("verify /md5 

usbflash0:c1900-universalk9-mz.SPA.153-2.T1.bin"). On CCO you may also find the hash value for this image in download section. As with just blind removal of old IOS you can stuck in ROMMON with no bootable IOS.

Niko

New Member

Re: System Boot Command

Can you provide show version and show bootvar
And also if you have the console log at the time when the router booted, this will show if the router tried to boot from the new image


Sent from Cisco Technical Support iPhone App

652
Views
0
Helpful
2
Replies