Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

T1 and Cable on the same 2621XM Router

I am tech coordinator for a school district. We currently use ISA server plugged directly into the ethernet port of a Cisco 2621XM router. On the Router I also have a T1 to the internet. What I am looking to try and do is add a Cable modem connection to my internet for additional bandwidth. We are basically out of capacity on our T1 and I am trying to add bandwidth and keep my set up the same with regards to my ISA server.

Is this possible to do and what would I need to add to my 2621XM to accomplish this. I know I have another WIC slot and another ethernet port on the router I am currently not using.

3 REPLIES

Re: T1 and Cable on the same 2621XM Router

Hi Friend,

I think what we can do in this situation is that you can terminate your cable modem on the ethernet port and have the ethernet port configured for get the DHCP address from cable modem. use " ip address dhcp " under the ethernet interface.

You can then use NAT and Policy based routing to divide the traffic across these links. For Example you can dicide the traffic based on Vlans, user segments, FTP traffic, HTTP traffic and see which link you want to carry what traffic.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c/qcpart1/qcpolicy.htm

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_white_paper09186a0080091cb9.shtml

HTH, Please rate if it does.

-amit singh

New Member

Re: T1 and Cable on the same 2621XM Router

I need some more help with my set up. I would like to either load balance my 2 internet circuits or I would like to have all http traffic go over the cable modem and all the rest go through the T1.

My current running config is:

version 12.0

service timestamps debug datetime localtime

service timestamps log datetime localtime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname myrouter

!

!

clock timezone EST -4

ip subnet-zero

!

!

interface fastEthernet0/0

description Main inside connection to the ISA Server

ip address 12.169.171.177 255.255.255.248

no ip directed-broadcast

no shutdown

!

interface Serial0/0

description T1 to isp

ip address 172.31.253.10 255.255.255.252

no ip directed-broadcast

no shutdown

!

interface fastEthernet0/1

ip address 74.193.123.161 255.255.255.248

Description Comcast data circuit

no ip directed-broadcast

no shutdown

!

router eigrp 300

redistribute connected

redistribute static

passive-interface FastEthernet0/0

network 172.19.0.0

network 172.31.253.8 0.0.0.3

network 172.31.254.8 0.0.0.3

no auto-summary

!

ip nat pool my-natpool 12.169.171.182 12.169.171.182 netmask 255.255.255.248

ip nat inside source list 1 pool my-natpool overload

no ip http server

ip classless

!

access-list 1 permit 172.19.0.0 0.0.255.255

access-list 1 permit 205.146.123.0 0.0.0.255

!

!

ntp clock-period 17180034

ntp peer 172.131.253.9

end

All my external IP's are static from both the T1 provider and Comcast. I set up the comcast circuit on my 2nd ethernet port, but I know it is not nating - since I never changed the NAT stuff when I converted. So essentially the comcast circuit is doing nothing at this point.

Now I have no clue what to do next to make this all work with load balancing if someone could help it would be appreciated.

P.S. all these IP addresses I have post are bogus numbers.

Re: T1 and Cable on the same 2621XM Router

Hi,

I would think that 1.5 Mbps link to Internet is quite sufficient in case you dont have a huge downloading crowd e.g. to download GBs of Music or Video.

My opinion would be to first judge and see if you are legitimate traffic is taking the bandwidth and using it upto the capacity or its some kind of non-business traffic that is taking the traffic?

If the later is true, you can easily deploy QoS for HTTP / HTTPS and FTP, and then block the traffic for P2P Applications.

Secondly even if the legitimate traffic is utilizing the bandwidth (for FTP/HTTP and SMTP), try to use some caching engine and that would ease the pressure on the T-1 Link.

Otherwise, you are never going to satisfy the needs to the end users.

All the Best!

Regards,

Wilson Samuel

256
Views
4
Helpful
3
Replies
CreatePlease to create content