Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

T1 Bundles - Multilink ppp?

Hello all,

I will soon have the task of working on several routers at another company. The company has multiple sites connected by a variety of links. In particular, two sites are connected using a single T1 between a pair of 2611's. The company is interested in adding a second T1 for more bandwidth between the sites.

If a second T1 is added, what would the best way be to bundle the lines? I am planning on trying multilink ppp, or is there a better method?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: T1 Bundles - Multilink ppp?

Multilink PPP will give you true load balancing and is the only way to do it if a non cisco router is involved. The disadvantage is that you are adding the PPP overhead both to the packets and to the router processor. You may want to just do a simple load balance by packet option on the interfaces. It does not balance as well since packet size varies but it is very simple. If it does not work well you can alway go to the ppp solution.

11 REPLIES
Gold

Re: T1 Bundles - Multilink ppp?

Multilink PPP will give you true load balancing and is the only way to do it if a non cisco router is involved. The disadvantage is that you are adding the PPP overhead both to the packets and to the router processor. You may want to just do a simple load balance by packet option on the interfaces. It does not balance as well since packet size varies but it is very simple. If it does not work well you can alway go to the ppp solution.

Re: T1 Bundles - Multilink ppp?

As Tim said, MLPPP adds some overhead, BUT allows streams >T1 speed. We have both kinds of links - parallel T1's and ML PPP - both work great.

Paul

Green

Re: T1 Bundles - Multilink ppp?

If the existing link is Frame-Relay, AND, if your carrier supports it, check out Multi-Link Frame Relay (MLFR),

The only hardware requirement is enough interfaces for the number of T1/DS1's you want to bundle, and the only software requirement is that the firmware version also supports it.

Good Luck

Scott

New Member

Re: T1 Bundles - Multilink ppp?

Thanks for the replies. It looks like I will use multilink ppp. The new T1 won't be installed for a while yet, hopefully gives me some time to find a couple of spare routers to test it out.

Thanks all!

Little_Wing

Re: T1 Bundles - Multilink ppp?

take a look at this:http://www.cisco.com/univercd/cc/td/doc/product/aggr/10000/10ksw/mlppos.htm

rate this post if it helps

regards

Devang

New Member

Re: T1 Bundles - Multilink ppp?

I have two T1's similiar to above. I have added MLPPP to routers on both sides and cannot seem to bond.

I have removed one of the T1s so i could remotely connect to far side, and work on adding one t1 to MLPPP but cannot get it to work.

Here is output, any help would be appreciated.

interface Multilink1

ip address x.x.x.x/30

no cdp enable

ppp multilink

no ppp multilink fragmentation

multilink-group 1

interface Serial0/0

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

service-module t1 fdl ansi

ppp multilink

multilink-group 1

sh int multilink 1

Multilink1 is down, line protocol is down

Hardware is multilink group interface

New Member

Re: T1 Bundles - Multilink ppp?

after debugging the issue: debug ppp negotiation, the output suggested i had a AAA authorization issue. Once i saw the problem with this portion of the config, i added

aaa authorization network NOAUTH none

!

interface Serial1/0:0

ppp authorization NOAUTH

This corrected the issue.

Hope this helps someone in the future.

New Member

Re: T1 Bundles - Multilink ppp?

I have an example of load sharing between two T1's that I have setup in the past for an Aggregation of 3MB.

interface Serial0

ip address xxx.xxx.xxx.xx1 255.255.255.252

no ip proxy-arp

ip load-sharing per-packet

no ip mroute-cache

no cdp enable

!

interface Serial1

ip address xxx.xxx.xxx.xx2 255.255.255.252

no ip proxy-arp

ip load-sharing per-packet

no ip mroute-cache

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xx1

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xx2

I hope this will help.

Thanks Jim

New Member

Re: T1 Bundles - Multilink ppp?

How do you guys verify the aggregated rate is doubled?

New Member

Re: T1 Bundles - Multilink ppp?

If you are going to add another T1 later on make sure the second T1 has to come from same vendor and same central office and the seme switc, otherwiese MLPP will not work thanks JM

New Member

Re: T1 Bundles - Multilink ppp?

Joe,

MLPP is independent of the carrier. If the T1s are point to point, it should not matter what carrier they are from.

Steve

1112
Views
2
Helpful
11
Replies
CreatePlease login to create content