Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Tag Routes from specific interfaces?http://knowledgebase/index.php?/article/AA-01867/54/Cisco-Networking/Client-Wireless-SSID-Password.html

Scenario is a hub router in an MPLS environment with DMVPN backup. MPLS runs over BGP and DMVPN uses EIGRP. All spokes are EIGRP stubs, hub has mutual redistribution to allow route exchange with 3rd parties who also run EIGRP.

 

I would like to prevent the hub from redistributing to BGP, any routes that come from the Tunnel interface. I can obviously develop and maintain a route map based on an ACL or prefix list, however I was wondering if I could somehow tag the routes that are learned over the tunnel? This makes things much easier to maintain in the long run, but my research so far has turned up empty.

 

Thanks in advance for any tips and tricks!

  • WAN Routing and Switching
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

If you get the tag into the

If you get the tag into the route, just create a route-map and deny redistributing that tag:

 

route-map DenyTag deny 10

match tag 40

route-map DenyTag permit 20

router bgp 1

redistribute eigrp 100 route-map DenyTag

 

 

HTH, John *** Please rate all useful posts ***
4 REPLIES

Yes you can: route-map Test

Yes you can:

 

route-map Test permit 10
 match interface Tunnel1
 set tag 40

 

 

Once you redistribute into whichever protocol you want, you'll append this route-map to the redistribution line:

router ospf 1

redistribute eigrp 100 route-map Test subnets

 

R3#sh ip route 2.2.2.0
Routing entry for 2.2.2.0/24
  Known via "ospf 1", distance 110, metric 20
  Tag 40, type extern 2, forward metric 10
  Last update from 172.13.0.1 on FastEthernet0/0, 00:00:09 ago
  Routing Descriptor Blocks:
  * 172.13.0.1, from 192.168.12.1, 00:00:09 ago, via FastEthernet0/0
      Route metric is 20, traffic share count is 1
      Route tag 40

 

The protocol used over the tunnel is eigrp only...

 

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

John,Thanks for the reply,

John,

Thanks for the reply, sorry for taking so long to get back to you. I see how the tag is applying and showing up, but I want to apply the tag and then based on that tag NOT redistribute it. Essentially saying redistribute eigrp into bgp except with tag x, where tag x has been applied to all routes inbound over Tunnel 1.

 

Does that make sense?

 

If you get the tag into the

If you get the tag into the route, just create a route-map and deny redistributing that tag:

 

route-map DenyTag deny 10

match tag 40

route-map DenyTag permit 20

router bgp 1

redistribute eigrp 100 route-map DenyTag

 

 

HTH, John *** Please rate all useful posts ***
New Member

Thanks for the assistance

Thanks for the assistance that nudge in the right direction got me exactly what I wanted:

SPOKES:
route-map DMVPN-TAG permit 10
 set tag 99

router eigrp XXX
 distribute-list route-map DMVPN-TAG out Tunnel1


HUB:
route-map DENY-DMVPN deny 10
 match tag 99
route-map DENY-DMVPN permit 20
router bgp XXXXX

 redistribute eigrp 69 route-map DENY-DMVPN

 

84
Views
5
Helpful
4
Replies
This widget could not be displayed.