Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Tarrfic-shape or Policy-Map

Hi Experts! I am trying to configure bandwidth control (only ICMP) in a ROUTER but in "both" ways. From PCA to PCB I want to configure 200K, and from PCB to PCA I want to configure 400K. This configurations are done because I want to avoid excessive traffic that can be increase the process of my router. There is other kind of traffic passing through these interfaces must not controlled:

PCA ----> G1/1 ROUTER G2/2 ----> PCB

PCA <---- G1/1 ROUTER G2/2 <---- PCB

1.- What is better? traffic-shape or policy-map?

2.- If I use traffic-shape, in wich interface do I must apply?

3.- If I use policy-map, in wich interface do I must apply?

4.- Is the following configuration correct?

PCA=10.10.10.10, PCB=20.20.20.20

access-list 110 remark LIMIT PCA to PCB

access-list 110 permit udp host 10.10.10.10 host 20.20.20.20 eq snmp

interface G2/2

traffic-shape group 110 200000

access-list 120 remark LIMIT PCB to PCA

access-list 110 permit udp host 20.20.20.20 host 10.10.10.10 eq snmp

interface G1/1

traffic-shape group 120 300000

Normally, traffic-shape is used in the outside of the interface, but with this, there is passing a lot of traffic to the router. With "policy-map" is more efficient? Can you send me an example please?

Thanks for your help!!!

3 REPLIES

Re: Tarrfic-shape or Policy-Map

Hi Carlos,

Traffic-shaping can be implemented in the outbound direction only.

So you must configure traffic-shaping on G1/1 and on G2/2 as well, if you want to implement it in both traffic directions.

The policy-map configuration is the newest method of configuring QoS.

Personally I would prefer to use the policy-map method, because it always separates traffic classification from the action taken on the traffic class, and this creates a more structured and clear configuration.

In addition to this, class-maps and policy-maps, once created, can be reused in other QoS configurations within the same router, which makes configuration quicker and the probability of configuration errors decreases.

Cheers:

Istvan

New Member

Re: Tarrfic-shape or Policy-Map

Thanks Istvan! Do you have an example of the configuration of policy-map?

Re: Tarrfic-shape or Policy-Map

Hi Carlos,

Access-lists:

access-list 110 permit udp host 10.10.10.10 host 20.20.20.20 eq snmp

access-list 120 permit udp host 20.20.20.20 host 10.10.10.10 eq snmp

Classifying traffic:

class-map PCA-TO-PCB

access-group 110

class-map PCB-TO-PCA

access-group 120

Definition of QoS actions:

policy-map PCA-TO-PCB

class PCA-TO-PCB

shape average 200000

policy-map PCB-TO-PCA

class PCB-TO-PCA

shape average 300000

Applying QoS policies to the interfaces (in this case in the outbound direction):

interface Gig2/2

service-policy output PCA-TO-PCB

interface Gig1/1

service-policy output PCB-TO-PCA

Cheers:

Istvan

255
Views
0
Helpful
3
Replies
CreatePlease login to create content