Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

TCP handshake issue

Hello experts,

Few of the poeple in my office are facing issue while sending and receiving emails using thunderbird.. Our email server is located at different geopgraphical location. So our inside hosts are natted to a public IP so access emails over internet. I have verified the access on my firewalls, thats pretty OK. As most of the peolpe can access emails. The ASA connection FLAG which i see for those 3-4 hosts is  SaAB, which shows that TCP handshake is not properly done. Please help me with your kind advise so that i can rectify the issue. Thanks in advance.

5 REPLIES

TCP handshake issue

Hello, Rizwan.

try telnet to connect to the IP-address:port and see if it opens connection.

If yes - then it's most likely application issue; if not - then OS or network.

New Member

Re:TCP handshake issue

Hi. I tried that. It's not connecting. Apparently it looks network issue. But there are twenty plus users who can connect to mail server. All the access in asa is subnet based . No specific access exist in firewall. Also the natting is for the whole subnet. And I can see the inside host which is unable to connect gets translated to the public IP.the same user can access internet and other services in my office. So I don't think it's an OS issue. If it's network then what can it be?
It's a mystery for me.

Sent from Cisco Technical Support Android App

Re:TCP handshake issue

I suspects it is due to limitation of nat translations issue where concurrent tcp request which goes to mail server. Kindly try by using nat rotary(round robin) pattern where it shows request from multiple publics ips. I faced a similar issue with my customer and solved.


Sent from Cisco Technical Support Android App

New Member

Re:TCP handshake issue

Hello Dinesh.
Another update on the issue. Around 1 out of 10 telnet tries gets successful. I also cleared Nat translations. And tried telnet again. It didnot work on first attempt.


Sent from Cisco Technical Support Android App

New Member

Re:TCP handshake issue

Hello everyone,

The issue has been solved, there was no natting issue. When i put captures in firewall, the email server was not responding to request by the clients whose emails were not working. It was TCP timestamp issue which was resolved.

280
Views
0
Helpful
5
Replies
CreatePlease to create content