cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
373
Views
0
Helpful
5
Replies

TCP/IP - X25

denaumcisco
Level 1
Level 1

Good morning Folks,

I have this situation

PC1 -> router A - router B -> pc2

where:

PC1=192.168.1.1

router A (eth)=192.168.1.100

router A (serial) = x25 123

router B (serial) = x25 789

router B (eth) = 192.168.2.100

PC2= 192.168.2.1

Now I can use a "translate" and start a telnet session from pc1 to router B, but what I need is start a telnet session from pc1 to pc2.

What I have to do? a translate on route B? How?

Thanks

5 Replies 5

I need TCP over X25.

About the file attached, I can connect from PC A to router B, and I can connect from router A to PC B, but I can't connect from pc A to pc B. (I'm using apache for this test)

that is my routers configurations:

show conf

Using 891 out of 245752 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

!

!

!

x25 routing

!

!

!

interface FastEthernet0/0

ip address 192.168.1.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

encapsulation x25 dce

no ip mroute-cache

x25 address 123

!

interface Serial0/0/1

no ip address

shutdown

clock rate 125000

!

ip classless

!

ip http server

!

!

translate x25 123 tcp 192.168.1.1 port 8080

access-list 100 permit icmp any any

access-list 100 permit tcp any any

x25 route 789 interface Serial0/0/0

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

!

end

Router#

and the another router:

show conf

Using 891 out of 245752 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

!

!

x25 routing

!

!

!

interface FastEthernet0/0

ip address 192.168.0.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

encapsulation x25 dce

no ip mroute-cache

x25 address 789

!

interface Serial0/0/1

shutdown

clock rate 125000

!

ip classless

!

ip http server

!

!

translate x25 123 tcp 192.168.1.1 port 8080

access-list 100 permit icmp any any

access-list 100 permit tcp any any

x25 route 789 interface Serial0/0/0

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end

Router#

anyone?

I got it!, but when I open my page it came with tcp header too, not the correct page.

Is it a problem of encapsulation? How can I resolve this?

ohassairi
Level 5
Level 5

here is an example to route TCP/IP over x25 network:

!

interface Ethernet0

ip address 194.147.160.254 255.255.255.0

!

interface Serial0

ip address 192.1.1.1 255.255.255.0

encapsulation x25

x25 address 133014389

x25 htc 2

x25 idle 1

x25 nvc 2

x25 map ip 192.1.1.2 112010132

(remote wan) (remote x25)

!

ip route 193.1.1.0 255.255.255.0 192.1.1.2

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: