Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Test ISDN Backup With Primary Up?

Have remote offices setup with Cisco 2600 router on serial frame-relay and an ISDN backup.

Is there a way to test the ISDN backup interface/circuit without taking the serial interface down?

I'd like to verify that the ISDN is indeed available before actually needing it.

6 REPLIES
New Member

Re: Test ISDN Backup With Primary Up?

We have two methods of ISDN backup in our network. One uses the 'dialer watch' approach and is triggered based upon the loss of a default route at the device. The second method utilizes a floating static default route that activates when the normal default route goes away -AND- there is interesting traffic to send from the site. The first method relies on the 'dialer string' configuration under the BRI interface and can only be tested by failing the primary link. However, the second method utilizes the 'dialer map ip' approach under the 'dialer 1' interface, can be tested while the primary is up by pinging the IP address that is contained in the dialer map statement. Hope this helps.

Hall of Fame Super Silver

Re: Test ISDN Backup With Primary Up?

As Daniel indicates, how you can test the ISDN backup depends on how your environment is configured. In addition to the dialer-watch and floating static route approaches some environments configure backup-interface as a way to implement ISDN backup. This approach requires taking the primary out of service to be able to test the backup.

So if the original poster will give some details of how the router(s) are configured, we might be able to give better advice about how to test it.

HTH

Rick

New Member

Re: Test ISDN Backup With Primary Up?

Here's our interface config:

interface Serial0/0

no ip address

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

!

interface Serial0/0.100 point-to-point

bandwidth 1536

backup delay 30 300

backup interface Dialer1

ip address 172.27.0.2 255.255.255.252

frame-relay interface-dlci 100

bridge-group 1

!

interface BRI0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-dms100

isdn spid1 32138531160101

isdn spid2 32138535080101

ppp multilink

!

interface Dialer1

bandwidth 128

ip address negotiated

encapsulation ppp

dialer pool 1

dialer remote-name DBU-5350

dialer string 4523451

dialer-group 1

ppp multilink

bridge-group 1

We hired a consultant to configure our WAN routers. I know enough to make basic config changes and that's about it.

Hall of Fame Super Silver

Re: Test ISDN Backup With Primary Up?

Tony

Thanks for posting the interface configurations. As I had wondered it does use backup-interface on the frame relay subinterface to initiate dial backup. As I indicated using backup-interface puts the inteface into a dedicated state and the primary must be taken out of service to test the backup. The good news is that in your configuration the ISDN is configured with dialer interfaces to get to the BRI. So the interface that is in the dedicated state is the dialer interface and the BRI interface can be used while the frame relay interface is functional. To be able to test the ISDN you would need to configure another dialer interface (probably dialer2) with most of the same parameters as dialer1. Then you could make a call using dialer2 to test the ISDN without disturbing dialer1 or the frame relay.

I assume that there are some routing statements that would direct traffic toward dialer1 if the frame relay stops working. You would need some similar statements for dialer2 to be able to test.

As a side note: I would have expected the BRI and the dialer1 to be configured with authentication (probably CHAP perhaps PAP) but do not see them. Are they there and you chose not to include them in what you posted, or are they not configured on the BRI or on the dialer1?

HTH

Rick

Silver

Re: Test ISDN Backup With Primary Up?

There is a way to just test thee ISD

N functionality, not the connectivity to the remote end. If you want to verify that the ISDN functions and calls out then you can make a test call off the interface BRI. This will attempt to call a number that you specify. Some carriers offer a special loopback number that they use to test their service. You can try those numbers. If the ISDN dials out (Use debug ISDN q931) you can verify that your ISDN layer function.. It does not test router configurations and will not come up to your remote router..Good Luck...

New Member

Re: Test ISDN Backup With Primary Up?

Hello,

I think there's 2 ways to test the ISDN as below, and you can enable 'debug dialer event' to see the test result activties :

1- using isdn test commaned (isdn test call interface BRI0/0 4523451 )

2- create any test host like 1.1.1.1 & include it in the interesting traffic to test the isdn

###############

ip route 1.1.1.1 255.255.255.255 dialer1

ip access-list extended

permit ip any host 1.1.1.1

###############

Then ping the host 1.1.1.1 will trigger the ISDN

Thanks,

Ahmed Hussein

541
Views
0
Helpful
6
Replies
CreatePlease login to create content