Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Testing T1 Interface on Cisco 1841

I am pretty much a novice as far as router configuration goes. We have just purchased two Cisco 1841 routers with the T1 interface. I have them configured, but am trying to test the communication between the two routers before shipping the one to the other side. I have created and attached a T1 cross-over cable to the serial interface on both routers. The modules are showing green (CD) and have no alarms now. The problem is I am trying to ping the interfaces and am having no luck. Here is the current situation:

Router 1: FA0/0 - 192.168.12.10

Serial0/0/0 - 192.168.15.2

Router 2: FA0/0 - 192.168.9.10

Serial0/0/0 - 192.168.15.1

From Router 1: It can not ping it's own serial interface (15.2) and it can not ping the FA0/0 interface on the other router. It can ping the serial interface on the second router.

The same is true when trying to ping from router2.

What am I doing wrong and what can I try?

Attached are my configs. Any help or suggestions you can offer is appreciated.

4 REPLIES
Hall of Fame Super Silver

Re: Testing T1 Interface on Cisco 1841

Brian

The biggest issue is this line in your configs:

no ip routing

This means that your 1841s are acting like IP hosts and not like routers. With no ip routing then it does not understand or process ip route statements. Remove the no ip routing and I believe that most of your problems will be solved. If not post again with updated configs and updated statements of what does not work.

HTH

Rick

New Member

Re: Testing T1 Interface on Cisco 1841

Thank you. I knew it was something small, but I just couldn't find it. This must have been one of the lines that were in the config automatically.

As far as configuring this, does everything else look OK for a t1 point to point connection? I can ping everything now.

Hall of Fame Super Silver

Re: Testing T1 Interface on Cisco 1841

Brian

I do not see any T1 controller commands in the config and without knowing what kind of T1 card you have can not know whether they are needed. If you can ping through the serial that is a good sign that they may not be needed. But without knowing about the card and about how the live T1 will be provisioned it is hard to know.

I would suggest removing this line from all vty lines:

privilege level 15

In general it is put into the config by SDM and has the effect that anyone who can log into the router will go directly into privilege mode and will have access to make configuration changes. I regard this as a poor security practice. Unless you have some particular reason to keep it I would suggest that you remove it.

I also note that your vty lines specify login local. However there is no username contained in the config. The result is that you will not be able to telnet into the router. This is another thing that SDM puts into the config. I very much suggest that you remove it (or that you configure a user name and password). I would also remove login local from the console.

I also note these lines:

ip http access-class 23

ip http authentication local

They specify to use access list 23 to control access through the web browser interface but access list is not configured, so access will be denied. And it specifies authentication loca which has the same issue as what I discussed on the vty lines. If you intend to use the web interface then you need to correct these. If you do not intend to use the web interface then I would disable it, which would be recommended from a security perspective.

Other than these things I believe that your configs are reasonable.

HTH

Rick

New Member

Re: Testing T1 Interface on Cisco 1841

Thanks. I have made the modifications. When I posted the config on the web, I removed the username statements. That is why they were not there.

As for the T1 controller, the card is a WIC 1DSU-T1 v2.

813
Views
0
Helpful
4
Replies