Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

This is possible?

Hi,

I need help.

This is possible?

192.168.10.2 only can ping gateway.

why 192.168.20.2 192.168.30.2 and 192.168.40.2 dont ping gateways?

Captura de ecrã 2013-11-23, às 11.05.12.png

config switch 2960PT:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport access vlan 500

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan500

ip address 83.240.176.241 255.255.255.252

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

end

Config router 2901:

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

!

!

!

!

license udi pid CISCO2901/K9 sn FTX1524Q2X2

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface GigabitEthernet0/0

ip address 83.240.176.242 255.255.255.252

ip nat outside

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.1

encapsulation dot1Q 10 native

ip address 192.168.10.254 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1.2

encapsulation dot1Q 20

ip address 192.168.20.254 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1.3

encapsulation dot1Q 30

ip address 192.168.30.254 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1.4

encapsulation dot1Q 40

ip address 192.168.40.254 255.255.255.0

ip nat inside

!

interface Vlan1

no ip address

shutdown

!

ip nat inside source list 180 interface GigabitEthernet0/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 83.240.176.241

!

!

access-list 180 permit ip 192.168.10.0 0.0.0.255 any

access-list 180 permit ip 192.168.20.0 0.0.0.255 any

access-list 180 permit ip 192.168.30.0 0.0.0.255 any

access-list 180 permit ip 192.168.40.0 0.0.0.255 any

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

5 REPLIES
Super Bronze

Re: This is possible?

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

It would help if your topology labeled ports!

However, I suspect most of your edge hosts are in VLAN 1 as is the link to the router.  As the router's 192.168.10.0/24 is the native VLAN, it's physically in the same VLAN and so your 192.168.10.2 host can ping it.

BTW, what are you trying to accomplish?  Because normally one would expect the port to the router would be configured as a trunk and each host, that's in a different subnet, should be in the VLAN for it.

Hall of Fame Super Gold

This is possible?

The drawing shows 1 router and 2 switches. The configuration shown has 1 router and 1 switch and the switch config appears to be for the switch that connects the router to the outside. We do not see the config of the switch that connects the router to the hosts. And that is the one that we need to see to understand what the issue is.

HTH

Rick

Community Member

This is possible?

switch config that connects the router to the hosts:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface Vlan1

no ip address

shutdown

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

end

Community Member

This is possible?

why only router interface 0/1.1 have connection?


Hall of Fame Super Gold

This is possible?

Thanks for the additional information. It allows us to accurately identify what is the issue. The switch has only a single vlan configured and no trunk port. So all its frames are sent without any vlan tags. The untagged frames are received by the router and treated as belonging to vlan 10 which is configured to be the native vlan. This explains why the PC configured with an address that matches the subnet of vlan 10 on the router is able to ping the router address.

All of the PCs are connected in a single vlan which corresponds to a single IP subnet. So PCs that are configured with IP addresses in other subnets are not able to ping the router addresses because they are physically in vlan 10 but have addresses in other vlans.

HTH

Rick

204
Views
0
Helpful
5
Replies
CreatePlease to create content