Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Time Base Bandwidth limit on subinterface in Cisco 3845

Dear Experts,

I need very Urgent Time based Bandwidth limit on subinterface in Cisco 3845 Router.

At Present 3Mb input/output rate-limit of our one of the client now they  need between 9:00  to 20:59  3 Mb and between 21:00 to 8:59 they need 9 Mb bandwidth, please see current b/w limit config of our client in my router subinterface.

interface GigabitEthernet0/1.12

description *** xyz ***

encapsulation dot1Q 12

ip address 10.11.12.13 255.255.255.248

rate-limit input 3072000 576000 1152000 conform-action transmit exceed-action drop

rate-limit output 3072000 576000 1152000 conform-action transmit exceed-action drop

Now how can i achive of my requrement to time based b/w limit.

Thanks in ADV,

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: Time Base Bandwidth limit on subinterface in Cisco 3845

Sorry, I should've read your post more carefully. I missed the requirement that throughput needed to be adjusted according to the time. I believe a configuration change needs to be made during those times and time-based ACL is not the ideal solution here. You need EEM scripting for this task and I recommend asking in the Network Management forum for further assistance.

Regards,

Edison

5 REPLIES
Hall of Fame Super Bronze

Re: Time Base Bandwidth limit on subinterface in Cisco 3845

Modify your rate-limit commands to use an access-group.

The ACL should be created using time-based features, please refer to this document:

http://www.cisco.com/en/US/products/sw/secursw/ps1018/products_tech_note09186a00800a5b9a.shtml#timebasedtimerange

Regards,

Edison

New Member

Re: Time Base Bandwidth limit on subinterface in Cisco 3845

Dear Edison,

First of all thank you very much for early reply.

I saw the doc and i bit confuse Time based rate-limit, So can you please hlp me...

Can you pl provide exact templates if you can so I very much appreciate

I need from Monday to Friday ( 9:00 am to 20:59) 3 mb and (21:00 to 08:59) 9 mb

and also weekend (saturday 00:00 to sunday  23:59 ) 9Mb

On subinterface for one of the client.

Thanks in ADV,

Hall of Fame Super Bronze

Re: Time Base Bandwidth limit on subinterface in Cisco 3845

Sorry, I should've read your post more carefully. I missed the requirement that throughput needed to be adjusted according to the time. I believe a configuration change needs to be made during those times and time-based ACL is not the ideal solution here. You need EEM scripting for this task and I recommend asking in the Network Management forum for further assistance.

Regards,

Edison

New Member

Re: Time Base Bandwidth limit on subinterface in Cisco 3845

Dear Edition,

Thank you very much and never mind  i achived this by Time based ACL with Rate-limit.

Here is my config as  per my required.

Time-range day

Periodic weekdays 9:00 to 20:59

!

Time-range night

Periodic weekdays 21:00 to 23:59

Periodic weekdays 0:00 to 8:59

!

Time-range weekend

Periodic weekend 0:00 to 23:59

access-list 135 permit ip any any time-range day

access-list 136 permit ip any any time-range night

access-list 137 permit ip any any time-range weekend

int gi0/1.12

description *** xyz ***

encapsulation dot1q 12

ip address 10.11.12.13 255.255.255.248

rate-limit input access-group 135 1248000 234375 468750 conform-action transmitexceed-action drop

rate-limit input access-group 136 2400000 450000 900000 conform-action transmitexceed-action drop

rate-limit input access-group 137 2400000 450000 900000 conform-action transmitexceed-action drop

rate-limit output access-group 135 1248000 234375 468750 conform-action transmit exceed-action drop

rate-limit output access-group 136 2400000 450000 900000 conform-action transmit exceed-action drop

rate-limit output access-group 137 2400000 450000 900000 conform-action transmit exceed-action drop

Thanks once again!!!

Hall of Fame Super Bronze

Re: Time Base Bandwidth limit on subinterface in Cisco 3845

Good job! I couldn't test the multiple rate-limit command theory since I didn't have a router available. Thanks for the rating and reporting back w/ your solution.

Regards,

Edison

939
Views
0
Helpful
5
Replies