Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Touble pinging a TFTP Server

Having touble pinging a TFTP Server

Connect a PC using the console port to a router for the perpose of UPLOADING IOS to a  TFTP Server on my PC. I connect the PC Host to a router E0/0, I config the PC with a (static IP 192.168.1.2 subnet mask 255.255.255.0  ), and Config the router with a (static IP Address 192.168.1.1 subnet mask 255.255.255.0) Configurations below However, once i try to Ping the PC Host IP Address 192.168.1.2 ,it fails, here are the config,  can anyone distinquish what is wrong!!  I used a cross-over cable to connect the router to the PC.

The Router is a Cisco 2600 platform

Thanks!!!!!!

Computer IP Config Microsoft Windows XP

[Version 5.1.2600] (C) Copyright 1985-2001 Microsoft Corp.

Ethernet adapter Local Area Connection:       

Connection-specific DNS Suffix  . :        

Description . . . . . . . . . . . :

Intel(R) PRO/1000 MT Network Connect ion        

Physical Address. . . . . . . . . : 00-0B-DB-69-1C-0C      

Dhcp Enabled. . . . . . . . . . . : No        

IP Address. . . . . . . . . . . . : 192.168.1.2        

Subnet Mask . . . . . . . . . . . : 255.255.255.0      

Default Gateway . . . . . . . . . :

C:

============================================================================================================= Router#sh config

Using 547 out of 29688 bytes

!

version 12.3 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption

!

hostname Router

!

boot-start-marker boot-end-marker

!

!

memory-size iomem 10 no aaa new-model ip subnet-zero ip cef

!

!

!

!

! ! ! !

interface Ethernet0/0

description Router connected to Host For TFTP Server, to upload IOS

ip address 192.168.1.1 255.255.255.0

half-duplex

!

interface Serial0/0 no ip address shutdown no fair-queue

!

ip http server ip classless

!

!

!

line con 0 line aux 0 line vty 0 4 login

!

!

end Router# ============================================================================================================ Router#ping

Protocol [ip]:

Target IP address: 192.168.1.2

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]:

Sweep range of sizes [n]:

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router#

============================================================================================================ Router#sh protocol

Global values:  

Internet Protocol routing is enabled Ethernet0/0 is up, line protocol is up   I

nternet address is 192.168.1.1/24

Serial0/0 is administratively down, line protocol is down

Router#

==============================================================================================================

Router#sh ip interface

Ethernet0/0 is up, line protocol is up 

Internet address is 192.168.1.1/24  

Broadcast address is 255.255.255.255  

Address determined by setup command  

MTU is 1500 bytes  

Helper address is not set  

Directed broadcast forwarding is disabled  

Outgoing access list is not set  

Inbound  access list is not set  

Proxy ARP is enabled  

Local Proxy ARP is disabled  

Security level is default  

Split horizon is enabled  

ICMP redirects are always sent  

ICMP unreachables are always sent  

ICMP mask replies are never sent  

IP fast switching is enabled  

IP fast switching on the same interface is disabled  

IP Flow switching is disabled  

IP CEF switching is enabled 

IP CEF Fast switching turbo vector 

IP multicast fast switching is enabled  

IP multicast distributed fast switching is disabled  

IP route-cache flags are Fast, CEF  

Router Discovery is disabled  

IP output packet accounting is disabled  

IP access violation accounting is disabled  

TCP/IP header compression is disabled  

RTP/IP header compression is disabled  

Policy routing is disabled 

Network address translation is disabled 

WCCP Redirect outbound is disabled  

WCCP Redirect inbound is disabled  

WCCP Redirect exclude is disabled  

BGP Policy Mapping is disabled Serial0/0 is administratively down, line protocol is down  

Internet protocol processing disabled

Router#

======================================================================================================

Everyone's tags (5)
2 ACCEPTED SOLUTIONS

Accepted Solutions

Touble pinging a TFTP Server

hi jesse,

add the default gateway 192.168.1.1 on your PC and try again.

Silver

Touble pinging a TFTP Server

jesse rodriguez wrote:

Thank you all, for your reply however i attempt both methods and i still can't ping the PC IP Address 192.168.1.2 here are the configs

Ethernet adapter Local Area Connection: 

Connection-specific DNS Suffix  . :        

Description . . . . . . . . . . . :

Intel(R) PRO/1000 MT Network Connect ion        

Physical Address. . . . . . . . . : 00-0B-DB-69-1C-0C        

Dhcp Enabled. . . . . . . . . . . : No        

IP Address. . . . . . . . . . . . : 192.168.1.2        

Subnet Mask . . . . . . . . . . . : 255.255.255.0        

Default Gateway . . . . . . . . . : 192.168.1.1

C:\Program Files\Microsoft Visual Studio 8\VC>

============================================================================

Router#ping 192.168.1.2

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router#

===========================================================================-

I'm assuming, from the post, that it's a WindoZe machine.

Do you have the Windows firewall turned off? Or at least modified to allow PING? It blocks PING by default, especially on Windows 7 (and 2008, and XP) - which means no matter how hard you try, you're not going to be able to PING your PC interface from anywhere.

Cheers

11 REPLIES

Touble pinging a TFTP Server

hi jesse,

add the default gateway 192.168.1.1 on your PC and try again.

New Member

Touble pinging a TFTP Server

I would like to thank everyone for their advise an d input, it help me solve my problem. Thank you all!!! Tremendously, the solution was firewall and the full duplex, defualt gateway 192.168.1.1

Thank's

Jesse

Touble pinging a TFTP Server

Hi,

try to Ping the router (192.168.1.1) from the PC.

There might be a personal FW running on the PC denying the ping reply.

If not successful, check the ARP tabloe on the router by show arp command. Does it show and ARP entry fo rthe PC (

192.168.1.2)?

I'd also try to leave the duplex auto in the router port, but don't think it's the root problem.

HTH,

Milan

New Member

Touble pinging a TFTP Server

Thank you all, for your reply however i attempt both methods and i still can't ping the PC IP Address 192.168.1.2 here are the configs

Ethernet adapter Local Area Connection: 

Connection-specific DNS Suffix  . :        

Description . . . . . . . . . . . :

Intel(R) PRO/1000 MT Network Connect ion        

Physical Address. . . . . . . . . : 00-0B-DB-69-1C-0C        

Dhcp Enabled. . . . . . . . . . . : No        

IP Address. . . . . . . . . . . . : 192.168.1.2        

Subnet Mask . . . . . . . . . . . : 255.255.255.0        

Default Gateway . . . . . . . . . : 192.168.1.1

C:\Program Files\Microsoft Visual Studio 8\VC>

============================================================================

Router#ping 192.168.1.2

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router#

===========================================================================-

Router#ping 192.168.1.1

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

============================================================================

Router#sh arp

Protocol  Address      Age (min)  Hardware Addr  Type  Interface

Internet  192.168.1.1            -  0004.c051.2780  ARPA Ethernet0/0

Internet  192.168.1.2            2  000b.db69.1c0c  ARPA  Ethernet0/0

Router#

Router#

==============================================================================

Router#sh config

Using 480 out of 29688 bytes ! version 12.3 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption .

!

hostname Router

!

boot-start-marker boot-end-marker

!

!

memory-size iomem 10 no aaa new-model ip subnet-zero ip cef

!

!

!

!

! ! ! !

interface Ethernet0/0 description connection ip address 192.168.1.1 255.255.255.0 half-duplex

!

interface Serial0/0 no ip address shutdown

!

ip http server ip classless

!

!

!

line con 0 line

aux 0

line vty 0 4

!

!

end Router#

Silver

Touble pinging a TFTP Server

jesse rodriguez wrote:

Thank you all, for your reply however i attempt both methods and i still can't ping the PC IP Address 192.168.1.2 here are the configs

Ethernet adapter Local Area Connection: 

Connection-specific DNS Suffix  . :        

Description . . . . . . . . . . . :

Intel(R) PRO/1000 MT Network Connect ion        

Physical Address. . . . . . . . . : 00-0B-DB-69-1C-0C        

Dhcp Enabled. . . . . . . . . . . : No        

IP Address. . . . . . . . . . . . : 192.168.1.2        

Subnet Mask . . . . . . . . . . . : 255.255.255.0        

Default Gateway . . . . . . . . . : 192.168.1.1

C:\Program Files\Microsoft Visual Studio 8\VC>

============================================================================

Router#ping 192.168.1.2

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router#

===========================================================================-

I'm assuming, from the post, that it's a WindoZe machine.

Do you have the Windows firewall turned off? Or at least modified to allow PING? It blocks PING by default, especially on Windows 7 (and 2008, and XP) - which means no matter how hard you try, you're not going to be able to PING your PC interface from anywhere.

Cheers

Touble pinging a TFTP Server

Hi Jesse,

On the router side, do a "show interface" to check that the interface is up and the in/out packet rate. You can also use "debug ip packet" or debug icmp to see what is being received/sent. On the Windows ME side you can use Wireshark to see what was on the wire. Then, you will definetely have a clear reason of the problem.

PS: Maybe for some reason it's not responding with it's own IP address.

Hope that helps!

Vasilis

Hall of Fame Super Gold

Touble pinging a TFTP Server

One piece of good news in a previous post is that the show arp from the router does include the MAC address of the PC. So we know that the connection is good and that the devices are talking at layer 2. Milan suggested that Jesse try to ping the router from the PC and I agree that this is a good suggestion. I do not see any evidence that Jesse has done that yet.

I agree that the most likely issue is a firewall running on the PC which frequently is configured by default to deny ping to the PC. And in my experience the firewall will also frequently deny incoming requests for TFTP. So after Jesse solves the problem with ping he may have a similar problem with TFTP.

HTH

Rick

New Member

Touble pinging a TFTP Server

Hi Jesse,

Checked all the FW setting as suggested by mate.

Straight cable also works. Try this may help.

BR// SS

New Member

Touble pinging a TFTP Server

HI,

router to pc should be crossover cable.

i seen eth0/0 in half duplex, change it to full duplex and stop window FW in computer.

and then try....

New Member

Touble pinging a TFTP Server

I would like to thank everyone for their advise an d input, it help me solve my problem. Thank you all!!! Tremendously, the solution was firewall and the full duplex

Thank you all !!

New Member

Re: Touble pinging a TFTP Server

You got it...

Sent from Cisco Technical Support App

6094
Views
0
Helpful
11
Replies
CreatePlease to create content